aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2004-11-20 03:17:00 +0800
committermarkus <markus@FreeBSD.org>2004-11-20 03:17:00 +0800
commite864db764ef7ca65edc9b539b2cb0be5aa857757 (patch)
treef619e7add20b107b0826e54e18eac32e0b97b7ac /deskutils
parent46f657d69c2b0d609eec609a9a460837c217841a (diff)
downloadfreebsd-ports-gnome-e864db764ef7ca65edc9b539b2cb0be5aa857757.tar.gz
freebsd-ports-gnome-e864db764ef7ca65edc9b539b2cb0be5aa857757.tar.zst
freebsd-ports-gnome-e864db764ef7ca65edc9b539b2cb0be5aa857757.zip
Update to version 0.35
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/superkaramba/Makefile4
-rw-r--r--deskutils/superkaramba/distinfo4
-rw-r--r--deskutils/superkaramba/files/patch-configure385
-rw-r--r--deskutils/superkaramba/files/patch-misc_python.cpp12
4 files changed, 400 insertions, 5 deletions
diff --git a/deskutils/superkaramba/Makefile b/deskutils/superkaramba/Makefile
index efc450124b78..97b21a6f9ffc 100644
--- a/deskutils/superkaramba/Makefile
+++ b/deskutils/superkaramba/Makefile
@@ -5,11 +5,10 @@
# $FreeBSD$
PORTNAME= superkaramba
-PORTVERSION= 0.34
+PORTVERSION= 0.35
CATEGORIES= deskutils kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= netdragon
-DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MAINTAINER= markus@FreeBSD.org
COMMENT= KDE tool that allows interactive eye-candy on the desktop
@@ -22,7 +21,6 @@ LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS= mbmon:${PORTSDIR}/sysutils/xmbmon
.endif
-WRKSRC= ${WRKDIR}/${DISTNAME:S/-1//}
USE_KDEBASE_VER= 3
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/deskutils/superkaramba/distinfo b/deskutils/superkaramba/distinfo
index 2a72f1027b3f..d8898b188eea 100644
--- a/deskutils/superkaramba/distinfo
+++ b/deskutils/superkaramba/distinfo
@@ -1,2 +1,2 @@
-MD5 (superkaramba-0.34-1.tar.gz) = a3d981f62b8bc6aeb519706672fe3255
-SIZE (superkaramba-0.34-1.tar.gz) = 1299148
+MD5 (superkaramba-0.35.tar.gz) = c397c35fc98112f13c35cee101085dde
+SIZE (superkaramba-0.35.tar.gz) = 1363255
diff --git a/deskutils/superkaramba/files/patch-configure b/deskutils/superkaramba/files/patch-configure
new file mode 100644
index 000000000000..ac450ef85049
--- /dev/null
+++ b/deskutils/superkaramba/files/patch-configure
@@ -0,0 +1,385 @@
+--- configure.orig Fri Nov 19 19:06:13 2004
++++ configure Fri Nov 19 19:20:05 2004
+@@ -22257,7 +22257,103 @@
+ fi
+
+
+-echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
++ LIBPTHREAD=""
++
++ if test -n "$PTHREAD_LIBS"; then
++ if test "x$PTHREAD_LIBS" = "x-pthread" ; then
++ LIBPTHREAD="PTHREAD"
++ else
++ PTHREAD_LIBS_save="$PTHREAD_LIBS"
++ PTHREAD_LIBS=`echo "$PTHREAD_LIBS_save" | sed -e 's,^-l,,g'`
++ echo "$as_me:$LINENO: checking for pthread_create in $PTHREAD_LIBS" >&5
++echo $ECHO_N "checking for pthread_create in $PTHREAD_LIBS... $ECHO_C" >&6
++
++ kde_save_LDFLAGS="$LDFLAGS"
++ kde_save_LIBS="$LIBS"
++ LDFLAGS="$LDFLAGS $all_libraries"
++ case $host_os in
++ aix*) LDFLAGS="-brtl $LDFLAGS"
++ test "$GCC" = yes && LDFLAGS="-Wl,$LDFLAGS"
++ ;;
++ esac
++ as_ac_Lib=`echo "ac_cv_lib_$PTHREAD_LIBS''_pthread_create" | $as_tr_sh`
++echo "$as_me:$LINENO: checking for pthread_create in -l$PTHREAD_LIBS" >&5
++echo $ECHO_N "checking for pthread_create in -l$PTHREAD_LIBS... $ECHO_C" >&6
++if eval "test \"\${$as_ac_Lib+set}\" = set"; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-l$PTHREAD_LIBS $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char pthread_create ();
++int
++main ()
++{
++pthread_create ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ eval "$as_ac_Lib=yes"
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++eval "$as_ac_Lib=no"
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Lib'}'`" >&5
++echo "${ECHO_T}`eval echo '${'$as_ac_Lib'}'`" >&6
++if test `eval echo '${'$as_ac_Lib'}'` = yes; then
++ LIBPTHREAD="$PTHREAD_LIBS_save"
++fi
++
++ LDFLAGS="$kde_save_LDFLAGS"
++ LIBS="$kde_save_LIBS"
++
++ PTHREAD_LIBS="$PTHREAD_LIBS_save"
++ fi
++ fi
++
++ if test -z "$LIBPTHREAD"; then
++ echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
+ echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
+ if test "${ac_cv_lib_pthread_pthread_create+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+@@ -22324,6 +22420,277 @@
+ if test $ac_cv_lib_pthread_pthread_create = yes; then
+ LIBPTHREAD="-lpthread"
+ fi
++
++ fi
++
++ if test -z "$LIBPTHREAD" ; then
++ echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
++echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
++ kde_safe_libs=$LIBS
++ LIBS="$LIBS -lpthread"
++ cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++#include <pthread.h>
++int
++main ()
++{
++(void)pthread_create(0,0,0,0);
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++
++ echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6
++ LIBPTHREAD="-lpthread"
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++ LIBS=$kde_safe_libs
++ fi
++
++ if test "x$LIBPTHREAD" = "xPTHREAD" ; then
++ LIBPTHREAD=""
++ fi
++
++
++
++
++ USE_THREADS=""
++ if test -z "$LIBPTHREAD"; then
++
++echo "$as_me:$LINENO: checking whether $CXX supports -pthread" >&5
++echo $ECHO_N "checking whether $CXX supports -pthread... $ECHO_C" >&6
++kde_cache=`echo pthread | sed 'y% .=/+-,%____p__%'`
++if eval "test \"\${kde_cv_prog_cxx_$kde_cache+set}\" = set"; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++
++
++
++ ac_ext=cc
++ac_cpp='$CXXCPP $CPPFLAGS'
++ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
++ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
++ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
++
++ac_link='rm -rf SunWS_cache; ${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
++
++
++ save_CXXFLAGS="$CXXFLAGS"
++ CXXFLAGS="$CXXFLAGS -pthread"
++ cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++int
++main ()
++{
++ return 0;
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_cxx_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ eval "kde_cv_prog_cxx_$kde_cache=yes"
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++ CXXFLAGS="$save_CXXFLAGS"
++ ac_ext=c
++ac_cpp='$CPP $CPPFLAGS'
++ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
++ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
++ac_compiler_gnu=$ac_cv_c_compiler_gnu
++
++
++fi
++
++if eval "test \"`echo '$kde_cv_prog_cxx_'$kde_cache`\" = yes"; then
++ echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6
++ :
++ USE_THREADS="-D_THREAD_SAFE -pthread"
++else
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++ :
++
++fi
++
++ fi
++
++
++
++ case $host_os in
++ solaris*)
++
++echo "$as_me:$LINENO: checking whether $CXX supports -mt" >&5
++echo $ECHO_N "checking whether $CXX supports -mt... $ECHO_C" >&6
++kde_cache=`echo mt | sed 'y% .=/+-,%____p__%'`
++if eval "test \"\${kde_cv_prog_cxx_$kde_cache+set}\" = set"; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++
++
++
++ ac_ext=cc
++ac_cpp='$CXXCPP $CPPFLAGS'
++ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
++ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
++ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
++
++ac_link='rm -rf SunWS_cache; ${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
++
++
++ save_CXXFLAGS="$CXXFLAGS"
++ CXXFLAGS="$CXXFLAGS -mt"
++ cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++int
++main ()
++{
++ return 0;
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_cxx_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ eval "kde_cv_prog_cxx_$kde_cache=yes"
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++ CXXFLAGS="$save_CXXFLAGS"
++ ac_ext=c
++ac_cpp='$CPP $CPPFLAGS'
++ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
++ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
++ac_compiler_gnu=$ac_cv_c_compiler_gnu
++
++
++fi
++
++if eval "test \"`echo '$kde_cv_prog_cxx_'$kde_cache`\" = yes"; then
++ echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6
++ :
++ USE_THREADS="-mt"
++else
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++ :
++
++fi
++
++ CPPFLAGS="$CPPFLAGS -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -DUSE_SOLARIS -DSVR4"
++ ;;
++ freebsd*)
++ CPPFLAGS="$CPPFLAGS -D_THREAD_SAFE $PTHREAD_CFLAGS"
++ ;;
++ aix*)
++ CPPFLAGS="$CPPFLAGS -D_THREAD_SAFE"
++ LIBPTHREAD="$LIBPTHREAD -lc_r"
++ ;;
++ linux*) CPPFLAGS="$CPPFLAGS -D_REENTRANT"
++ if test "$CXX" = "KCC"; then
++ CXXFLAGS="$CXXFLAGS --thread_safe"
++ NOOPT_CXXFLAGS="$NOOPT_CXXFLAGS --thread_safe"
++ fi
++ ;;
++ *)
++ ;;
++ esac
+
+
+
diff --git a/deskutils/superkaramba/files/patch-misc_python.cpp b/deskutils/superkaramba/files/patch-misc_python.cpp
new file mode 100644
index 000000000000..22b3e7b8267c
--- /dev/null
+++ b/deskutils/superkaramba/files/patch-misc_python.cpp
@@ -0,0 +1,12 @@
+--- src/misc_python.cpp.orig Fri Nov 19 13:31:33 2004
++++ src/misc_python.cpp Fri Nov 19 13:37:12 2004
+@@ -380,6 +380,9 @@
+ #include <sys/ioctl.h>
+ #include <net/if.h>
+ #include <arpa/inet.h>
++#ifdef __FreeBSD__
++#include <netinet/in.h>
++#endif
+
+ /* now a method we need to expose to Python */
+ QString getIp(char *device_name)