aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2010-06-03 00:35:17 +0800
committerromain <romain@FreeBSD.org>2010-06-03 00:35:17 +0800
commit0129e55b81efdbd51657e3b313a4d9b82a6f7bc5 (patch)
tree3b582d2dede98cbeb0998e5a1bd037882a583349 /deskutils
parent3f0307e3eaaa51299a04936c09b1d70d78989dd9 (diff)
downloadfreebsd-ports-gnome-0129e55b81efdbd51657e3b313a4d9b82a6f7bc5.tar.gz
freebsd-ports-gnome-0129e55b81efdbd51657e3b313a4d9b82a6f7bc5.tar.zst
freebsd-ports-gnome-0129e55b81efdbd51657e3b313a4d9b82a6f7bc5.zip
Tomboy-Wordcount is a Tomboy plugin (or “addin”) which will count the lines,
words, and characters in a note, much like the Unix “wc” (word count) tool. WWW: http://www.proven-corporation.com/software/tomboy-wordcount/
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/tomboy-plugin-wordcount/Makefile27
-rw-r--r--deskutils/tomboy-plugin-wordcount/distinfo3
-rw-r--r--deskutils/tomboy-plugin-wordcount/pkg-descr4
4 files changed, 35 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index b2b5c6b83c4b..c7374d977c64 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -267,6 +267,7 @@
SUBDIR += tomboy-plugin-latex
SUBDIR += tomboy-plugin-reminder
SUBDIR += tomboy-plugin-todo
+ SUBDIR += tomboy-plugin-wordcount
SUBDIR += toolbox
SUBDIR += toolboxkit
SUBDIR += tpb
diff --git a/deskutils/tomboy-plugin-wordcount/Makefile b/deskutils/tomboy-plugin-wordcount/Makefile
new file mode 100644
index 000000000000..37009336dbac
--- /dev/null
+++ b/deskutils/tomboy-plugin-wordcount/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: tomboy-wordcount
+# Date created: 2008-12-23
+# Whom: Romain Tartiere <romain@blogreen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tomboy-plugin-wordcount
+PORTVERSION= 0.2
+CATEGORIES= deskutils
+MASTER_SITES= http://www.proven-corporation.com/~jhs/
+DISTNAME= tomboy-wordcount-${PORTVERSION}
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= Counts lines, words, and characters in your notes
+
+BUILD_DEPENDS= tomboy:${PORTSDIR}/deskutils/tomboy
+RUN_DEPENDS= tomboy:${PORTSDIR}/deskutils/tomboy
+
+ALL_TARGET= Wordcount.dll
+
+PLIST_FILES= lib/tomboy/addins/Wordcount.dll
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_DATA} Wordcount.dll ${PREFIX}/lib/tomboy/addins/
+
+.include <bsd.port.mk>
diff --git a/deskutils/tomboy-plugin-wordcount/distinfo b/deskutils/tomboy-plugin-wordcount/distinfo
new file mode 100644
index 000000000000..941699b68830
--- /dev/null
+++ b/deskutils/tomboy-plugin-wordcount/distinfo
@@ -0,0 +1,3 @@
+MD5 (tomboy-wordcount-0.2.tar.gz) = ce1bef60ae6e9e9bc14f9fd327b5e5bb
+SHA256 (tomboy-wordcount-0.2.tar.gz) = 562b74900ca285e3b4d8a2cc91f57e89f6c9a8027f0eb0b12b39adb670d2a14d
+SIZE (tomboy-wordcount-0.2.tar.gz) = 15432
diff --git a/deskutils/tomboy-plugin-wordcount/pkg-descr b/deskutils/tomboy-plugin-wordcount/pkg-descr
new file mode 100644
index 000000000000..14ec545badf6
--- /dev/null
+++ b/deskutils/tomboy-plugin-wordcount/pkg-descr
@@ -0,0 +1,4 @@
+Tomboy-Wordcount is a Tomboy plugin (or “addin”) which will count the lines,
+words, and characters in a note, much like the Unix “wc” (word count) tool.
+
+WWW: http://www.proven-corporation.com/software/tomboy-wordcount/