aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
committerflo <flo@FreeBSD.org>2013-05-05 06:48:03 +0800
commit02ba370ac4348e20c88c9698d4e91f3fe34868c8 (patch)
treeab399d9912d8f00891d9d8508edf96aa3ef0bc0b /deskutils
parentab79042bad4c4010d43e6983f39a47e3575126a5 (diff)
downloadfreebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.gz
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.tar.zst
freebsd-ports-gnome-02ba370ac4348e20c88c9698d4e91f3fe34868c8.zip
Fix installation of ports that rely on cp -n for installing files. r245960
changed cp to exit with a non-zero exit code if the file exists and is not overwritten thus causing ports to fail installing when e.g. trying to cp .default -> .conf files that already exist. We just ignore the error and continue, as we used to. Reported by: jaset Approved by: portmgr (bapt)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/plans/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/deskutils/plans/Makefile b/deskutils/plans/Makefile
index 37a5950c18ad..b098a976a012 100644
--- a/deskutils/plans/Makefile
+++ b/deskutils/plans/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: plans
-# Date created: 2004-12-17
-# Whom: Edwin Groothuis <edwin@mavetju.org>
-#
+# Created by: Edwin Groothuis <edwin@mavetju.org>
# $FreeBSD$
-#
PORTNAME= plans
PORTVERSION= 8.2.1
@@ -62,7 +58,7 @@ do-install:
@${FIND} ${WWWDIR} -name '*.cgi' -exec ${CHMOD} 755 {} \;
@${FIND} ${WWWDIR} -name '*.xml' -exec ${CHMOD} 664 {} \;
@for i in ${WWWDIR}/data/*default ${WWWDIR}/*default; do\
- ${CP} -np $$i $${i%.default}; done
+ ${CP} -np $$i $${i%.default} || ${TRUE} ; done
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>