aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2012-09-03 04:03:39 +0800
committernivit <nivit@FreeBSD.org>2012-09-03 04:03:39 +0800
commit03869670ba611a96325a311a3497b1682e45a8e8 (patch)
treedee817168452718716b66775d5d5a0fabdbf1221 /deskutils
parent698d9047eef561f00e432a6d774b6c0a23457c0c (diff)
downloadfreebsd-ports-gnome-03869670ba611a96325a311a3497b1682e45a8e8.tar.gz
freebsd-ports-gnome-03869670ba611a96325a311a3497b1682e45a8e8.tar.zst
freebsd-ports-gnome-03869670ba611a96325a311a3497b1682e45a8e8.zip
Growl For Linux is Linux-compatible of Growl. Growl is a notification
system for Mac OS X. WWW: http://mattn.github.com/growl-for-linux/
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/growl-for-linux/Makefile48
-rw-r--r--deskutils/growl-for-linux/distinfo2
-rw-r--r--deskutils/growl-for-linux/files/patch-configure.ac9
-rw-r--r--deskutils/growl-for-linux/pkg-descr4
-rw-r--r--deskutils/growl-for-linux/pkg-plist37
6 files changed, 101 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 8293b42d4a3b..5b53e38634df 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -82,6 +82,7 @@
SUBDIR += google-gadgets
SUBDIR += gourmet
SUBDIR += griffith
+ SUBDIR += growl-for-linux
SUBDIR += gruler
SUBDIR += gtg
SUBDIR += gtimer
diff --git a/deskutils/growl-for-linux/Makefile b/deskutils/growl-for-linux/Makefile
new file mode 100644
index 000000000000..64a439b7bdb2
--- /dev/null
+++ b/deskutils/growl-for-linux/Makefile
@@ -0,0 +1,48 @@
+# $FreeBSD$
+
+PORTNAME= growl-for-linux
+PORTVERSION= 0.6.8
+#PORTREVISION= 0
+CATEGORIES= deskutils
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Notification system compatible with Growl
+
+LICENSE= BSD
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
+ dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+
+GH_ACCOUNT= mattn
+GH_COMMIT= cab80f2
+GH_TAGNAME= master
+
+GNU_CONFIGURE= yes
+
+OPTIONS_DEFINE= LIBNOTIFY
+OPTIONS_DEFAULT= LIBNOTIFY
+LIBNOTIFY_DESC= Use notify-osd for libnotify display plugin
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MLIBNOTIFY}
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
+RUN_DEPENDS+= notify-osd>=0.9.29_3:${PORTSDIR}/deskutils/notify-osd
+.endif
+
+PLIST_SUB= DESKTOPDIR=${_DESKTOPDIR_REL}
+
+USE_AUTOTOOLS= autoconf:env automake:env libtoolize:env
+USE_GITHUB= yes
+USE_GNOME= desktopfileutils gtk20
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+USE_PKGCONFIG= build
+USE_SQLITE= 3
+
+WITH_OPENSSL_PORT= yes
+
+pre-configure:
+ @(cd ${CONFIGURE_WRKSRC} ; ${SETENV} ${CONFIGURE_ENV} ${SH} autogen.sh)
+
+.include <bsd.port.mk>
diff --git a/deskutils/growl-for-linux/distinfo b/deskutils/growl-for-linux/distinfo
new file mode 100644
index 000000000000..ef171ff1c743
--- /dev/null
+++ b/deskutils/growl-for-linux/distinfo
@@ -0,0 +1,2 @@
+SHA256 (growl-for-linux-0.6.8.tar.gz) = cd8b1b2dadb57f2beaf5fc6a5d6798b33a11fdf7177b82b0d03c4d331cc8121a
+SIZE (growl-for-linux-0.6.8.tar.gz) = 739994
diff --git a/deskutils/growl-for-linux/files/patch-configure.ac b/deskutils/growl-for-linux/files/patch-configure.ac
new file mode 100644
index 000000000000..f1250a736b26
--- /dev/null
+++ b/deskutils/growl-for-linux/files/patch-configure.ac
@@ -0,0 +1,9 @@
+--- ./configure.ac.orig 2012-09-01 14:59:36.000000000 +0200
++++ ./configure.ac 2012-09-01 15:00:01.000000000 +0200
+@@ -1,5 +1,5 @@
+ AC_PREREQ([2.65])
+-AC_INIT([growl-for-linux], [esyscmd([cat VERSION | tr -d '\n'])], [mattn.jp@gmail.com])
++AC_INIT([growl-for-linux], esyscmd([tr -d '\n' < VERSION]), [mattn.jp@gmail.com])
+ AC_CONFIG_SRCDIR([gol.c])
+ AC_CONFIG_MACRO_DIR([m4])
+
diff --git a/deskutils/growl-for-linux/pkg-descr b/deskutils/growl-for-linux/pkg-descr
new file mode 100644
index 000000000000..d52efb0527e3
--- /dev/null
+++ b/deskutils/growl-for-linux/pkg-descr
@@ -0,0 +1,4 @@
+Growl For Linux is Linux-compatible of Growl. Growl is a notification
+system for Mac OS X.
+
+WWW: http://mattn.github.com/growl-for-linux/
diff --git a/deskutils/growl-for-linux/pkg-plist b/deskutils/growl-for-linux/pkg-plist
new file mode 100644
index 000000000000..8a6322d5c8c2
--- /dev/null
+++ b/deskutils/growl-for-linux/pkg-plist
@@ -0,0 +1,37 @@
+@comment $FreeBSD$
+bin/gol
+lib/growl-for-linux/display/libballoon.a
+lib/growl-for-linux/display/libballoon.la
+lib/growl-for-linux/display/libballoon.so
+lib/growl-for-linux/display/libballoon.so.0
+lib/growl-for-linux/display/libfog.a
+lib/growl-for-linux/display/libfog.la
+lib/growl-for-linux/display/libfog.so
+lib/growl-for-linux/display/libfog.so.0
+lib/growl-for-linux/display/libnico2.a
+lib/growl-for-linux/display/libnico2.la
+lib/growl-for-linux/display/libnico2.so
+lib/growl-for-linux/display/libnico2.so.0
+lib/growl-for-linux/display/libnotify_gol.a
+lib/growl-for-linux/display/libnotify_gol.la
+lib/growl-for-linux/display/libnotify_gol.so
+lib/growl-for-linux/display/libnotify_gol.so.0
+lib/growl-for-linux/subscribe/librhythmbox.a
+lib/growl-for-linux/subscribe/librhythmbox.la
+lib/growl-for-linux/subscribe/librhythmbox.so
+lib/growl-for-linux/subscribe/librhythmbox.so.0
+lib/growl-for-linux/subscribe/libtweets.a
+lib/growl-for-linux/subscribe/libtweets.la
+lib/growl-for-linux/subscribe/libtweets.so
+lib/growl-for-linux/subscribe/libtweets.so.0
+lib/libgolplug.a
+%%DESKTOPDIR%%/gol.desktop
+%%DATADIR%%/data/growl4linux.jpg
+%%DATADIR%%/data/icon.png
+%%DATADIR%%/data/icon_dnd.png
+%%DATADIR%%/data/mattn.png
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%
+@dirrm lib/growl-for-linux/subscribe
+@dirrm lib/growl-for-linux/display
+@dirrm lib/growl-for-linux