aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-04-30 08:12:03 +0800
committersteve <steve@FreeBSD.org>2000-04-30 08:12:03 +0800
commit51527ddb1090af6e0c022c218e73313b54433b39 (patch)
treebc8cece2ed2a652e4912d1db8dc2eb1a23723e6e /deskutils
parentaf4e034382d3baac07a5e1469795ccdc069b54e9 (diff)
downloadfreebsd-ports-gnome-51527ddb1090af6e0c022c218e73313b54433b39.tar.gz
freebsd-ports-gnome-51527ddb1090af6e0c022c218e73313b54433b39.tar.zst
freebsd-ports-gnome-51527ddb1090af6e0c022c218e73313b54433b39.zip
Respect C{,XX}FLAGS.
PR: 18242 Submitted by: Mikhail Teterin <mi@aldan.algebra.com>
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/ical/files/patch-ac18
-rw-r--r--deskutils/ical/files/patch-ad10
-rw-r--r--deskutils/ical/files/patch-ae10
-rw-r--r--deskutils/ical/files/patch-af11
4 files changed, 49 insertions, 0 deletions
diff --git a/deskutils/ical/files/patch-ac b/deskutils/ical/files/patch-ac
new file mode 100644
index 000000000000..962fcb69d94e
--- /dev/null
+++ b/deskutils/ical/files/patch-ac
@@ -0,0 +1,18 @@
+--- Makefile.in.orig Sat Apr 29 15:16:02 2000
++++ Makefile.in Sat Apr 29 15:16:28 2000
+@@ -59,14 +59,11 @@
+ # Tiny bundled executable uses shared versions of tcl/tk libraries
+ TINY_BLIBS = $(LIBS)
+
+- OPTF = -O
+-
+- CXXFLAGS = $(OPTF)
+ CXXINCS = -I. -I$(srcdir) -I$(srcdir)/calendar \
+ -I$(srcdir)/types -I$(srcdir)/time \
+ $(X_CFLAGS) -I@TCL_INCDIR@ -I@TK_INCDIR@
+
+- CFLAGS = $(OPTF) -I. -I$(srcdir) $(X_CFLAGS)
++ CFLAGS += -I. -I$(srcdir) $(X_CFLAGS)
+
+ OBJS = cal_tcl.o dateeditor.o dispatch.o ical.o ical_tcl.o \
+ item_tcl.o object.o time_tcl.o @LIBOBJS@
diff --git a/deskutils/ical/files/patch-ad b/deskutils/ical/files/patch-ad
new file mode 100644
index 000000000000..8b05de5fdf0a
--- /dev/null
+++ b/deskutils/ical/files/patch-ad
@@ -0,0 +1,10 @@
+--- calendar/Makefile.in.orig Sat Apr 29 15:16:46 2000
++++ calendar/Makefile.in Sat Apr 29 15:16:54 2000
+@@ -12,7 +12,6 @@
+ AR = ar
+ ECHO = echo
+
+- CXXFLAGS = -O
+ CXXINCS = -I.. -I$(srcdir) -I$(srcdir)/../types -I$(srcdir)/../time
+
+ CXXOBJS = arrays.o calendar.o calfile.o dateset.o item.o\
diff --git a/deskutils/ical/files/patch-ae b/deskutils/ical/files/patch-ae
new file mode 100644
index 000000000000..5a03584dbdba
--- /dev/null
+++ b/deskutils/ical/files/patch-ae
@@ -0,0 +1,10 @@
+--- time/Makefile.in.orig Sat Apr 29 15:17:20 2000
++++ time/Makefile.in Sat Apr 29 15:17:25 2000
+@@ -11,7 +11,6 @@
+ ECHO = echo
+ RANLIB = @RANLIB@
+
+- CXXFLAGS = -O
+ CXXINCS = -I.. -I$(srcdir)
+ OBJS = Date.o Month.o Time.o WeekDay.o Year.o parse.o
+ TESTS = testparse
diff --git a/deskutils/ical/files/patch-af b/deskutils/ical/files/patch-af
new file mode 100644
index 000000000000..178be09f0022
--- /dev/null
+++ b/deskutils/ical/files/patch-af
@@ -0,0 +1,11 @@
+--- types/Makefile.in.orig Sat Apr 29 15:17:47 2000
++++ types/Makefile.in Sat Apr 29 15:17:56 2000
+@@ -12,7 +12,7 @@
+ ECHO = echo
+ RANLIB = @RANLIB@
+
+- CXXFLAGS = -O $(DEFS)
++ CXXFLAGS = $(DEFS)
+ CXXINCS = -I$(srcdir)
+ OBJS = bitvec.o hashfuncs.o intset.o
+ TESTS = testarray testbv testomap testoset timemap testhash testmap\