aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-05 05:46:21 +0800
committerpav <pav@FreeBSD.org>2003-12-05 05:46:21 +0800
commit66c8a240b9d83d7cd4de4d4397c5070bab75ad8d (patch)
tree7ef4cc31ff4cdb1c49ac1d8aacf93b9a83cd790c /deskutils
parent991e97ab6bf6cb2b5e0d8e8c228ba0843df2e615 (diff)
downloadfreebsd-ports-gnome-66c8a240b9d83d7cd4de4d4397c5070bab75ad8d.tar.gz
freebsd-ports-gnome-66c8a240b9d83d7cd4de4d4397c5070bab75ad8d.tar.zst
freebsd-ports-gnome-66c8a240b9d83d7cd4de4d4397c5070bab75ad8d.zip
Add Evolution plugin for Multisync, allowing to sync your calendar,
contacts and todo from your Evolution with other devices. Approved by: adamw (mentor)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/multisync-evolution/Makefile19
-rw-r--r--deskutils/multisync-evolution/files/patch-configure55
-rw-r--r--deskutils/multisync-evolution/pkg-descr5
-rw-r--r--deskutils/multisync-evolution/pkg-plist4
5 files changed, 84 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index eda8b680b753..c591bf026820 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -63,6 +63,7 @@
SUBDIR += multi-backgrounds-daemon
SUBDIR += multisync
SUBDIR += multisync-backup
+ SUBDIR += multisync-evolution
SUBDIR += nag
SUBDIR += narval
SUBDIR += notebook
diff --git a/deskutils/multisync-evolution/Makefile b/deskutils/multisync-evolution/Makefile
new file mode 100644
index 000000000000..1456d1bf7cae
--- /dev/null
+++ b/deskutils/multisync-evolution/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: multisync
+# Date created: 25 Nov 2003
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= multisync-evolution
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Evolution synchronization plugin for Multisync
+
+RUN_DEPENDS= multisync:${PORTSDIR}/deskutils/multisync \
+ evolution:${PORTSDIR}/mail/evolution
+
+MD5_FILE= ${.CURDIR}/../multisync/distinfo
+
+WRKSRC= ${WRKDIR}/multisync-${PORTVERSION}/plugins/evolution_sync
+
+.include "${.CURDIR}/../multisync/Makefile"
diff --git a/deskutils/multisync-evolution/files/patch-configure b/deskutils/multisync-evolution/files/patch-configure
new file mode 100644
index 000000000000..b850776d9974
--- /dev/null
+++ b/deskutils/multisync-evolution/files/patch-configure
@@ -0,0 +1,55 @@
+--- configure.orig Tue Nov 25 22:14:55 2003
++++ configure Tue Nov 25 22:15:20 2003
+@@ -4147,11 +4147,11 @@
+
+
+ EVO_VER=`evolution --version | sed -e 's/.nome .volution //g'`
+-EVO_MAJVER=${EVO_VER:0:1}
+-EVO_MINVER=${EVO_VER:2:1}
++EVO_MAJVER=`echo ${EVO_VER} | awk -F . '{print $1}'`
++EVO_MINVER=`echo ${EVO_VER} | awk -F . '{print $2}'`
+
+ pkg_modules="gtk+-2.0 glib libbonobo-2.0"
+-if (( EVO_MAJVER > 1 || ( EVO_MAJVER==1 && EVO_MINVER >= 4))); then
++if (( [ ${EVO_MAJVER} -gt 1 ] || ( [ ${EVO_MAJVER} = 1 ] && [ ${EVO_MINVER} -ge 4 ]))); then
+ pkg_modules="${pkgmodules} evolution-addressbook evolution-calendar libgnomeui-2.0"
+ else
+ { { echo "$as_me:$LINENO: error: This version of the Evolution plugin (and MultiSync) does only work with Evolution >= 1.4." >&5
+@@ -8917,7 +8917,7 @@
+ withval="$with_evo_libs"
+ EVO_LIB_PATH="$withval"
+ else
+- EVO_LIB_PATH="/usr/lib"
++ EVO_LIB_PATH="/usr/X11R6/lib/evolution"
+ fi;
+ # Extract the first word of "evolution", so it can be a program name with args.
+ set dummy evolution; ac_word=$2
+@@ -8962,10 +8962,10 @@
+ fi
+
+ cat >>confdefs.h <<_ACEOF
+-#define EVOLUTION_VERSION "${EVO_VER:0:5}"
++#define EVOLUTION_VERSION "${EVO_VER}"
+ _ACEOF
+
+-echo Detected evolution ${EVO_VER:0:5}.
++echo Detected evolution ${EVO_VER}.
+ EVO_LIBS=
+ EVO_DFLAGS=
+ rm -rf liblinks &> /dev/null
+@@ -8973,13 +8973,13 @@
+ for evolib in ebook camel cal-client cal-util eame eutil ical-evolution\
+ wombat ename; do
+ EVOLIB=`find ${EVO_LIB_PATH} -name "lib${evolib}.so" 2>/dev/null | sed -e 'q'`
+-if test "x${EVOLIB:0:1}" != "x/"; then
++if test "x`echo ${EVOLIB} | cut -c 1,1`" != "x/"; then
+ EVOLIB=`find ${EVO_LIB_PATH} -name "lib${evolib}.so*" 2>/dev/null | sed -e 'q'`
+ EVO_CREATE_SO="yes"
+ else
+ EVO_CREATE_SO="no"
+ fi
+-if test "x${EVOLIB:0:1}" = "x/"; then
++if test "x`echo ${EVOLIB} | cut -c 1,1`" = "x/"; then
+ echo Found ${evolib}.
+ EVOLIBDIR=`dirname ${EVOLIB}`
+ if test ${EVOLIBDIR} != "/usr/lib"; then
diff --git a/deskutils/multisync-evolution/pkg-descr b/deskutils/multisync-evolution/pkg-descr
new file mode 100644
index 000000000000..9e0886601638
--- /dev/null
+++ b/deskutils/multisync-evolution/pkg-descr
@@ -0,0 +1,5 @@
+This MultiSync plugin is:
+
+Ximian Evolution synchronization, supporting calendar, ToDos and contacts.
+
+WWW: http://multisync.sourceforge.net/
diff --git a/deskutils/multisync-evolution/pkg-plist b/deskutils/multisync-evolution/pkg-plist
new file mode 100644
index 000000000000..b0a1eff718fc
--- /dev/null
+++ b/deskutils/multisync-evolution/pkg-plist
@@ -0,0 +1,4 @@
+lib/multisync/libevolution_sync.a
+lib/multisync/libevolution_sync.so
+lib/multisync/libevolution_sync.so.0
+@unexec rmdir %D/lib/multisync 2>/dev/null || true