aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authoradridg <adridg@FreeBSD.org>2017-12-23 18:44:23 +0800
committeradridg <adridg@FreeBSD.org>2017-12-23 18:44:23 +0800
commit8aaab2f98634f774e392d192523d6a3ae3a73a58 (patch)
treef01e4cd9ef2c99decd0b26c2e6a9d905c7d10777 /deskutils
parent4a88f4bb8f71b83c7d44ba9d81d6c46ae854f776 (diff)
downloadfreebsd-ports-gnome-8aaab2f98634f774e392d192523d6a3ae3a73a58.tar.gz
freebsd-ports-gnome-8aaab2f98634f774e392d192523d6a3ae3a73a58.tar.zst
freebsd-ports-gnome-8aaab2f98634f774e392d192523d6a3ae3a73a58.zip
Update CMake to 3.10.1
- https://blog.kitware.com/cmake-3-10-1-available-for-download/ - flang support - changes to automoc policies - support for FreeBSD package generation with CPack Necessary fixes to other ports: - cad/openvsp make search for libxml explicit - math/scalapack force C compiler to be compatible with mpi - deskutils/kdepim4 fix incorrect sources list - www/qt5-webkit fix incorrect sources list Thanks to Antoine for the multiple exp-runs. PR: 223872 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13210
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/kdepim4/files/patch-kdgantt2_CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/deskutils/kdepim4/files/patch-kdgantt2_CMakeLists.txt b/deskutils/kdepim4/files/patch-kdgantt2_CMakeLists.txt
new file mode 100644
index 000000000000..1eaf823c7d75
--- /dev/null
+++ b/deskutils/kdepim4/files/patch-kdgantt2_CMakeLists.txt
@@ -0,0 +1,13 @@
+Remove files not included in the tarball from being moc'ed
+
+--- kdgantt2/CMakeLists.txt.orig 2017-10-07 07:32:16 UTC
++++ kdgantt2/CMakeLists.txt
+@@ -40,8 +40,6 @@ set(libkdgantt_mocable_files
+ kdganttproxymodel
+ kdganttsummaryhandlingproxymodel
+ kdganttview
+- kdganttlegend
+- kdgantttimescalezoomdialog
+ )
+ foreach(it ${libkdgantt_mocable_files})
+ qt4_generate_moc(${it}.h ${CMAKE_BINARY_DIR}/kdgantt2/moc_${it}.cpp)