aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2001-03-31 05:15:41 +0800
committerolgeni <olgeni@FreeBSD.org>2001-03-31 05:15:41 +0800
commit944f1ee6895ea2cb6114c47cbfd2f314e442656d (patch)
tree92f1b07907e3455d6ce5264a35e2b7ba053d8257 /deskutils
parentd5797c27f1bbd9fe051e1e5e908a7584f3d8c632 (diff)
downloadfreebsd-ports-gnome-944f1ee6895ea2cb6114c47cbfd2f314e442656d.tar.gz
freebsd-ports-gnome-944f1ee6895ea2cb6114c47cbfd2f314e442656d.tar.zst
freebsd-ports-gnome-944f1ee6895ea2cb6114c47cbfd2f314e442656d.zip
Add phpgw_projects and phpgw_inventory to RUN_DEPENDS, to get the full
phpgroupware suite. Fix permissions for phpgroupware's files directory (707 is needed to access user files). Don't complain if files directory still contains files at deinstall time.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/egroupware/Makefile6
-rw-r--r--deskutils/egroupware/pkg-plist9
-rw-r--r--deskutils/phpgroupware/Makefile6
-rw-r--r--deskutils/phpgroupware/pkg-plist9
4 files changed, 20 insertions, 10 deletions
diff --git a/deskutils/egroupware/Makefile b/deskutils/egroupware/Makefile
index 014919151558..a5010b5867b1 100644
--- a/deskutils/egroupware/Makefile
+++ b/deskutils/egroupware/Makefile
@@ -13,12 +13,14 @@ DISTNAME= phpGroupWare-${PORTVERSION}
MAINTAINER= olgeni@FreeBSD.org
-RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4 \
+ ${LOCALBASE}/www/data/phpgroupware/projects/index.php:${PORTSDIR}/deskutils/phpgw_projects \
+ ${LOCALBASE}/www/data/phpgroupware/inv/index.php:${PORTSDIR}/deskutils/phpgw_inventory
NO_BUILD= yes
WRKSRC= ${WRKDIR}/phpgroupware
do-install:
- @${CP} -r ${WRKDIR}/phpgroupware ${PREFIX}/www/data/
+ @${CP} -r ${WRKSRC} ${PREFIX}/www/data/
.include <bsd.port.mk>
diff --git a/deskutils/egroupware/pkg-plist b/deskutils/egroupware/pkg-plist
index ab45b90a1949..a3bc2311b9ab 100644
--- a/deskutils/egroupware/pkg-plist
+++ b/deskutils/egroupware/pkg-plist
@@ -787,9 +787,6 @@ www/data/phpgroupware/transy/templates/verdilak/images/navbar.gif
@dirrm www/data/phpgroupware/manual/templates
@dirrm www/data/phpgroupware/manual/inc
@dirrm www/data/phpgroupware/manual
-@dirrm www/data/phpgroupware/files/users
-@dirrm www/data/phpgroupware/files/groups
-@dirrm www/data/phpgroupware/files
@dirrm www/data/phpgroupware/filemanager/templates/default/images
@dirrm www/data/phpgroupware/filemanager/templates/default
@dirrm www/data/phpgroupware/filemanager/templates
@@ -825,4 +822,10 @@ www/data/phpgroupware/transy/templates/verdilak/images/navbar.gif
@dirrm www/data/phpgroupware/addressbook/templates
@dirrm www/data/phpgroupware/addressbook/inc
@dirrm www/data/phpgroupware/addressbook
+@exec chmod 707 %D/www/data/phpgroupware/files
+@exec chmod 707 %D/www/data/phpgroupware/files/users
+@exec chmod 707 %D/www/data/phpgroupware/files/groups
+@unexec rmdir %D/www/data/phpgroupware/files/users 2>/dev/null || true
+@unexec rmdir %D/www/data/phpgroupware/files/groups 2>/dev/null || true
+@unexec rmdir %D/www/data/phpgroupware/files 2>/dev/null || true
@unexec rmdir %D/www/data/phpgroupware 2>/dev/null || true
diff --git a/deskutils/phpgroupware/Makefile b/deskutils/phpgroupware/Makefile
index 014919151558..a5010b5867b1 100644
--- a/deskutils/phpgroupware/Makefile
+++ b/deskutils/phpgroupware/Makefile
@@ -13,12 +13,14 @@ DISTNAME= phpGroupWare-${PORTVERSION}
MAINTAINER= olgeni@FreeBSD.org
-RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4 \
+ ${LOCALBASE}/www/data/phpgroupware/projects/index.php:${PORTSDIR}/deskutils/phpgw_projects \
+ ${LOCALBASE}/www/data/phpgroupware/inv/index.php:${PORTSDIR}/deskutils/phpgw_inventory
NO_BUILD= yes
WRKSRC= ${WRKDIR}/phpgroupware
do-install:
- @${CP} -r ${WRKDIR}/phpgroupware ${PREFIX}/www/data/
+ @${CP} -r ${WRKSRC} ${PREFIX}/www/data/
.include <bsd.port.mk>
diff --git a/deskutils/phpgroupware/pkg-plist b/deskutils/phpgroupware/pkg-plist
index ab45b90a1949..a3bc2311b9ab 100644
--- a/deskutils/phpgroupware/pkg-plist
+++ b/deskutils/phpgroupware/pkg-plist
@@ -787,9 +787,6 @@ www/data/phpgroupware/transy/templates/verdilak/images/navbar.gif
@dirrm www/data/phpgroupware/manual/templates
@dirrm www/data/phpgroupware/manual/inc
@dirrm www/data/phpgroupware/manual
-@dirrm www/data/phpgroupware/files/users
-@dirrm www/data/phpgroupware/files/groups
-@dirrm www/data/phpgroupware/files
@dirrm www/data/phpgroupware/filemanager/templates/default/images
@dirrm www/data/phpgroupware/filemanager/templates/default
@dirrm www/data/phpgroupware/filemanager/templates
@@ -825,4 +822,10 @@ www/data/phpgroupware/transy/templates/verdilak/images/navbar.gif
@dirrm www/data/phpgroupware/addressbook/templates
@dirrm www/data/phpgroupware/addressbook/inc
@dirrm www/data/phpgroupware/addressbook
+@exec chmod 707 %D/www/data/phpgroupware/files
+@exec chmod 707 %D/www/data/phpgroupware/files/users
+@exec chmod 707 %D/www/data/phpgroupware/files/groups
+@unexec rmdir %D/www/data/phpgroupware/files/users 2>/dev/null || true
+@unexec rmdir %D/www/data/phpgroupware/files/groups 2>/dev/null || true
+@unexec rmdir %D/www/data/phpgroupware/files 2>/dev/null || true
@unexec rmdir %D/www/data/phpgroupware 2>/dev/null || true