aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2012-02-26 07:54:29 +0800
committereadler <eadler@FreeBSD.org>2012-02-26 07:54:29 +0800
commitf8eb28f6db17424189a14582bf0cc6ac65ca9afc (patch)
tree18e253974bceedf8c1fdd34b71644455f98f7cf5 /deskutils
parenta4ff5cbdb2c4d51ea0bdd797d010e31e63bf5391 (diff)
downloadfreebsd-ports-gnome-f8eb28f6db17424189a14582bf0cc6ac65ca9afc.tar.gz
freebsd-ports-gnome-f8eb28f6db17424189a14582bf0cc6ac65ca9afc.tar.zst
freebsd-ports-gnome-f8eb28f6db17424189a14582bf0cc6ac65ca9afc.zip
Update to 2.3.0
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/teapot/Makefile6
-rw-r--r--deskutils/teapot/distinfo8
-rw-r--r--deskutils/teapot/files/patch-CMakeLists.txt40
-rw-r--r--deskutils/teapot/pkg-plist54
4 files changed, 54 insertions, 54 deletions
diff --git a/deskutils/teapot/Makefile b/deskutils/teapot/Makefile
index 0a6ceb71cb9b..6a10e67ab0b9 100644
--- a/deskutils/teapot/Makefile
+++ b/deskutils/teapot/Makefile
@@ -6,18 +6,20 @@
#
PORTNAME= teapot
-PORTVERSION= 2.2.0
+PORTVERSION= 2.3.0
CATEGORIES= deskutils
MASTER_SITES= http://www.syntax-k.de/projekte/${PORTNAME}/ \
http://www.syntax-k.de/projekte/${PORTNAME}/:docs
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:DEFAULT \
- ${DISTNAME:C/^./T/}-Linux-x86${EXTRACT_SUFX}:docs
+ ${DISTNAME:C/^./T/}-Linux-i386${EXTRACT_SUFX}:docs
MAINTAINER= eadler@FreeBSD.org
COMMENT= Full-screen curses based spread sheet program
USE_CMAKE= yes
+MAN1= teapot.1
+
# We download the prebuilt binary tarball for Linux in order to avoid
# having to generate the pdf and html docs from the LyX sourcecode.
WRKSRC_DOCS= ${WRKDIR}/${DISTNAME:C/^./T/}-Linux/share/doc/${PORTNAME}
diff --git a/deskutils/teapot/distinfo b/deskutils/teapot/distinfo
index 35500d1a9fd7..9e6dc6168c3f 100644
--- a/deskutils/teapot/distinfo
+++ b/deskutils/teapot/distinfo
@@ -1,4 +1,4 @@
-SHA256 (teapot-2.2.0.tar.gz) = 883c6298002e0f4f27abeeb08f1c0282ae69de8f5b70619437b46ad92bb70916
-SIZE (teapot-2.2.0.tar.gz) = 113903
-SHA256 (Teapot-2.2.0-Linux-x86.tar.gz) = ba841701f50e3c6a84603db3cf2135025037a8809b58a0786ecfa68b844ce517
-SIZE (Teapot-2.2.0-Linux-x86.tar.gz) = 686141
+SHA256 (teapot-2.3.0.tar.gz) = 580e0cb416ae3fb3df87bc6e92e43bf72929d47b65ea2b50bc09acea3bff0b65
+SIZE (teapot-2.3.0.tar.gz) = 113647
+SHA256 (Teapot-2.3.0-Linux-i386.tar.gz) = 6ae8a68b401f47d62c9001575b86539d5c9534ee964b8cff381d731f14a138ab
+SIZE (Teapot-2.3.0-Linux-i386.tar.gz) = 390642
diff --git a/deskutils/teapot/files/patch-CMakeLists.txt b/deskutils/teapot/files/patch-CMakeLists.txt
index 75005c6e6925..a67cce2ffac2 100644
--- a/deskutils/teapot/files/patch-CMakeLists.txt
+++ b/deskutils/teapot/files/patch-CMakeLists.txt
@@ -1,33 +1,38 @@
---- CMakeLists.txt 2010-10-04 22:41:32.000000000 +0200
-+++ CMakeLists.txt.port 2010-11-21 23:05:26.000000000 +0100
+--- CMakeLists.txt 2012-02-06 06:30:53.000000000 -0500
++++ CMakeLists.txt 2012-02-25 18:06:26.000000000 -0500
@@ -5,7 +5,7 @@
- set(Teapot_VERSION_MINOR 2)
+ set(Teapot_VERSION_MINOR 3)
set(Teapot_VERSION_PATCH 0)
-option(ENABLE_HELP "Enable built-in documentation" ON)
+option(ENABLE_HELP "Enable built-in documentation" OFF)
option(ENABLE_UTF8 "Enable UTF-8 support" ON)
+ option(ENABLE_STATIC "Link FLTK statically" OFF)
- add_library(teapotlib context.c csv.c eval.c func.c html.c latex.c main.c misc.c parser.c sc.c scanner.c sheet.c utf8.c wk1.c xdr.c)
-@@ -36,25 +36,6 @@
+@@ -40,30 +40,6 @@
install(TARGETS teapot DESTINATION bin)
endif ()
-find_package(FLTK NO_MODULE)
-if (FLTK_FOUND)
-- include(${FLTK_USE_FILE})
+- include("${FLTK_USE_FILE}")
-
- fltk_wrap_ui(fteapot fteapot.fl)
- add_executable(fteapot WIN32 ${fteapot_FLTK_UI_SRCS})
-- set(fteapot_DEB_DEPENDS ", libstdc++6 (>= 4.1.1), libx11-6, libxinerama1")
-- if (FLTK_XFT_FOUND)
-- set(fteapot_DEB_DEPENDS "${fteapot_DEB_DEPENDS}, libfontconfig1 (>= 2.4.0), libxft2 (>> 2.1.1)")
-- endif ()
+- set(fteapot_DEB_DEPENDS ", libstdc++6 (>= 4.1.1), libfltk1.3")
- if (ENABLE_HELP)
-- set(fteapot_DEB_DEPENDS "${fteapot_DEB_DEPENDS}, libjpeg62, libpng12-0 (>= 1.2.13-4)")
-- target_link_libraries(fteapot teapotlib fltk fltk_images ${LIB_PORTABLEXDR})
+- set(fteapot_DEB_DEPENDS "${fteapot_DEB_DEPENDS}, libfltk-images1.3")
+- if (ENABLE_STATIC)
+- target_link_libraries(fteapot teapotlib fltk fltk_images ${LIB_PORTABLEXDR})
+- else ()
+- target_link_libraries(fteapot teapotlib fltk_SHARED fltk_images_SHARED ${LIB_PORTABLEXDR})
+- endif ()
- else ()
-- target_link_libraries(fteapot teapotlib fltk ${LIB_PORTABLEXDR})
+- if (ENABLE_STATIC)
+- target_link_libraries(fteapot teapotlib fltk fltk_images ${LIB_PORTABLEXDR})
+- else ()
+- target_link_libraries(fteapot teapotlib fltk_SHARED ${LIB_PORTABLEXDR})
+- endif ()
- endif ()
- install(TARGETS fteapot DESTINATION bin)
-endif ()
@@ -35,12 +40,3 @@
if (ENABLE_HELP)
add_custom_command(
OUTPUT teapot.tex teapot.lyx
-@@ -88,7 +69,7 @@
- set(HELPFILE "${CMAKE_INSTALL_PREFIX}/share/doc/teapot/html/index.html")
- endif ()
-
--install(FILES COPYING README DESTINATION share/doc/teapot)
-+#install(FILES COPYING README DESTINATION share/doc/teapot)
-
- add_custom_target(dist
- COMMAND ${CMAKE_COMMAND} -E remove_directory teapot-${Teapot_VERSION_MAJOR}.${Teapot_VERSION_MINOR}.${Teapot_VERSION_PATCH}
diff --git a/deskutils/teapot/pkg-plist b/deskutils/teapot/pkg-plist
index 41d31dfc2370..d542e700b900 100644
--- a/deskutils/teapot/pkg-plist
+++ b/deskutils/teapot/pkg-plist
@@ -2,32 +2,31 @@
bin/teapot
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/html/About_this_document.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Batch_functions.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Block_Functions.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Cell_Attributes.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Command_Mode.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Contents.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Copyright_Contributors_Lice.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Data_Types.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Differences_Between_User_In.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Expression_Grammar.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Expressions.html
-%%PORTDOCS%%%%DOCSDIR%%/html/First_Steps.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Frequently_Asked_Questions.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Functions.html
-%%PORTDOCS%%%%DOCSDIR%%/html/General_Introduction.html
-%%PORTDOCS%%%%DOCSDIR%%/html/How_do_I_hide_intermediate_.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Interactive_Functions.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Introduction_Spread_Sheets.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Line_Editor.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Operators.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Other_Functions.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Saving_Loading.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Why_is_1_0_unequal_1_0.html
-%%PORTDOCS%%%%DOCSDIR%%/html/Why_is_there_no_conditional.html
-%%PORTDOCS%%%%DOCSDIR%%/html/contents.png
-%%PORTDOCS%%%%DOCSDIR%%/html/footnode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node1.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node4.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node5.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node6.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node7.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node9.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node10.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node11.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node12.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node13.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node14.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node15.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node16.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node17.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node18.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node19.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node20.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node21.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node22.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node23.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node24.html
+%%PORTDOCS%%%%DOCSDIR%%/html/footnote.html
%%PORTDOCS%%%%DOCSDIR%%/html/img1.png
%%PORTDOCS%%%%DOCSDIR%%/html/img2.png
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
@@ -38,6 +37,9 @@ bin/teapot
%%PORTDOCS%%%%DOCSDIR%%/html/teapot.html
%%PORTDOCS%%%%DOCSDIR%%/html/up.png
%%PORTDOCS%%%%DOCSDIR%%/html/up_g.png
+%%PORTDOCS%%%%DOCSDIR%%/html/contents.png
+%%PORTDOCS%%%%DOCSDIR%%/html/footnode.html
+%%PORTDOCS%%%%DOCSDIR%%/html/footnote.png
%%PORTDOCS%%%%DOCSDIR%%/teapot.pdf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/asqrt.README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/asqrt.tp