aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-03-12 18:39:38 +0800
committermarcus <marcus@FreeBSD.org>2005-03-12 18:39:38 +0800
commit0b42143dea1a55d0f1f6d09704bbc131e1b633ed (patch)
treebc54902eb18f738e45a91362b2b0faf1ec6d04fa /deskutils
parent773c9ca4ac44ac67652d01f1e985e4df8dab5301 (diff)
downloadfreebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.tar.gz
freebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.tar.zst
freebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.zip
Presenting GNOME 2.10 for FreeBSD!
The release notes can be found at http://www.gnome.org/start/2.10/notes/rnwhatsnew.html, and will give you a good idea of what has gone into this release overall. However, a lot of FreeBSD specific additions and fixes have been made. For example, this release offers fixed ACPI support as well as new CPU freqeuncy monitoring support. See the FreeBSD GNOME 2.10 upgrade page at http://www.FreeBSD.org/gnome/docs/faq210.html for the entire list as well as a list of known issues and upgrade instructions. GNOME 2.10, as well as all of our releases, would not be possible without the great team that goes into porting and testign each and every component. Thanks definitely goes out to ahze, adamw, bland, kwm, mezz, and pav for all their work. We would also like to thank our adventurous users that chose to ride the walrus. We'd especially like to thank the following users that provided patches for GNOME 2.10: ade Yasuda Keisuke Franz Klammer Khairil Yusof Radek Kozlowsk And anyone else I may have accidentally omitted. As with GNOME 2.8, 2.10 comes with a brand-spankin' new splashscreen courtesy of Franz Klammer. However, unlike GNOME 2.8, we've included all of the FreeBSD GNOME splashscreen entries with gnomesession. You can use the deskutils/splashsetter port to choose the one you like best. As always, GNOME users should _not_ use portupgrade alone to upgrade to 2.10. Instead, get the gnome_upgrade.sh script from http://www.FreeBSD.org/gnome/gnome_upgrade.sh. Enjoy!
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/gnome-utils/Makefile18
-rw-r--r--deskutils/gnome-utils/distinfo4
-rw-r--r--deskutils/gnome-utils/files/patch-gnome-screenshot_screenshot-save.c29
-rw-r--r--deskutils/gnome-utils/files/patch-gsearchtool_gsearchtool-callbacks.c29
-rw-r--r--deskutils/gnome-utils/files/patch-gsearchtool_gsearchtool-support.c10
-rw-r--r--deskutils/gnome-utils/files/patch-logview::log_repaint.c15
-rw-r--r--deskutils/gnome-utils/files/patch-logview::logrtns.h15
-rw-r--r--deskutils/gnome-utils/files/patch-logview_desc_db.c10
-rw-r--r--deskutils/gnome-utils/files/patch-logview_logview.c24
-rw-r--r--deskutils/gnome-utils/files/patch-logview_userprefs.c10
-rw-r--r--deskutils/gnome-utils/pkg-plist24
-rw-r--r--deskutils/gnomeutils2/Makefile18
-rw-r--r--deskutils/gnomeutils2/distinfo4
-rw-r--r--deskutils/gnomeutils2/files/patch-gnome-screenshot_screenshot-save.c29
-rw-r--r--deskutils/gnomeutils2/files/patch-gsearchtool_gsearchtool-callbacks.c29
-rw-r--r--deskutils/gnomeutils2/files/patch-gsearchtool_gsearchtool-support.c10
-rw-r--r--deskutils/gnomeutils2/files/patch-logview::log_repaint.c15
-rw-r--r--deskutils/gnomeutils2/files/patch-logview::logrtns.h15
-rw-r--r--deskutils/gnomeutils2/files/patch-logview_desc_db.c10
-rw-r--r--deskutils/gnomeutils2/files/patch-logview_logview.c24
-rw-r--r--deskutils/gnomeutils2/files/patch-logview_userprefs.c10
-rw-r--r--deskutils/gnomeutils2/pkg-plist24
22 files changed, 270 insertions, 106 deletions
diff --git a/deskutils/gnome-utils/Makefile b/deskutils/gnome-utils/Makefile
index 8f118a9f5748..d6e79dff9447 100644
--- a/deskutils/gnome-utils/Makefile
+++ b/deskutils/gnome-utils/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= gnomeutils2
-PORTVERSION= 2.8.1
-PORTREVISION= 1
+PORTVERSION= 2.10.0
PORTEPOCH= 1
CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-utils/2.8
+MASTER_SITE_SUBDIR= sources/gnome-utils/2.10
DISTNAME= gnome-utils-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -24,12 +23,21 @@ INSTALLS_OMF= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomehack intlhack gnomehier gnomepanel
+USE_GNOME= gnomeprefix gnomehack intlhack gnomepanel \
+ libgnomeprintui gnomedesktop
USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= gnome-dictionary.1 gnome-search-tool.1 gnome-system-log.1
-GCONF_SCHEMAS= gdict.schemas gnome-search-tool.schemas logview.schemas
+GCONF_SCHEMAS= gdict.schemas gnome-screenshot.schemas \
+ gnome-search-tool.schemas logview.schemas
+
+post-extract:
+ @${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's| $$||g'
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH} -f
.include <bsd.port.mk>
diff --git a/deskutils/gnome-utils/distinfo b/deskutils/gnome-utils/distinfo
index a5647e87561d..1e7ee27e21cb 100644
--- a/deskutils/gnome-utils/distinfo
+++ b/deskutils/gnome-utils/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-utils-2.8.1.tar.bz2) = 048224275454781c7eebc5afd4004069
-SIZE (gnome2/gnome-utils-2.8.1.tar.bz2) = 1738576
+MD5 (gnome2/gnome-utils-2.10.0.tar.bz2) = 43644d28321645aa68428e99fadb2504
+SIZE (gnome2/gnome-utils-2.10.0.tar.bz2) = 2012166
diff --git a/deskutils/gnome-utils/files/patch-gnome-screenshot_screenshot-save.c b/deskutils/gnome-utils/files/patch-gnome-screenshot_screenshot-save.c
new file mode 100644
index 000000000000..0cc89594e169
--- /dev/null
+++ b/deskutils/gnome-utils/files/patch-gnome-screenshot_screenshot-save.c
@@ -0,0 +1,29 @@
+--- gnome-screenshot/screenshot-save.c.orig Mon Nov 1 15:56:19 2004
++++ gnome-screenshot/screenshot-save.c Fri Dec 17 23:11:51 2004
+@@ -94,16 +94,20 @@
+ gchar *message = NULL;
+ gchar *error_message = NULL;
+ GtkWidget *dialog;
++ GIOStatus status;
+
+- g_io_channel_read_line (source, &error_message, NULL, NULL, NULL);
+- message = g_strdup_printf ("Unable to save the screenshot to disk:\n\n%s", error_message);
+- dialog = gtk_message_dialog_new (NULL, 0,
++ status = g_io_channel_read_line (source, &error_message, NULL, NULL, NULL);
++ if (status == G_IO_STATUS_NORMAL)
++ {
++ message = g_strdup_printf ("Unable to save the screenshot to disk:\n\n%s", error_message);
++ dialog = gtk_message_dialog_new (NULL, 0,
+ GTK_MESSAGE_ERROR,
+ GTK_BUTTONS_OK,
+ message);
+- gtk_dialog_run (GTK_DIALOG (dialog));
+- gtk_widget_destroy (dialog);
+- exit (1);
++ gtk_dialog_run (GTK_DIALOG (dialog));
++ gtk_widget_destroy (dialog);
++ exit (1);
++ }
+ }
+
+ (*save_callback) (save_user_data);
diff --git a/deskutils/gnome-utils/files/patch-gsearchtool_gsearchtool-callbacks.c b/deskutils/gnome-utils/files/patch-gsearchtool_gsearchtool-callbacks.c
new file mode 100644
index 000000000000..325e50a3548d
--- /dev/null
+++ b/deskutils/gnome-utils/files/patch-gsearchtool_gsearchtool-callbacks.c
@@ -0,0 +1,29 @@
+--- gsearchtool/gsearchtool-callbacks.c.orig Thu Dec 23 19:14:17 2004
++++ gsearchtool/gsearchtool-callbacks.c Thu Dec 23 19:15:55 2004
+@@ -54,9 +54,11 @@
+ quit_application (GSearchCommandDetails * command_details)
+ {
+ if (command_details->command_status == RUNNING) {
+- command_details->command_status = MAKE_IT_QUIT;
+ #ifdef HAVE_GETPGID
+ pid_t pgid;
++#endif
++ command_details->command_status = MAKE_IT_QUIT;
++#ifdef HAVE_GETPGID
+
+ pgid = getpgid (command_details->command_pid);
+
+@@ -122,10 +124,12 @@
+ GSearchWindow * gsearch = data;
+
+ if (gsearch->command_details->command_status == RUNNING) {
++#ifdef HAVE_GETPGID
++ pid_t pgid;
++#endif
+ gtk_widget_set_sensitive (gsearch->stop_button, FALSE);
+ gsearch->command_details->command_status = MAKE_IT_STOP;
+ #ifdef HAVE_GETPGID
+- pid_t pgid;
+
+ pgid = getpgid (gsearch->command_details->command_pid);
+
diff --git a/deskutils/gnome-utils/files/patch-gsearchtool_gsearchtool-support.c b/deskutils/gnome-utils/files/patch-gsearchtool_gsearchtool-support.c
new file mode 100644
index 000000000000..03a974c23aa4
--- /dev/null
+++ b/deskutils/gnome-utils/files/patch-gsearchtool_gsearchtool-support.c
@@ -0,0 +1,10 @@
+--- gsearchtool/gsearchtool-support.c.orig Thu Dec 23 19:13:28 2004
++++ gsearchtool/gsearchtool-support.c Thu Dec 23 19:13:38 2004
+@@ -30,6 +30,7 @@
+ #endif
+
+ #include <glib/gi18n.h>
++#include <sys/types.h>
+ #include <regex.h>
+ #include <gdk/gdkx.h>
+ #include <bonobo-activation/bonobo-activation.h>
diff --git a/deskutils/gnome-utils/files/patch-logview::log_repaint.c b/deskutils/gnome-utils/files/patch-logview::log_repaint.c
deleted file mode 100644
index 3944b8205b12..000000000000
--- a/deskutils/gnome-utils/files/patch-logview::log_repaint.c
+++ /dev/null
@@ -1,15 +0,0 @@
-
-$FreeBSD$
-
---- logview/log_repaint.c 2001/11/23 16:01:55 1.1
-+++ logview/log_repaint.c 2001/11/23 16:02:30
-@@ -24,7 +24,9 @@
- #include <unistd.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#ifdef HAVE_MALLOC_H
- #include <malloc.h>
-+#endif
- #include <string.h>
- #include <gnome.h>
- #include "logview.h"
diff --git a/deskutils/gnome-utils/files/patch-logview::logrtns.h b/deskutils/gnome-utils/files/patch-logview::logrtns.h
deleted file mode 100644
index a39ce6a77b82..000000000000
--- a/deskutils/gnome-utils/files/patch-logview::logrtns.h
+++ /dev/null
@@ -1,15 +0,0 @@
-
-$FreeBSD$
-
---- logview/logrtns.h 2001/11/23 16:04:00 1.1
-+++ logview/logrtns.h 2001/11/23 16:04:14
-@@ -24,7 +24,9 @@
- #include <unistd.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#ifdef HAVE_MALLOC_H
- #include <malloc.h>
-+#endif
- #include <string.h>
- #include "logview.h"
-
diff --git a/deskutils/gnome-utils/files/patch-logview_desc_db.c b/deskutils/gnome-utils/files/patch-logview_desc_db.c
new file mode 100644
index 000000000000..5b687f492e88
--- /dev/null
+++ b/deskutils/gnome-utils/files/patch-logview_desc_db.c
@@ -0,0 +1,10 @@
+--- logview/desc_db.c.orig Wed Dec 1 16:45:13 2004
++++ logview/desc_db.c Wed Dec 1 16:45:25 2004
+@@ -21,6 +21,7 @@
+ #include <gtk/gtk.h>
+ #include <glib/gi18n.h>
+ #include <string.h>
++#include <sys/types.h>
+ #include <regex.h>
+ #include "logview.h"
+ #include "desc_db.h"
diff --git a/deskutils/gnome-utils/files/patch-logview_logview.c b/deskutils/gnome-utils/files/patch-logview_logview.c
index 942ed8a02d6b..4ac243d34e9a 100644
--- a/deskutils/gnome-utils/files/patch-logview_logview.c
+++ b/deskutils/gnome-utils/files/patch-logview_logview.c
@@ -1,37 +1,29 @@
---- logview/logview.c.orig Fri May 7 21:47:59 2004
-+++ logview/logview.c Wed Aug 4 18:40:24 2004
-@@ -781,7 +781,7 @@
+--- logview/logview.c.orig Tue Nov 30 00:29:01 2004
++++ logview/logview.c Tue Nov 30 00:30:44 2004
+@@ -656,7 +656,7 @@
if ( ! found) {
g_snprintf (full_name, sizeof (full_name),
- "%s/share/gnome-system-log/gnome-system-log-regexp.db", LOGVIEWINSTALLPREFIX);
-+ "%s/gnome-system-log/gnome-system-log-regexp.db", DATADIR);
++ "%s/gnome-system-log/gnome-system-log-regexp.db", LOGVIEWINSTALLPREFIX);
if (access (full_name, R_OK) == 0) {
found = TRUE;
g_free (cfg->regexp_db_path);
-@@ -804,7 +804,7 @@
+@@ -678,7 +678,7 @@
if ( ! found) {
g_snprintf (full_name, sizeof (full_name),
- "%s/share/gnome-system-log/gnome-system-log-descript.db", LOGVIEWINSTALLPREFIX);
-+ "%s/gnome-system-log/gnome-system-log-descript.db", DATADIR);
++ "%s/gnome-system-log/gnome-system-log-descript.db", LOGVIEWINSTALLPREFIX);
if (access (full_name, R_OK) == 0) {
found = TRUE;
g_free (cfg->descript_db_path);
-@@ -838,7 +838,7 @@
+@@ -709,7 +709,7 @@
if ( ! found) {
g_snprintf (full_name, sizeof (full_name),
- "%s/share/gnome-system-log/gnome-system-log-actions.db", LOGVIEWINSTALLPREFIX);
-+ "%s/gnome-system-log/gnome-system-log-actions.db", DATADIR);
++ "%s/gnome-system-log/gnome-system-log-actions.db", LOGVIEWINSTALLPREFIX);
if (access (full_name, R_OK) == 0) {
found = TRUE;
g_free (cfg->action_db_path);
-@@ -922,6 +922,7 @@
- /* remove trailing newline */
- if (logfile[strlen(logfile)-1] == '\n')
- logfile[strlen(logfile)-1] = '\0';
-+ if (strcmp (logfile, "/dev/console") == 0) continue;
- fprintf(stderr, "Found a logfile: (%s)\n", logfile);
- return logfile;
- }
diff --git a/deskutils/gnome-utils/files/patch-logview_userprefs.c b/deskutils/gnome-utils/files/patch-logview_userprefs.c
new file mode 100644
index 000000000000..d93f8ae57fc2
--- /dev/null
+++ b/deskutils/gnome-utils/files/patch-logview_userprefs.c
@@ -0,0 +1,10 @@
+--- logview/userprefs.c.orig Tue Nov 30 00:35:05 2004
++++ logview/userprefs.c Tue Nov 30 00:36:34 2004
+@@ -56,6 +56,7 @@
+ /* remove trailing newline */
+ if (logfile[strlen(logfile)-1] == '\n')
+ logfile[strlen(logfile)-1] = '\0';
++ if (strcmp (logfile, "/dev/console") == 0) continue;
+ return logfile;
+ }
+ }
diff --git a/deskutils/gnome-utils/pkg-plist b/deskutils/gnome-utils/pkg-plist
index cc90083672a7..9bb821653750 100644
--- a/deskutils/gnome-utils/pkg-plist
+++ b/deskutils/gnome-utils/pkg-plist
@@ -1,4 +1,6 @@
bin/gnome-dictionary
+bin/gnome-panel-screenshot
+bin/gnome-screenshot
bin/gnome-search-tool
bin/gnome-system-log
libdata/bonobo/servers/GNOME_GDictApplet.server
@@ -7,6 +9,7 @@ share/gnome/applications/gnome-dictionary.desktop
share/gnome/applications/gnome-search-tool.desktop
share/gnome/applications/gnome-system-log.desktop
share/gnome/gnome-2.0/ui/GNOME_GDictApplet.xml
+share/gnome/gnome-screenshot/glade/gnome-screenshot.glade
share/gnome/gnome-system-log/gnome-system-log-actions.db
share/gnome/gnome-system-log/gnome-system-log-descript.db
share/gnome/gnome-system-log/gnome-system-log-regexp.db
@@ -18,6 +21,10 @@ share/gnome/help/gnome-dictionary/ja/figures/gdict_applet.png
share/gnome/help/gnome-dictionary/ja/figures/gdict_window.png
share/gnome/help/gnome-dictionary/ja/gnome-dictionary.xml
share/gnome/help/gnome-dictionary/ja/legal.xml
+share/gnome/help/gnome-dictionary/uk/figures/gdict_applet.png
+share/gnome/help/gnome-dictionary/uk/figures/gdict_window.png
+share/gnome/help/gnome-dictionary/uk/gnome-dictionary.xml
+share/gnome/help/gnome-dictionary/uk/legal.xml
share/gnome/help/gnome-search-tool/C/figures/gnome-search-tool_window.png
share/gnome/help/gnome-search-tool/C/gnome-search-tool.xml
share/gnome/help/gnome-search-tool/C/legal.xml
@@ -39,6 +46,9 @@ share/gnome/help/gnome-search-tool/ko/legal.xml
share/gnome/help/gnome-search-tool/sv/figures/gnome-search-tool_window.png
share/gnome/help/gnome-search-tool/sv/gnome-search-tool.xml
share/gnome/help/gnome-search-tool/sv/legal.xml
+share/gnome/help/gnome-search-tool/uk/figures/gnome-search-tool_window.png
+share/gnome/help/gnome-search-tool/uk/gnome-search-tool.xml
+share/gnome/help/gnome-search-tool/uk/legal.xml
share/gnome/help/gnome-search-tool/zh_CN/figures/gnome-search-tool_window.png
share/gnome/help/gnome-search-tool/zh_CN/gnome-search-tool.xml
share/gnome/help/gnome-search-tool/zh_CN/legal.xml
@@ -72,6 +82,9 @@ share/gnome/help/gnome-system-log/ko/legal.xml
share/gnome/help/gnome-system-log/sv/figures/syslog_window.png
share/gnome/help/gnome-system-log/sv/gnome-system-log.xml
share/gnome/help/gnome-system-log/sv/legal.xml
+share/gnome/help/gnome-system-log/uk/figures/syslog_window.png
+share/gnome/help/gnome-system-log/uk/gnome-system-log.xml
+share/gnome/help/gnome-system-log/uk/legal.xml
share/gnome/help/gnome-system-log/zh_CN/figures/syslog_window.png
share/gnome/help/gnome-system-log/zh_CN/gnome-system-log.xml
share/gnome/help/gnome-system-log/zh_CN/legal.xml
@@ -80,6 +93,7 @@ share/gnome/help/gnome-system-log/zh_TW/gnome-system-log.xml
share/gnome/help/gnome-system-log/zh_TW/legal.xml
share/gnome/omf/gnome-utils/gnome-dictionary-C.omf
share/gnome/omf/gnome-utils/gnome-dictionary-ja.omf
+share/gnome/omf/gnome-utils/gnome-dictionary-uk.omf
share/gnome/omf/gnome-utils/gnome-search-tool-C.omf
share/gnome/omf/gnome-utils/gnome-search-tool-es.omf
share/gnome/omf/gnome-utils/gnome-search-tool-fr.omf
@@ -87,6 +101,7 @@ share/gnome/omf/gnome-utils/gnome-search-tool-it.omf
share/gnome/omf/gnome-utils/gnome-search-tool-ja.omf
share/gnome/omf/gnome-utils/gnome-search-tool-ko.omf
share/gnome/omf/gnome-utils/gnome-search-tool-sv.omf
+share/gnome/omf/gnome-utils/gnome-search-tool-uk.omf
share/gnome/omf/gnome-utils/gnome-search-tool-zh_CN.omf
share/gnome/omf/gnome-utils/gnome-search-tool-zh_HK.omf
share/gnome/omf/gnome-utils/gnome-search-tool-zh_TW.omf
@@ -98,6 +113,7 @@ share/gnome/omf/gnome-utils/gnome-system-log-it.omf
share/gnome/omf/gnome-utils/gnome-system-log-ja.omf
share/gnome/omf/gnome-utils/gnome-system-log-ko.omf
share/gnome/omf/gnome-utils/gnome-system-log-sv.omf
+share/gnome/omf/gnome-utils/gnome-system-log-uk.omf
share/gnome/omf/gnome-utils/gnome-system-log-zh_CN.omf
share/gnome/omf/gnome-utils/gnome-system-log-zh_TW.omf
share/locale/am/LC_MESSAGES/gnome-utils-2.0.mo
@@ -168,6 +184,8 @@ share/locale/zh_TW/LC_MESSAGES/gnome-utils-2.0.mo
@dirrm share/gnome/help/gnome-system-log/zh_TW
@dirrm share/gnome/help/gnome-system-log/zh_CN/figures
@dirrm share/gnome/help/gnome-system-log/zh_CN
+@dirrm share/gnome/help/gnome-system-log/uk/figures
+@dirrm share/gnome/help/gnome-system-log/uk
@dirrm share/gnome/help/gnome-system-log/sv/figures
@dirrm share/gnome/help/gnome-system-log/sv
@dirrm share/gnome/help/gnome-system-log/ko/figures
@@ -191,6 +209,8 @@ share/locale/zh_TW/LC_MESSAGES/gnome-utils-2.0.mo
@dirrm share/gnome/help/gnome-search-tool/zh_HK
@dirrm share/gnome/help/gnome-search-tool/zh_CN/figures
@dirrm share/gnome/help/gnome-search-tool/zh_CN
+@dirrm share/gnome/help/gnome-search-tool/uk/figures
+@dirrm share/gnome/help/gnome-search-tool/uk
@dirrm share/gnome/help/gnome-search-tool/sv/figures
@dirrm share/gnome/help/gnome-search-tool/sv
@dirrm share/gnome/help/gnome-search-tool/ko/figures
@@ -206,9 +226,13 @@ share/locale/zh_TW/LC_MESSAGES/gnome-utils-2.0.mo
@dirrm share/gnome/help/gnome-search-tool/C/figures
@dirrm share/gnome/help/gnome-search-tool/C
@dirrm share/gnome/help/gnome-search-tool
+@dirrm share/gnome/help/gnome-dictionary/uk/figures
+@dirrm share/gnome/help/gnome-dictionary/uk
@dirrm share/gnome/help/gnome-dictionary/ja/figures
@dirrm share/gnome/help/gnome-dictionary/ja
@dirrm share/gnome/help/gnome-dictionary/C/figures
@dirrm share/gnome/help/gnome-dictionary/C
@dirrm share/gnome/help/gnome-dictionary
@dirrm share/gnome/gnome-system-log
+@dirrm share/gnome/gnome-screenshot/glade
+@dirrm share/gnome/gnome-screenshot
diff --git a/deskutils/gnomeutils2/Makefile b/deskutils/gnomeutils2/Makefile
index 8f118a9f5748..d6e79dff9447 100644
--- a/deskutils/gnomeutils2/Makefile
+++ b/deskutils/gnomeutils2/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= gnomeutils2
-PORTVERSION= 2.8.1
-PORTREVISION= 1
+PORTVERSION= 2.10.0
PORTEPOCH= 1
CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-utils/2.8
+MASTER_SITE_SUBDIR= sources/gnome-utils/2.10
DISTNAME= gnome-utils-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -24,12 +23,21 @@ INSTALLS_OMF= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomehack intlhack gnomehier gnomepanel
+USE_GNOME= gnomeprefix gnomehack intlhack gnomepanel \
+ libgnomeprintui gnomedesktop
USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= gnome-dictionary.1 gnome-search-tool.1 gnome-system-log.1
-GCONF_SCHEMAS= gdict.schemas gnome-search-tool.schemas logview.schemas
+GCONF_SCHEMAS= gdict.schemas gnome-screenshot.schemas \
+ gnome-search-tool.schemas logview.schemas
+
+post-extract:
+ @${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's| $$||g'
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH} -f
.include <bsd.port.mk>
diff --git a/deskutils/gnomeutils2/distinfo b/deskutils/gnomeutils2/distinfo
index a5647e87561d..1e7ee27e21cb 100644
--- a/deskutils/gnomeutils2/distinfo
+++ b/deskutils/gnomeutils2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-utils-2.8.1.tar.bz2) = 048224275454781c7eebc5afd4004069
-SIZE (gnome2/gnome-utils-2.8.1.tar.bz2) = 1738576
+MD5 (gnome2/gnome-utils-2.10.0.tar.bz2) = 43644d28321645aa68428e99fadb2504
+SIZE (gnome2/gnome-utils-2.10.0.tar.bz2) = 2012166
diff --git a/deskutils/gnomeutils2/files/patch-gnome-screenshot_screenshot-save.c b/deskutils/gnomeutils2/files/patch-gnome-screenshot_screenshot-save.c
new file mode 100644
index 000000000000..0cc89594e169
--- /dev/null
+++ b/deskutils/gnomeutils2/files/patch-gnome-screenshot_screenshot-save.c
@@ -0,0 +1,29 @@
+--- gnome-screenshot/screenshot-save.c.orig Mon Nov 1 15:56:19 2004
++++ gnome-screenshot/screenshot-save.c Fri Dec 17 23:11:51 2004
+@@ -94,16 +94,20 @@
+ gchar *message = NULL;
+ gchar *error_message = NULL;
+ GtkWidget *dialog;
++ GIOStatus status;
+
+- g_io_channel_read_line (source, &error_message, NULL, NULL, NULL);
+- message = g_strdup_printf ("Unable to save the screenshot to disk:\n\n%s", error_message);
+- dialog = gtk_message_dialog_new (NULL, 0,
++ status = g_io_channel_read_line (source, &error_message, NULL, NULL, NULL);
++ if (status == G_IO_STATUS_NORMAL)
++ {
++ message = g_strdup_printf ("Unable to save the screenshot to disk:\n\n%s", error_message);
++ dialog = gtk_message_dialog_new (NULL, 0,
+ GTK_MESSAGE_ERROR,
+ GTK_BUTTONS_OK,
+ message);
+- gtk_dialog_run (GTK_DIALOG (dialog));
+- gtk_widget_destroy (dialog);
+- exit (1);
++ gtk_dialog_run (GTK_DIALOG (dialog));
++ gtk_widget_destroy (dialog);
++ exit (1);
++ }
+ }
+
+ (*save_callback) (save_user_data);
diff --git a/deskutils/gnomeutils2/files/patch-gsearchtool_gsearchtool-callbacks.c b/deskutils/gnomeutils2/files/patch-gsearchtool_gsearchtool-callbacks.c
new file mode 100644
index 000000000000..325e50a3548d
--- /dev/null
+++ b/deskutils/gnomeutils2/files/patch-gsearchtool_gsearchtool-callbacks.c
@@ -0,0 +1,29 @@
+--- gsearchtool/gsearchtool-callbacks.c.orig Thu Dec 23 19:14:17 2004
++++ gsearchtool/gsearchtool-callbacks.c Thu Dec 23 19:15:55 2004
+@@ -54,9 +54,11 @@
+ quit_application (GSearchCommandDetails * command_details)
+ {
+ if (command_details->command_status == RUNNING) {
+- command_details->command_status = MAKE_IT_QUIT;
+ #ifdef HAVE_GETPGID
+ pid_t pgid;
++#endif
++ command_details->command_status = MAKE_IT_QUIT;
++#ifdef HAVE_GETPGID
+
+ pgid = getpgid (command_details->command_pid);
+
+@@ -122,10 +124,12 @@
+ GSearchWindow * gsearch = data;
+
+ if (gsearch->command_details->command_status == RUNNING) {
++#ifdef HAVE_GETPGID
++ pid_t pgid;
++#endif
+ gtk_widget_set_sensitive (gsearch->stop_button, FALSE);
+ gsearch->command_details->command_status = MAKE_IT_STOP;
+ #ifdef HAVE_GETPGID
+- pid_t pgid;
+
+ pgid = getpgid (gsearch->command_details->command_pid);
+
diff --git a/deskutils/gnomeutils2/files/patch-gsearchtool_gsearchtool-support.c b/deskutils/gnomeutils2/files/patch-gsearchtool_gsearchtool-support.c
new file mode 100644
index 000000000000..03a974c23aa4
--- /dev/null
+++ b/deskutils/gnomeutils2/files/patch-gsearchtool_gsearchtool-support.c
@@ -0,0 +1,10 @@
+--- gsearchtool/gsearchtool-support.c.orig Thu Dec 23 19:13:28 2004
++++ gsearchtool/gsearchtool-support.c Thu Dec 23 19:13:38 2004
+@@ -30,6 +30,7 @@
+ #endif
+
+ #include <glib/gi18n.h>
++#include <sys/types.h>
+ #include <regex.h>
+ #include <gdk/gdkx.h>
+ #include <bonobo-activation/bonobo-activation.h>
diff --git a/deskutils/gnomeutils2/files/patch-logview::log_repaint.c b/deskutils/gnomeutils2/files/patch-logview::log_repaint.c
deleted file mode 100644
index 3944b8205b12..000000000000
--- a/deskutils/gnomeutils2/files/patch-logview::log_repaint.c
+++ /dev/null
@@ -1,15 +0,0 @@
-
-$FreeBSD$
-
---- logview/log_repaint.c 2001/11/23 16:01:55 1.1
-+++ logview/log_repaint.c 2001/11/23 16:02:30
-@@ -24,7 +24,9 @@
- #include <unistd.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#ifdef HAVE_MALLOC_H
- #include <malloc.h>
-+#endif
- #include <string.h>
- #include <gnome.h>
- #include "logview.h"
diff --git a/deskutils/gnomeutils2/files/patch-logview::logrtns.h b/deskutils/gnomeutils2/files/patch-logview::logrtns.h
deleted file mode 100644
index a39ce6a77b82..000000000000
--- a/deskutils/gnomeutils2/files/patch-logview::logrtns.h
+++ /dev/null
@@ -1,15 +0,0 @@
-
-$FreeBSD$
-
---- logview/logrtns.h 2001/11/23 16:04:00 1.1
-+++ logview/logrtns.h 2001/11/23 16:04:14
-@@ -24,7 +24,9 @@
- #include <unistd.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#ifdef HAVE_MALLOC_H
- #include <malloc.h>
-+#endif
- #include <string.h>
- #include "logview.h"
-
diff --git a/deskutils/gnomeutils2/files/patch-logview_desc_db.c b/deskutils/gnomeutils2/files/patch-logview_desc_db.c
new file mode 100644
index 000000000000..5b687f492e88
--- /dev/null
+++ b/deskutils/gnomeutils2/files/patch-logview_desc_db.c
@@ -0,0 +1,10 @@
+--- logview/desc_db.c.orig Wed Dec 1 16:45:13 2004
++++ logview/desc_db.c Wed Dec 1 16:45:25 2004
+@@ -21,6 +21,7 @@
+ #include <gtk/gtk.h>
+ #include <glib/gi18n.h>
+ #include <string.h>
++#include <sys/types.h>
+ #include <regex.h>
+ #include "logview.h"
+ #include "desc_db.h"
diff --git a/deskutils/gnomeutils2/files/patch-logview_logview.c b/deskutils/gnomeutils2/files/patch-logview_logview.c
index 942ed8a02d6b..4ac243d34e9a 100644
--- a/deskutils/gnomeutils2/files/patch-logview_logview.c
+++ b/deskutils/gnomeutils2/files/patch-logview_logview.c
@@ -1,37 +1,29 @@
---- logview/logview.c.orig Fri May 7 21:47:59 2004
-+++ logview/logview.c Wed Aug 4 18:40:24 2004
-@@ -781,7 +781,7 @@
+--- logview/logview.c.orig Tue Nov 30 00:29:01 2004
++++ logview/logview.c Tue Nov 30 00:30:44 2004
+@@ -656,7 +656,7 @@
if ( ! found) {
g_snprintf (full_name, sizeof (full_name),
- "%s/share/gnome-system-log/gnome-system-log-regexp.db", LOGVIEWINSTALLPREFIX);
-+ "%s/gnome-system-log/gnome-system-log-regexp.db", DATADIR);
++ "%s/gnome-system-log/gnome-system-log-regexp.db", LOGVIEWINSTALLPREFIX);
if (access (full_name, R_OK) == 0) {
found = TRUE;
g_free (cfg->regexp_db_path);
-@@ -804,7 +804,7 @@
+@@ -678,7 +678,7 @@
if ( ! found) {
g_snprintf (full_name, sizeof (full_name),
- "%s/share/gnome-system-log/gnome-system-log-descript.db", LOGVIEWINSTALLPREFIX);
-+ "%s/gnome-system-log/gnome-system-log-descript.db", DATADIR);
++ "%s/gnome-system-log/gnome-system-log-descript.db", LOGVIEWINSTALLPREFIX);
if (access (full_name, R_OK) == 0) {
found = TRUE;
g_free (cfg->descript_db_path);
-@@ -838,7 +838,7 @@
+@@ -709,7 +709,7 @@
if ( ! found) {
g_snprintf (full_name, sizeof (full_name),
- "%s/share/gnome-system-log/gnome-system-log-actions.db", LOGVIEWINSTALLPREFIX);
-+ "%s/gnome-system-log/gnome-system-log-actions.db", DATADIR);
++ "%s/gnome-system-log/gnome-system-log-actions.db", LOGVIEWINSTALLPREFIX);
if (access (full_name, R_OK) == 0) {
found = TRUE;
g_free (cfg->action_db_path);
-@@ -922,6 +922,7 @@
- /* remove trailing newline */
- if (logfile[strlen(logfile)-1] == '\n')
- logfile[strlen(logfile)-1] = '\0';
-+ if (strcmp (logfile, "/dev/console") == 0) continue;
- fprintf(stderr, "Found a logfile: (%s)\n", logfile);
- return logfile;
- }
diff --git a/deskutils/gnomeutils2/files/patch-logview_userprefs.c b/deskutils/gnomeutils2/files/patch-logview_userprefs.c
new file mode 100644
index 000000000000..d93f8ae57fc2
--- /dev/null
+++ b/deskutils/gnomeutils2/files/patch-logview_userprefs.c
@@ -0,0 +1,10 @@
+--- logview/userprefs.c.orig Tue Nov 30 00:35:05 2004
++++ logview/userprefs.c Tue Nov 30 00:36:34 2004
+@@ -56,6 +56,7 @@
+ /* remove trailing newline */
+ if (logfile[strlen(logfile)-1] == '\n')
+ logfile[strlen(logfile)-1] = '\0';
++ if (strcmp (logfile, "/dev/console") == 0) continue;
+ return logfile;
+ }
+ }
diff --git a/deskutils/gnomeutils2/pkg-plist b/deskutils/gnomeutils2/pkg-plist
index cc90083672a7..9bb821653750 100644
--- a/deskutils/gnomeutils2/pkg-plist
+++ b/deskutils/gnomeutils2/pkg-plist
@@ -1,4 +1,6 @@
bin/gnome-dictionary
+bin/gnome-panel-screenshot
+bin/gnome-screenshot
bin/gnome-search-tool
bin/gnome-system-log
libdata/bonobo/servers/GNOME_GDictApplet.server
@@ -7,6 +9,7 @@ share/gnome/applications/gnome-dictionary.desktop
share/gnome/applications/gnome-search-tool.desktop
share/gnome/applications/gnome-system-log.desktop
share/gnome/gnome-2.0/ui/GNOME_GDictApplet.xml
+share/gnome/gnome-screenshot/glade/gnome-screenshot.glade
share/gnome/gnome-system-log/gnome-system-log-actions.db
share/gnome/gnome-system-log/gnome-system-log-descript.db
share/gnome/gnome-system-log/gnome-system-log-regexp.db
@@ -18,6 +21,10 @@ share/gnome/help/gnome-dictionary/ja/figures/gdict_applet.png
share/gnome/help/gnome-dictionary/ja/figures/gdict_window.png
share/gnome/help/gnome-dictionary/ja/gnome-dictionary.xml
share/gnome/help/gnome-dictionary/ja/legal.xml
+share/gnome/help/gnome-dictionary/uk/figures/gdict_applet.png
+share/gnome/help/gnome-dictionary/uk/figures/gdict_window.png
+share/gnome/help/gnome-dictionary/uk/gnome-dictionary.xml
+share/gnome/help/gnome-dictionary/uk/legal.xml
share/gnome/help/gnome-search-tool/C/figures/gnome-search-tool_window.png
share/gnome/help/gnome-search-tool/C/gnome-search-tool.xml
share/gnome/help/gnome-search-tool/C/legal.xml
@@ -39,6 +46,9 @@ share/gnome/help/gnome-search-tool/ko/legal.xml
share/gnome/help/gnome-search-tool/sv/figures/gnome-search-tool_window.png
share/gnome/help/gnome-search-tool/sv/gnome-search-tool.xml
share/gnome/help/gnome-search-tool/sv/legal.xml
+share/gnome/help/gnome-search-tool/uk/figures/gnome-search-tool_window.png
+share/gnome/help/gnome-search-tool/uk/gnome-search-tool.xml
+share/gnome/help/gnome-search-tool/uk/legal.xml
share/gnome/help/gnome-search-tool/zh_CN/figures/gnome-search-tool_window.png
share/gnome/help/gnome-search-tool/zh_CN/gnome-search-tool.xml
share/gnome/help/gnome-search-tool/zh_CN/legal.xml
@@ -72,6 +82,9 @@ share/gnome/help/gnome-system-log/ko/legal.xml
share/gnome/help/gnome-system-log/sv/figures/syslog_window.png
share/gnome/help/gnome-system-log/sv/gnome-system-log.xml
share/gnome/help/gnome-system-log/sv/legal.xml
+share/gnome/help/gnome-system-log/uk/figures/syslog_window.png
+share/gnome/help/gnome-system-log/uk/gnome-system-log.xml
+share/gnome/help/gnome-system-log/uk/legal.xml
share/gnome/help/gnome-system-log/zh_CN/figures/syslog_window.png
share/gnome/help/gnome-system-log/zh_CN/gnome-system-log.xml
share/gnome/help/gnome-system-log/zh_CN/legal.xml
@@ -80,6 +93,7 @@ share/gnome/help/gnome-system-log/zh_TW/gnome-system-log.xml
share/gnome/help/gnome-system-log/zh_TW/legal.xml
share/gnome/omf/gnome-utils/gnome-dictionary-C.omf
share/gnome/omf/gnome-utils/gnome-dictionary-ja.omf
+share/gnome/omf/gnome-utils/gnome-dictionary-uk.omf
share/gnome/omf/gnome-utils/gnome-search-tool-C.omf
share/gnome/omf/gnome-utils/gnome-search-tool-es.omf
share/gnome/omf/gnome-utils/gnome-search-tool-fr.omf
@@ -87,6 +101,7 @@ share/gnome/omf/gnome-utils/gnome-search-tool-it.omf
share/gnome/omf/gnome-utils/gnome-search-tool-ja.omf
share/gnome/omf/gnome-utils/gnome-search-tool-ko.omf
share/gnome/omf/gnome-utils/gnome-search-tool-sv.omf
+share/gnome/omf/gnome-utils/gnome-search-tool-uk.omf
share/gnome/omf/gnome-utils/gnome-search-tool-zh_CN.omf
share/gnome/omf/gnome-utils/gnome-search-tool-zh_HK.omf
share/gnome/omf/gnome-utils/gnome-search-tool-zh_TW.omf
@@ -98,6 +113,7 @@ share/gnome/omf/gnome-utils/gnome-system-log-it.omf
share/gnome/omf/gnome-utils/gnome-system-log-ja.omf
share/gnome/omf/gnome-utils/gnome-system-log-ko.omf
share/gnome/omf/gnome-utils/gnome-system-log-sv.omf
+share/gnome/omf/gnome-utils/gnome-system-log-uk.omf
share/gnome/omf/gnome-utils/gnome-system-log-zh_CN.omf
share/gnome/omf/gnome-utils/gnome-system-log-zh_TW.omf
share/locale/am/LC_MESSAGES/gnome-utils-2.0.mo
@@ -168,6 +184,8 @@ share/locale/zh_TW/LC_MESSAGES/gnome-utils-2.0.mo
@dirrm share/gnome/help/gnome-system-log/zh_TW
@dirrm share/gnome/help/gnome-system-log/zh_CN/figures
@dirrm share/gnome/help/gnome-system-log/zh_CN
+@dirrm share/gnome/help/gnome-system-log/uk/figures
+@dirrm share/gnome/help/gnome-system-log/uk
@dirrm share/gnome/help/gnome-system-log/sv/figures
@dirrm share/gnome/help/gnome-system-log/sv
@dirrm share/gnome/help/gnome-system-log/ko/figures
@@ -191,6 +209,8 @@ share/locale/zh_TW/LC_MESSAGES/gnome-utils-2.0.mo
@dirrm share/gnome/help/gnome-search-tool/zh_HK
@dirrm share/gnome/help/gnome-search-tool/zh_CN/figures
@dirrm share/gnome/help/gnome-search-tool/zh_CN
+@dirrm share/gnome/help/gnome-search-tool/uk/figures
+@dirrm share/gnome/help/gnome-search-tool/uk
@dirrm share/gnome/help/gnome-search-tool/sv/figures
@dirrm share/gnome/help/gnome-search-tool/sv
@dirrm share/gnome/help/gnome-search-tool/ko/figures
@@ -206,9 +226,13 @@ share/locale/zh_TW/LC_MESSAGES/gnome-utils-2.0.mo
@dirrm share/gnome/help/gnome-search-tool/C/figures
@dirrm share/gnome/help/gnome-search-tool/C
@dirrm share/gnome/help/gnome-search-tool
+@dirrm share/gnome/help/gnome-dictionary/uk/figures
+@dirrm share/gnome/help/gnome-dictionary/uk
@dirrm share/gnome/help/gnome-dictionary/ja/figures
@dirrm share/gnome/help/gnome-dictionary/ja
@dirrm share/gnome/help/gnome-dictionary/C/figures
@dirrm share/gnome/help/gnome-dictionary/C
@dirrm share/gnome/help/gnome-dictionary
@dirrm share/gnome/gnome-system-log
+@dirrm share/gnome/gnome-screenshot/glade
+@dirrm share/gnome/gnome-screenshot