aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-11-20 02:01:23 +0800
committerdinoex <dinoex@FreeBSD.org>2006-11-20 02:01:23 +0800
commit0ebc27ae944f701f7f6132c15908f713eeed766b (patch)
tree4528888e211b8cccb3077b9264bd87161d481495 /deskutils
parent5dbef221ddaf1d52bd9bcd3a866dbf41b104e8f8 (diff)
downloadfreebsd-ports-gnome-0ebc27ae944f701f7f6132c15908f713eeed766b.tar.gz
freebsd-ports-gnome-0ebc27ae944f701f7f6132c15908f713eeed766b.tar.zst
freebsd-ports-gnome-0ebc27ae944f701f7f6132c15908f713eeed766b.zip
Etoile intends to be an innovative GNUstep based user environnement built
from the ground up on highly modular and light components with project and document orientation in mind, in order to allow users to create their own workflow by reshaping or recombining provided Services (aka Applications), Components etc. Flexibility and modularity on both User Interface and code level should allow us to scale from PDA to computer environment. This package installs the EtoileExtensionsKit framework. WWW: http://www.etoile-project.org/
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/etoile-etoileextensionskit/Makefile30
-rw-r--r--deskutils/etoile-etoileextensionskit/distinfo3
-rw-r--r--deskutils/etoile-etoileextensionskit/pkg-descr10
-rw-r--r--deskutils/etoile-etoileextensionskit/pkg-plist18
5 files changed, 62 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 6a2cc9c96c19..1e7f1eda01eb 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -38,6 +38,7 @@
SUBDIR += estickies
SUBDIR += etask
SUBDIR += etoile
+ SUBDIR += etoile-etoileextensionskit
SUBDIR += etoile-extendedworkspacekit
SUBDIR += etoile-preferenceskit
SUBDIR += etoile-trackerkit
diff --git a/deskutils/etoile-etoileextensionskit/Makefile b/deskutils/etoile-etoileextensionskit/Makefile
new file mode 100644
index 000000000000..a970bf0f86f7
--- /dev/null
+++ b/deskutils/etoile-etoileextensionskit/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: etoile-etoileextensionskit
+# Date created: 18 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= etoileextensionskit
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= deskutils
+MASTER_SITES= http://florida.ethz.ch/ports/distfiles/
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile_0+${SNAPSHOT}+dfsg.orig
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project EtoileExtensionsKit framework
+
+SNAPSHOT= 20060917
+WRKSRC= ${WRKDIR}/etoile-0+${SNAPSHOT}+dfsg/Etoile/
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE= GNUmakefile
+NO_FILTER_SHLIBS= yes
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/EtoileExtensionsKit
+
+.include <bsd.port.mk>
diff --git a/deskutils/etoile-etoileextensionskit/distinfo b/deskutils/etoile-etoileextensionskit/distinfo
new file mode 100644
index 000000000000..2d5c7ccf5d13
--- /dev/null
+++ b/deskutils/etoile-etoileextensionskit/distinfo
@@ -0,0 +1,3 @@
+MD5 (etoile_0+20060917+dfsg.orig.tar.gz) = bc96dcaba7ac66abb1320d5cfc98f05e
+SHA256 (etoile_0+20060917+dfsg.orig.tar.gz) = de7cb026ccebdbb72d115ca800a13910cd51c9df27f5578ad7059b13f88eb334
+SIZE (etoile_0+20060917+dfsg.orig.tar.gz) = 10478850
diff --git a/deskutils/etoile-etoileextensionskit/pkg-descr b/deskutils/etoile-etoileextensionskit/pkg-descr
new file mode 100644
index 000000000000..95ccf635016f
--- /dev/null
+++ b/deskutils/etoile-etoileextensionskit/pkg-descr
@@ -0,0 +1,10 @@
+Etoile intends to be an innovative GNUstep based user environnement built
+from the ground up on highly modular and light components with project and
+document orientation in mind, in order to allow users to create their own
+workflow by reshaping or recombining provided Services (aka Applications),
+Components etc. Flexibility and modularity on both User Interface and code
+level should allow us to scale from PDA to computer environment.
+
+This package installs the EtoileExtensionsKit framework.
+
+WWW: http://www.etoile-project.org/
diff --git a/deskutils/etoile-etoileextensionskit/pkg-plist b/deskutils/etoile-etoileextensionskit/pkg-plist
new file mode 100644
index 000000000000..0148b7020f0b
--- /dev/null
+++ b/deskutils/etoile-etoileextensionskit/pkg-plist
@@ -0,0 +1,18 @@
+Local/Library/Headers/EtoileExtensions/Cocoa.h
+Local/Library/Headers/EtoileExtensions/EtoileCompatibility.h
+Local/Library/Headers/EtoileExtensions/NSBezierPathCappedBoxes.h
+Local/Library/Headers/EtoileExtensions/NSFileManager+NameForTempFile.h
+Local/Library/Headers/EtoileExtensions/NSImage+NiceScaling.h
+Local/Library/Headers/EtoileExtensions/UKDistributedView.h
+Local/Library/Headers/EtoileExtensions/UKFileWatcher.h
+Local/Library/Headers/EtoileExtensions/UKFinderIconCell.h
+Local/Library/Headers/EtoileExtensions/UKKQueue.h
+Local/Library/Headers/EtoileExtensions/UKMainThreadProxy.h
+Local/Library/Headers/EtoileExtensions/UKNibOwner.h
+Local/Library/Headers/EtoileExtensions/UKPluginsRegistry.h
+Local/Library/Headers/EtoileExtensions/UKPushbackMessenger.h
+Local/Library/Headers/EtoileExtensions/UKThreadMessenger.h
+Local/Library/Libraries/libEtoileExtensions.so
+Local/Library/Libraries/libEtoileExtensions.so.%%MAJORLIBVERSION%%
+Local/Library/Libraries/libEtoileExtensions.so.%%MAJORLIBVERSION%%.1
+@dirrm Local/Library/Headers/EtoileExtensions