aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-10-23 05:18:12 +0800
committermarino <marino@FreeBSD.org>2016-10-23 05:18:12 +0800
commit40ad4478712bc22b1e76315ac2c94def2fbe22e6 (patch)
treee1eeafd57d36b63d7a055b03aab05877118aca07 /deskutils
parentee0bda608fb8e10c1bfacf477e07df8f99bdaaea (diff)
downloadfreebsd-ports-gnome-40ad4478712bc22b1e76315ac2c94def2fbe22e6.tar.gz
freebsd-ports-gnome-40ad4478712bc22b1e76315ac2c94def2fbe22e6.tar.zst
freebsd-ports-gnome-40ad4478712bc22b1e76315ac2c94def2fbe22e6.zip
deskutils/gnome-contacts: restore CHEESE option
Since version 3.18, the --without-cheese configuration argument didn't work out of the box. However, touching a couple of files causes c source files to be regenerated enabling the option to be honored. This commit restores the options as they were before r421349 but now disabling the default CHEESE option works. PR: 207426 Approved by: follow-on commit (r421349)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/gnome-contacts/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/deskutils/gnome-contacts/Makefile b/deskutils/gnome-contacts/Makefile
index 0e2591f7d114..251dbe8ecefe 100644
--- a/deskutils/gnome-contacts/Makefile
+++ b/deskutils/gnome-contacts/Makefile
@@ -13,7 +13,6 @@ COMMENT= Contacts manager for gnome
BUILD_DEPENDS= vala>=0.14.0:lang/vala
LIB_DEPENDS= libgoa-1.0.so:net/gnome-online-accounts \
libchamplain-0.12.so:graphics/libchamplain \
- libcheese-gtk.so:multimedia/cheese \
libclutter-gtk-1.0.so:graphics/clutter-gtk3 \
libgee-0.8.so:devel/libgee \
libfolks.so:net-im/folks \
@@ -39,7 +38,6 @@ USE_GNOME= cairo evolutiondataserver3 gdkpixbuf2 glib20 gnomedesktop3 \
USE_GL= egl
USES= gettext gmake gnome pathfix perl5 pkgconfig sqlite tar:xz
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-cheese
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -52,6 +50,11 @@ OPTIONS_SUB= yes
OPTIONS_DEFINE= MANPAGES NLS
OPTIONS_DEFAULT=MANPAGES
+OPTIONS_DEFINE_i386= CHEESE
+OPTIONS_DEFINE_amd64= CHEESE
+OPTIONS_DEFAULT_i386= CHEESE
+OPTIONS_DEFAULT_amd64= CHEESE
+
MANPAGES_CONFIGURE_ENABLE= man-pages
MANPAGES_USE= GNOME=libxslt:build
MANPAGES_BUILD_DEPENDS= docbook-xml>=0:textproc/docbook-xml \
@@ -60,5 +63,13 @@ MANPAGES_BUILD_DEPENDS= docbook-xml>=0:textproc/docbook-xml \
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
+CHEESE_DESC= Cheese webcam support
+CHEESE_CONFIGURE_WITH= cheese
+CHEESE_LIB_DEPENDS= libcheese-gtk.so:multimedia/cheese
+
+post-patch:
+ # touch vala sources to force regen c sources to honor cheese setting
+ ${TOUCH} ${WRKSRC}/src/main.vala \
+ ${WRKSRC}/src/contacts-avatar-dialog.vala
.include <bsd.port.mk>