aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-03-12 03:41:25 +0800
committerpav <pav@FreeBSD.org>2005-03-12 03:41:25 +0800
commit6c6b821f92581037aba029c8e2b2c7499c5f7b3d (patch)
tree30f047ec100a6c692b611c5aa831fbe36615c01e /deskutils
parent1ffb294248d77b0104803eb601d265440b203faf (diff)
downloadfreebsd-ports-gnome-6c6b821f92581037aba029c8e2b2c7499c5f7b3d.tar.gz
freebsd-ports-gnome-6c6b821f92581037aba029c8e2b2c7499c5f7b3d.tar.zst
freebsd-ports-gnome-6c6b821f92581037aba029c8e2b2c7499c5f7b3d.zip
planner.el, an organizer and day planner for Emacs. It helps you keep track of
your pending and completed tasks, daily schedule, dates to remember, notes and inspirations. It is a powerful tool not only for managing your time and productivity, but also for keeping within easy keystroke reach all of the information you need to be productive. It can even publish reports charting your work for your personal web page, your conscience, or your soon-to-be-impressed boss. PR: ports/78615 Submitted by: Dryice Liu <dryice@liu.com.cn>
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/planner.el/Makefile73
-rw-r--r--deskutils/planner.el/distinfo2
-rw-r--r--deskutils/planner.el/pkg-descr9
-rw-r--r--deskutils/planner.el/pkg-plist39
5 files changed, 124 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 8fdb8e225ff6..2fcdcd0bd657 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -110,6 +110,7 @@
SUBDIR += phprojekt
SUBDIR += plan
SUBDIR += planner
+ SUBDIR += planner.el
SUBDIR += plans
SUBDIR += preferences.app
SUBDIR += py-dosage
diff --git a/deskutils/planner.el/Makefile b/deskutils/planner.el/Makefile
new file mode 100644
index 000000000000..72cbd4984341
--- /dev/null
+++ b/deskutils/planner.el/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: planner.el
+# Date created: March 09 2005
+# Whom: Dryice Liu <dryice@liu.com.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= planner.el
+PORTVERSION= 3.27
+CATEGORIES= deskutils elisp
+MASTER_SITES= http://sacha.free.net.ph/notebook/emacs/planner/ \
+ http://bsdchat.com/dist/dryice/
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+DISTNAME= planner-el-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
+
+MAINTAINER= dryice@liu.com.cn
+COMMENT= PlannerMode is an organizer and day planner for Emacs
+
+EMACS_PORT_NAME?= emacs21
+
+.if ${EMACS_PORT_NAME} != "emacs21"
+PORTNAMESUFFIX= ${PKGNAMESUFFIX}
+.endif
+
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/emacs-wiki/emacs-wiki.el:${PORTSDIR}/textproc/emacs-wiki
+
+OPTIONS= BBDB "BBDB support" off
+OPTIONS+= ERC "ERC support" off
+OPTIONS+= VM "View Mail support" off
+OPTIONS+= W3M "W3M support" off
+OPTIONS+= WL "Wanderlust support" off
+OPTIONS+= XTLA "XTLA support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_BBDB)
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/bbdb/bbdb-com.el:${PORTSDIR}/databases/bbdb
+.endif
+
+.if defined(WITH_ERC)
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/erc/erc.el:${PORTSDIR}/irc/erc
+.endif
+
+.if defined(WITH_VM)
+RUN_DEPENDS+= qp-decode:${PORTSDIR}/mail/vm
+.endif
+
+.if defined(WITH_W3M)
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/w3m/w3m.el:${PORTSDIR}/www/emacs-w3m
+.endif
+
+.if defined(WITH_WL)
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/wl/wl.el:${PORTSDIR}/mail/wanderlust
+.endif
+
+.if defined(WITH_XTLA)
+RUN_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/xtla/xtla.el:${PORTSDIR}/devel/xtla
+.endif
+
+INFO= planner-el
+LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/planner
+
+do-build:
+ cd ${WRKSRC}; makeinfo --no-split planner-el.texi
+
+do-install:
+ ${MKDIR} ${LISPDIR}
+.for i in *.el
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${LISPDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/planner-el.info ${PREFIX}/info
+
+.include <bsd.port.post.mk>
diff --git a/deskutils/planner.el/distinfo b/deskutils/planner.el/distinfo
new file mode 100644
index 000000000000..c562b27aad77
--- /dev/null
+++ b/deskutils/planner.el/distinfo
@@ -0,0 +1,2 @@
+MD5 (planner-el-3.27.tar.gz) = 4274f45b8bb5d632a96e4710a29945d9
+SIZE (planner-el-3.27.tar.gz) = 283700
diff --git a/deskutils/planner.el/pkg-descr b/deskutils/planner.el/pkg-descr
new file mode 100644
index 000000000000..fd0a4c51eba6
--- /dev/null
+++ b/deskutils/planner.el/pkg-descr
@@ -0,0 +1,9 @@
+PlannerMode is an organizer and day planner for Emacs. It helps you
+keep track of your pending and completed tasks, daily schedule, dates
+to remember, notes and inspirations. It is a powerful tool not only
+for managing your time and productivity, but also for keeping within
+easy keystroke reach all of the information you need to be
+productive. It can even publish reports charting your work for your
+personal web page, your conscience, or your soon-to-be-impressed boss.
+
+WWW: http://www.emacswiki.org/cgi-bin/wiki/PlannerMode
diff --git a/deskutils/planner.el/pkg-plist b/deskutils/planner.el/pkg-plist
new file mode 100644
index 000000000000..3cab339cadd8
--- /dev/null
+++ b/deskutils/planner.el/pkg-plist
@@ -0,0 +1,39 @@
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-accomplishments.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-authz.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-auto.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-bbdb.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-bibtex.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-bookmark.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-calendar.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-cyclic.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-deadline.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-diary.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-erc.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-experimental.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-export-diary.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-gnus.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-id.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-ledger.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-lisp.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-log-edit.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-mhe.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-multi.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-notes-index.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-rank.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-rdf.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-report.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-rmail.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-rss.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-schedule.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-tasks-overview.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-timeclock-summary-proj.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-timeclock-summary.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-timeclock.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-unix-mail.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-vm.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-w3m.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-wl.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner-xtla.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/planner.el
+%%EMACS_VERSION_SITE_LISPDIR%%/planner/schedule.el
+@dirrm %%EMACS_VERSION_SITE_LISPDIR%%/planner