aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2006-11-14 17:11:51 +0800
committeralexbl <alexbl@FreeBSD.org>2006-11-14 17:11:51 +0800
commit7746b35707e7a5e40ee293fd724257f6f37696f7 (patch)
tree843cd1241881e054cd7eb8c15d0975387bebc9d4 /deskutils
parent894aac5da40ac6cf3d57a7fc3b8575436925b03b (diff)
downloadfreebsd-ports-gnome-7746b35707e7a5e40ee293fd724257f6f37696f7.tar.gz
freebsd-ports-gnome-7746b35707e7a5e40ee293fd724257f6f37696f7.tar.zst
freebsd-ports-gnome-7746b35707e7a5e40ee293fd724257f6f37696f7.zip
- add TagFu 0.1
TagFu is a library for tagging entities (which can be anything with a url) with Tags or metadata. TagFu is implemented in Python and very closely mimics basic Python data structures. Tags is a Python list of tags, Entities is a Python List of Entity objects, and Entity is a dict which contains all the key-value pairs for all tags associated to the Entity. The key is the Tag name and value is an arbitrary value, if no value is set, the tag is considered to be a simple tag. WWW: http://www.geekfire.com/~alex/tagfu/
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/py-tagfu/Makefile21
-rw-r--r--deskutils/py-tagfu/distinfo3
-rw-r--r--deskutils/py-tagfu/pkg-descr9
-rw-r--r--deskutils/py-tagfu/pkg-plist10
5 files changed, 44 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 68be2c13c3f9..a5681026861d 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -137,6 +137,7 @@
SUBDIR += preferencepanes
SUBDIR += preferences.app
SUBDIR += py-dosage
+ SUBDIR += py-tagfu
SUBDIR += pybookreader
SUBDIR += pypanel
SUBDIR += recoll
diff --git a/deskutils/py-tagfu/Makefile b/deskutils/py-tagfu/Makefile
new file mode 100644
index 000000000000..1aaa763f394c
--- /dev/null
+++ b/deskutils/py-tagfu/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: py-tagfu
+# Date created: 14 Nov 2006
+# Whom: Alexander Botero-Lowry <alexbl@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= tagfu
+PORTVERSION= 0.1
+CATEGORIES= deskutils devel python
+MASTER_SITES= http://www.geekfire.com/~alex/tagfu/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alexbl@FreeBSD.org
+COMMENT= Python module for tagging urls with tags or metadata
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite22
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/deskutils/py-tagfu/distinfo b/deskutils/py-tagfu/distinfo
new file mode 100644
index 000000000000..65875a0ef48b
--- /dev/null
+++ b/deskutils/py-tagfu/distinfo
@@ -0,0 +1,3 @@
+MD5 (tagfu-0.1.tar.gz) = ae2e3ea3b37b989f43ae8d506f1677d6
+SHA256 (tagfu-0.1.tar.gz) = 1bcac0acace9f1fd87476c1030a657483f139e060909115fb11e02cf4f38e4d7
+SIZE (tagfu-0.1.tar.gz) = 7579
diff --git a/deskutils/py-tagfu/pkg-descr b/deskutils/py-tagfu/pkg-descr
new file mode 100644
index 000000000000..1673072cf302
--- /dev/null
+++ b/deskutils/py-tagfu/pkg-descr
@@ -0,0 +1,9 @@
+TagFu is a library for tagging entities (which can be anything with
+a url) with Tags or metadata. TagFu is implemented in Python and very
+closely mimics basic Python data structures. Tags is a Python list of
+tags, Entities is a Python List of Entity objects, and Entity is a
+dict which contains all the key-value pairs for all tags associated
+to the Entity. The key is the Tag name and value is an arbitrary value,
+if no value is set, the tag is considered to be a simple tag.
+
+WWW: http://www.geekfire.com/~alex/tagfu/
diff --git a/deskutils/py-tagfu/pkg-plist b/deskutils/py-tagfu/pkg-plist
new file mode 100644
index 000000000000..f4878add34cf
--- /dev/null
+++ b/deskutils/py-tagfu/pkg-plist
@@ -0,0 +1,10 @@
+%%PYTHON_SITELIBDIR%%/tagfu/__init__.py
+%%PYTHON_SITELIBDIR%%/tagfu/__init__.pyc
+%%PYTHON_SITELIBDIR%%/tagfu/__init__.pyo
+%%PYTHON_SITELIBDIR%%/tagfu/tagfu.py
+%%PYTHON_SITELIBDIR%%/tagfu/tagfu.pyc
+%%PYTHON_SITELIBDIR%%/tagfu/tagfu.pyo
+%%PYTHON_SITELIBDIR%%/tagfu/tagfu_attrs.py
+%%PYTHON_SITELIBDIR%%/tagfu/tagfu_attrs.pyc
+%%PYTHON_SITELIBDIR%%/tagfu/tagfu_attrs.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/tagfu