aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2005-02-06 19:55:12 +0800
committerdes <des@FreeBSD.org>2005-02-06 19:55:12 +0800
commitf37e9f9e1244efde5325e3130be5e0779ad9cab9 (patch)
treed879073ff658aa5566d491ad2a1db409ac2c7c78 /deskutils
parenta6fe9bd4f4343f2df46f84bc558eb60e5a00c294 (diff)
downloadfreebsd-ports-gnome-f37e9f9e1244efde5325e3130be5e0779ad9cab9.tar.gz
freebsd-ports-gnome-f37e9f9e1244efde5325e3130be5e0779ad9cab9.tar.zst
freebsd-ports-gnome-f37e9f9e1244efde5325e3130be5e0779ad9cab9.zip
Lower-case the group name, not the entire image file name. This makes
"Display layout as image" work.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/xfce4-xkb-plugin/Makefile2
-rw-r--r--deskutils/xfce4-xkb-plugin/files/patch-panel-plugin::xkb.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/deskutils/xfce4-xkb-plugin/Makefile b/deskutils/xfce4-xkb-plugin/Makefile
index e31133ad9b01..7355bd6e2ae4 100644
--- a/deskutils/xfce4-xkb-plugin/Makefile
+++ b/deskutils/xfce4-xkb-plugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-xkb-plugin
PORTVERSION= 0.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils xfce
MASTER_SITES= http://download.berlios.de/xfce-goodies/
DIST_SUBDIR= xfce4
diff --git a/deskutils/xfce4-xkb-plugin/files/patch-panel-plugin::xkb.c b/deskutils/xfce4-xkb-plugin/files/patch-panel-plugin::xkb.c
new file mode 100644
index 000000000000..7d72d7b174c1
--- /dev/null
+++ b/deskutils/xfce4-xkb-plugin/files/patch-panel-plugin::xkb.c
@@ -0,0 +1,15 @@
+--- panel-plugin/xkb.c.orig Wed Jun 30 11:46:49 2004
++++ panel-plugin/xkb.c Sun Feb 6 12:51:04 2005
+@@ -264,12 +264,12 @@
+ char *group;
+
+ group = strdup(get_symbol_name_by_res_no(current_group_xkb_no));
++ to_lower(group);
+ strcpy(filename, FLAGSDIR);
+ strcat(filename, "/");
+ strcat(filename, group);
+ strcat(filename, ".png");
+- to_lower(filename);
+
+ free(group);
+