aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-01-03 07:09:36 +0800
committerrakuco <rakuco@FreeBSD.org>2016-01-03 07:09:36 +0800
commitc64158ae5c6f95be7e89d2930d7f07a486f982e9 (patch)
treebd1ecfa60add7fb10202be711bc71b7a29994b05 /deskutils
parentc35edb83fb14c1db7eb95802a4d358433782e48c (diff)
downloadfreebsd-ports-gnome-c64158ae5c6f95be7e89d2930d7f07a486f982e9.tar.gz
freebsd-ports-gnome-c64158ae5c6f95be7e89d2930d7f07a486f982e9.tar.zst
freebsd-ports-gnome-c64158ae5c6f95be7e89d2930d7f07a486f982e9.zip
py-spice-gtk: Fix plist and unmark BROKEN.
The attached patch removes the static library version of SpiceClientGtk.a from the port's plist. After 0.26, the spice-gtk disables static builds by default. I tried passing --enable-static, but the build fails: gmake[3]: Entering directory '/wrkdirs/usr/ports/deskutils/py-spice-gtk/work/spice-gtk-0.30/tests' CC coroutine.o CC util.o CC session.o CCLD coroutine CCLD session CCLD util /usr/bin/ld: undefined reference to symbol `hypot@@FBSD_1.0' (try adding -lm) //lib/libm.so.5: could not read symbols: Bad value cc: error: linker command failed with exit code 1 (use -v to see invocation) Makefile:719: recipe for target 'session' failed PR: 205442 Approved by: maintainer timeout (15 days)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/py-spice-gtk/Makefile1
-rw-r--r--deskutils/spice-gtk/Makefile4
2 files changed, 2 insertions, 3 deletions
diff --git a/deskutils/py-spice-gtk/Makefile b/deskutils/py-spice-gtk/Makefile
index 8c70b4ac1797..83a968f0cf13 100644
--- a/deskutils/py-spice-gtk/Makefile
+++ b/deskutils/py-spice-gtk/Makefile
@@ -6,6 +6,5 @@ MASTERDIR= ${.CURDIR}/../spice-gtk
CONFLICTS= spice-gtk-[0-9]*
SPICE_SLAVE= yes
-BROKEN= fails to package
.include "${MASTERDIR}/Makefile"
diff --git a/deskutils/spice-gtk/Makefile b/deskutils/spice-gtk/Makefile
index f6cf98e3bd11..e84d676abc79 100644
--- a/deskutils/spice-gtk/Makefile
+++ b/deskutils/spice-gtk/Makefile
@@ -20,13 +20,13 @@ BUILD_DEPENDS= spice-protocol>=0.12.10:${PORTSDIR}/devel/spice-protocol \
${PYTHON_PKGNAMEPREFIX}pyparsing>=2.0.1:${PORTSDIR}/devel/py-pyparsing
.if defined(SPICE_SLAVE)
+PORTREVISION= 1
CATEGORIES+= python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:${PORTSDIR}/x11-toolkits/py-gtk2
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:${PORTSDIR}/x11-toolkits/py-gtk2
CONFIGURE_ARGS+= --with-python
-PLIST_FILES+= %%PYTHON_SITELIBDIR%%/SpiceClientGtk.a \
- %%PYTHON_SITELIBDIR%%/SpiceClientGtk.so
+PLIST_FILES+= %%PYTHON_SITELIBDIR%%/SpiceClientGtk.so
USES+= python
.endif