aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-05 02:06:07 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-05 02:06:07 +0800
commit41290677b018da2819144b0188ac8bd1b91a88e4 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /deskutils
parent02239bfdfc92a832c32cc57d07d3a1a4b3fc4ad9 (diff)
downloadfreebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.tar.gz
freebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.tar.zst
freebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.zip
- Make ports use the libc provided iconv implementation on 10-CURRENT
after r254273 - Fix a bunch of ports to properly work after this - Mark converters/libiconv as IGNORE for systems with iconv in libc Reviewed by: bapt Approved by: portmgr (bapt) Discussed with: bapt, bsam (who both contributed ideas and code)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/adesklets/Makefile2
-rw-r--r--deskutils/fbreader/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/deskutils/adesklets/Makefile b/deskutils/adesklets/Makefile
index c9b38319a77f..10680c3f3e93 100644
--- a/deskutils/adesklets/Makefile
+++ b/deskutils/adesklets/Makefile
@@ -33,7 +33,7 @@ INFO= adesklets \
SUB_FILES= pkg-message
INSTALLS_EGGINFO= yes
-LDFLAGS+= -liconv
+LDFLAGS+= ${ICONV_LIB}
.if !defined(WITHOUT_PERL)
USE_PERL5= yes
diff --git a/deskutils/fbreader/Makefile b/deskutils/fbreader/Makefile
index 8bc1729774c6..664f7ef1075e 100644
--- a/deskutils/fbreader/Makefile
+++ b/deskutils/fbreader/Makefile
@@ -56,7 +56,7 @@ post-patch:
@${REINPLACE_CMD} -e '/^CFLAGS/s,-pipe.*$$,${CFLAGS} -DDO_ICONV_CAST -DLIBICONV_PLUG,' \
-e '/^CC/d;/^LD/d;/QTINCLUDE/s,-I.*$$,-I${QT_INCDIR},;s,libpng ,libpng15 ,' \
${WRKSRC}/makefiles/arch/desktop.mk
- @${REINPLACE_CMD} -e 's,-O3,,;s,-ldl,-liconv,' \
+ @${REINPLACE_CMD} -e 's,-O3,,;s,-ldl,${ICONV_LIB},' \
${WRKSRC}/makefiles/config.mk ${WRKSRC}/zlibrary/core/Makefile
@${REINPLACE_CMD} -e 's,/usr,${PREFIX},' ${WRKSRC}/fbreader/desktop/Makefile
@${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} \