aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
committertijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
commit55e5c34e31b90aa95311b10bd4a3072f2163ebfe (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /deskutils
parent0c15193d405451f0e1452ba981c8efb1df1447dd (diff)
downloadfreebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.gz
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.zst
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/bitcollider/Makefile4
-rw-r--r--deskutils/gtkjournal/Makefile4
-rw-r--r--deskutils/notify-osd/Makefile7
3 files changed, 9 insertions, 6 deletions
diff --git a/deskutils/bitcollider/Makefile b/deskutils/bitcollider/Makefile
index f65b09f36f05..e1bf490c4c37 100644
--- a/deskutils/bitcollider/Makefile
+++ b/deskutils/bitcollider/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bitcollider
PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils multimedia
MASTER_SITES= SF/${PORTNAME}/Bitcollider/${PORTVERSION}
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Bitzi metadata generator
GNU_CONFIGURE= yes
-USES= libtool
+USES= libtool:keepla
USE_LDCONFIG= yes
CFLAGS+= -lm
diff --git a/deskutils/gtkjournal/Makefile b/deskutils/gtkjournal/Makefile
index 8ee5f8b0ff31..2ca60f8999a6 100644
--- a/deskutils/gtkjournal/Makefile
+++ b/deskutils/gtkjournal/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gtkjournal
PORTVERSION= 0.3.5.b
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= deskutils gnome
MASTER_SITES= http://sourcefiles.org/Productivity_Tools/Diary/ \
LOCAL/beech
@@ -21,9 +21,9 @@ PLIST_FILES= bin/gtkjournal man/man1/gtkjournal.1.gz \
lib/libsqlitemm.so lib/libsqlitemm.so.0 \
lib/libsqlitemm.so.0.0.1
+USES= gmake libtool:keepla pathfix pkgconfig
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix pkgconfig
CONFIGURE_ARGS= --enable-gtkspell
USE_LDCONFIG= yes
diff --git a/deskutils/notify-osd/Makefile b/deskutils/notify-osd/Makefile
index cb4f6693a6a0..21e267b8ee39 100644
--- a/deskutils/notify-osd/Makefile
+++ b/deskutils/notify-osd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= notify-osd
PORTVERSION= 0.9.29
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= deskutils
MASTER_SITES= http://launchpadlibrarian.net/43419242/ \
CRITICAL
@@ -20,8 +20,11 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus
GNU_CONFIGURE= yes
-USES= gmake pkgconfig
+USES= gmake libtool pkgconfig
USE_GNOME= libwnck gconf2
+USE_XORG= pixman
USE_GCC= yes
+LDFLAGS+= -L${LOCALBASE}/lib -lpixman-1
+
.include <bsd.port.mk>