aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-10 21:54:26 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-10 21:54:26 +0800
commit591689f7f7301da41e08d95976e1318322254d75 (patch)
tree3a1e73b4128190b7ed7020b2113a1d94d76b0e93 /deskutils
parent241bc346167b5bfc4beac8d3b3044454cf6b0f87 (diff)
downloadfreebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.tar.gz
freebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.tar.zst
freebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.zip
According to the Porter's Handbook (5.12.2.3.) default options must be added to
OPTIONS_DEFINE. This policy has been implemented only recently that's why we have many ports violating this policy. This patch adds the default options specified in the Porter's Handbook to OPTIONS_DEFINE where they are being used. Ports maintained by gnome@FreeBSD.org, kde@FreeBSD.org and x11@FreeBSD.org have been excluded. Approved by: portmgr (bapt)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/bmp-docklet/Makefile3
-rw-r--r--deskutils/gcal/Makefile2
-rw-r--r--deskutils/genius/Makefile3
-rw-r--r--deskutils/gimmie/Makefile3
-rw-r--r--deskutils/gxmessage/Makefile3
-rw-r--r--deskutils/virt-manager/Makefile3
-rw-r--r--deskutils/x-tile/Makefile3
7 files changed, 20 insertions, 0 deletions
diff --git a/deskutils/bmp-docklet/Makefile b/deskutils/bmp-docklet/Makefile
index 3e9f8d51b16a..b3a21ecd0279 100644
--- a/deskutils/bmp-docklet/Makefile
+++ b/deskutils/bmp-docklet/Makefile
@@ -24,6 +24,9 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/deskutils/gcal/Makefile b/deskutils/gcal/Makefile
index 1beaf15ce37d..4d6081affa73 100644
--- a/deskutils/gcal/Makefile
+++ b/deskutils/gcal/Makefile
@@ -18,6 +18,8 @@ SHEBANG_FILES= misc/gcalltx/gcalltxp.in misc/gcalltx/gcalltx.pl
INFO= gcal
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index 0034a7fd4fa4..cda210b6688b 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -30,6 +30,9 @@ INSTALLS_ICONS= yes
INSTALLS_OMF= yes
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/deskutils/gimmie/Makefile b/deskutils/gimmie/Makefile
index 7e9e5e436626..16ab9b5357c6 100644
--- a/deskutils/gimmie/Makefile
+++ b/deskutils/gimmie/Makefile
@@ -27,6 +27,9 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/deskutils/gxmessage/Makefile b/deskutils/gxmessage/Makefile
index 6799f6f236d2..047867e7fe4c 100644
--- a/deskutils/gxmessage/Makefile
+++ b/deskutils/gxmessage/Makefile
@@ -19,6 +19,9 @@ INSTALLS_ICONS= yes
MAKE_ARGS+= INSTALL="${INSTALL_PROGRAM}"
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/deskutils/virt-manager/Makefile b/deskutils/virt-manager/Makefile
index efcae1b6f3fb..3769656ad1d4 100644
--- a/deskutils/virt-manager/Makefile
+++ b/deskutils/virt-manager/Makefile
@@ -22,6 +22,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83.2:${PORTSDIR}/devel/py-dbus \
librsvg2>=2.32.1:${PORTSDIR}/graphics/librsvg2
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/deskutils/x-tile/Makefile b/deskutils/x-tile/Makefile
index 9e3dfca47dba..035f1c395d1f 100644
--- a/deskutils/x-tile/Makefile
+++ b/deskutils/x-tile/Makefile
@@ -18,6 +18,9 @@ USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= X_Tile
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}