aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-11-28 14:38:03 +0800
committerdinoex <dinoex@FreeBSD.org>2006-11-28 14:38:03 +0800
commit6eef2e2a19d245b9e26a67ffd8504ec35e7f6a4a (patch)
tree5e32463253e800e031cb36caa3151354cd9d6b9e /deskutils
parent8579498afaaff3c9f895ddd2cc5ebc93ae73a22c (diff)
downloadfreebsd-ports-gnome-6eef2e2a19d245b9e26a67ffd8504ec35e7f6a4a.tar.gz
freebsd-ports-gnome-6eef2e2a19d245b9e26a67ffd8504ec35e7f6a4a.tar.zst
freebsd-ports-gnome-6eef2e2a19d245b9e26a67ffd8504ec35e7f6a4a.zip
- fix linker paths
LFLAGS was passed but was clobbered in Makefile.options - strip path from patches and pass it via Makefile - honor CFLAGS and LDFLAGS
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/abacus/Makefile8
-rw-r--r--deskutils/abacus/files/patch-aa9
2 files changed, 10 insertions, 7 deletions
diff --git a/deskutils/abacus/Makefile b/deskutils/abacus/Makefile
index 4b4ecac50852..7b8f3197bc21 100644
--- a/deskutils/abacus/Makefile
+++ b/deskutils/abacus/Makefile
@@ -23,10 +23,12 @@ LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82 \
USE_XLIB= yes
USE_GMAKE= yes
-MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS} -Wno-deprecated" LFLAGS="${LDFLAGS}"
-LDFLAGS+= -L$(X11BASE)/lib -L$(LOCALBASE)/lib
+MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS} -Wno-deprecated" LDFLAGS="${LDFLAGS}"
+CFLAGS+= -I$(X11BASE)/include \
+ -I$(LOCALBASE)/include/tcl8.2 \
+ -I$(LOCALBASE)/include/tk8.2
+LDFLAGS+= -L$(LOCALBASE)/lib -L$(X11BASE)/lib
ALL_TARGET= dep tcl_interf/nxlc
-MAKE_ENV+= LDFLAGS="${LDFLAGS}"
MAN1= abacus.1
diff --git a/deskutils/abacus/files/patch-aa b/deskutils/abacus/files/patch-aa
index 594093aa3fe1..2102008e770f 100644
--- a/deskutils/abacus/files/patch-aa
+++ b/deskutils/abacus/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.options.orig Wed Oct 21 05:19:08 1998
-+++ Makefile.options Fri Aug 4 04:53:59 2000
+--- Makefile.options.orig Tue Oct 20 22:19:08 1998
++++ Makefile.options Tue Nov 28 06:56:07 2006
@@ -3,22 +3,22 @@
#
@@ -33,7 +33,8 @@
# Add extra include dirs here
-IFLAGS = -I$(IDIR)
-+IFLAGS = -I$(IDIR) -I$(X11BASE)/include -I$(LOCALBASE)/include/tcl8.2 -I$(LOCALBASE)/include/tk8.2
++IFLAGS = -I$(IDIR) ${CFLAGS}
# Add extra directories where you want the abacus to search for libraries here
- LFLAGS = -L/usr/local/lib -L/usr/X11R6/lib -L$(LIBDIR) -L.
+-LFLAGS = -L/usr/local/lib -L/usr/X11R6/lib -L$(LIBDIR) -L.
++LFLAGS = ${LDFLAGS} -L$(LIBDIR) -L.