aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2004-06-06 21:26:34 +0800
committermarkus <markus@FreeBSD.org>2004-06-06 21:26:34 +0800
commit70cd72932149a09a379e2357bd1381169e263bc0 (patch)
tree5b074b4455273849b133d939a0c82e2c4e8df6ec /deskutils
parent6bcc293162ec080760681a0efb1fa6746cf6fc0b (diff)
downloadfreebsd-ports-gnome-70cd72932149a09a379e2357bd1381169e263bc0.tar.gz
freebsd-ports-gnome-70cd72932149a09a379e2357bd1381169e263bc0.tar.zst
freebsd-ports-gnome-70cd72932149a09a379e2357bd1381169e263bc0.zip
Don't use Makefile.kde anymore
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/ktagebuch/Makefile9
-rw-r--r--deskutils/kuake/Makefile9
-rw-r--r--deskutils/superkaramba/Makefile9
3 files changed, 12 insertions, 15 deletions
diff --git a/deskutils/ktagebuch/Makefile b/deskutils/ktagebuch/Makefile
index d19e730bea81..69b216a8ef20 100644
--- a/deskutils/ktagebuch/Makefile
+++ b/deskutils/ktagebuch/Makefile
@@ -20,13 +20,12 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
@${RM} ${WRKSRC}/ktagebuch/library/ui/inserthtmldialog.cpp \
${WRKSRC}/ktagebuch/library/ui/inserthtmldialog.h
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/kuake/Makefile b/deskutils/kuake/Makefile
index 5a5ae26781da..220bca5d5320 100644
--- a/deskutils/kuake/Makefile
+++ b/deskutils/kuake/Makefile
@@ -18,9 +18,10 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
+
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/superkaramba/Makefile b/deskutils/superkaramba/Makefile
index 8be624431fa9..aacbbb448f19 100644
--- a/deskutils/superkaramba/Makefile
+++ b/deskutils/superkaramba/Makefile
@@ -33,8 +33,6 @@ USE_REINPLACE= yes
CONFIGURE_ARGS+= --with-pythondir=${PYTHON_INCLUDEDIR}
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-
pre-everything::
.if !defined(WITH_XMMS)
@${ECHO_MSG} "You can enable XMMS support by defining WITH_XMMS."
@@ -44,8 +42,7 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-O2 ||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-O2 ||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>