aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-12-09 04:52:38 +0800
committerthierry <thierry@FreeBSD.org>2004-12-09 04:52:38 +0800
commitae9095c9bc7b894cc62dad18597c6f417dc8017a (patch)
tree9c6357152157409f1e251a0582a45b5ce1253edc /deskutils
parent17e0adc7b8fd14ccfa85bb869ab9206b101bfb67 (diff)
downloadfreebsd-ports-gnome-ae9095c9bc7b894cc62dad18597c6f417dc8017a.tar.gz
freebsd-ports-gnome-ae9095c9bc7b894cc62dad18597c6f417dc8017a.tar.zst
freebsd-ports-gnome-ae9095c9bc7b894cc62dad18597c6f417dc8017a.zip
- fix a coredump;
- take maintainership. PR: ports/74326 Submitted by: Thomas Kempka.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/wmpinboard/Makefile4
-rw-r--r--deskutils/wmpinboard/files/patch-src::wmpinboard.c13
2 files changed, 13 insertions, 4 deletions
diff --git a/deskutils/wmpinboard/Makefile b/deskutils/wmpinboard/Makefile
index 9190e53ab0b5..1d75933f686b 100644
--- a/deskutils/wmpinboard/Makefile
+++ b/deskutils/wmpinboard/Makefile
@@ -7,12 +7,12 @@
PORTNAME= wmpinboard
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils afterstep windowmaker
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= t.kempka@web.de
COMMENT= Post-it notes for the WindowMaker dock or AfterStep Wharf
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
diff --git a/deskutils/wmpinboard/files/patch-src::wmpinboard.c b/deskutils/wmpinboard/files/patch-src::wmpinboard.c
index 90606f1723e9..28787abf2eca 100644
--- a/deskutils/wmpinboard/files/patch-src::wmpinboard.c
+++ b/deskutils/wmpinboard/files/patch-src::wmpinboard.c
@@ -1,5 +1,5 @@
---- wmpinboard.c.orig Thu Apr 13 15:01:17 2000
-+++ src/wmpinboard.c Wed Apr 18 13:06:36 2001
+--- wmpinboard.c.orig Fri Dec 8 20:42:23 2000
++++ src/wmpinboard.c Wed Nov 24 02:05:22 2004
@@ -10,6 +10,7 @@
#include <stdlib.h>
#include <stdio.h>
@@ -8,6 +8,15 @@
#include <sys/stat.h>
#include <sys/time.h>
+@@ -165,7 +166,7 @@
+ char t[STRING_BUF_SIZE];
+ FILE *file;
+ int pid = (int) getpid();
+- static int sizes[6];
++ static int sizes[7];
+ sizes[0] = size_0;
+ sizes[1] = size_1;
+ sizes[2] = size_2;
@@ -1141,13 +1142,7 @@
void
timer(unsigned int intv)