aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2014-01-14 05:00:02 +0800
committerrene <rene@FreeBSD.org>2014-01-14 05:00:02 +0800
commitd738d5587ccf4b7f0ecd6b4ab8e1105dd9d20a99 (patch)
tree15cdc9de8e1435e170938ead4c0c26dfe041a7e6 /deskutils
parent0c77840ce77e9be1c328ea8862f0987d9efb7d8a (diff)
downloadfreebsd-ports-gnome-d738d5587ccf4b7f0ecd6b4ab8e1105dd9d20a99.tar.gz
freebsd-ports-gnome-d738d5587ccf4b7f0ecd6b4ab8e1105dd9d20a99.tar.zst
freebsd-ports-gnome-d738d5587ccf4b7f0ecd6b4ab8e1105dd9d20a99.zip
Python cleanup:
- USE_PYTHON* = 2.X -> USE_PYTHON* = 2 - USE_PYTHON* = 2.X+ -> USE_PYTHON* = yes Reviewed by: python (mva, rm) Approved by: portmgr-lurkers (mat)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/calibre/Makefile2
-rw-r--r--deskutils/conduit/Makefile2
-rw-r--r--deskutils/gbirthday/Makefile2
-rw-r--r--deskutils/glipper/Makefile2
-rw-r--r--deskutils/gnochm/Makefile2
-rw-r--r--deskutils/gourmet/Makefile2
-rw-r--r--deskutils/griffith/Makefile2
-rw-r--r--deskutils/ontv/Makefile2
-rw-r--r--deskutils/py-vobject/Makefile2
-rw-r--r--deskutils/pybookreader/Makefile2
-rw-r--r--deskutils/rednotebook/Makefile2
-rw-r--r--deskutils/semantik/Makefile2
-rw-r--r--deskutils/superkaramba/Makefile2
-rw-r--r--deskutils/treeline/Makefile2
14 files changed, 14 insertions, 14 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index 1ceeb619e8ca..c1de6153adf2 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -56,7 +56,7 @@ SHEBANG_FILES= src/calibre/ebooks/metadata/odt.py \
src/calibre/utils/*.py \
src/odf/*.py
USE_XZ= yes
-USE_PYTHON= 2.7
+USE_PYTHON= 2
USE_QT4= dbus qmake_build moc_build
INSTALLS_ICONS= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-src
diff --git a/deskutils/conduit/Makefile b/deskutils/conduit/Makefile
index 1e17ecc33673..3eca33de4857 100644
--- a/deskutils/conduit/Makefile
+++ b/deskutils/conduit/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/goocanvasmodule.so:${PORTSDIR}/graphics/py-goo
${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
xdg-open:${PORTSDIR}/devel/xdg-utils
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
GNU_CONFIGURE= yes
USES= gettext gmake pkgconfig
INSTALLS_OMF= yes
diff --git a/deskutils/gbirthday/Makefile b/deskutils/gbirthday/Makefile
index a2c30ea7f30e..1178966c357c 100644
--- a/deskutils/gbirthday/Makefile
+++ b/deskutils/gbirthday/Makefile
@@ -17,7 +17,7 @@ EVO_DESC= Evolution support
THUNDER_DESC= Thunderbird/Sunbird support
USE_XZ= yes
-USE_PYTHON_RUN= -2.7
+USE_PYTHON_RUN= 2
USE_GNOME= pygtk2 desktopfileutils
NO_STAGE= yes
diff --git a/deskutils/glipper/Makefile b/deskutils/glipper/Makefile
index 8cb45754d80d..b260c52a023d 100644
--- a/deskutils/glipper/Makefile
+++ b/deskutils/glipper/Makefile
@@ -13,7 +13,7 @@ COMMENT= Clipboard manager for the GNOME panel
USE_BZIP2= yes
USES= gettext gmake iconv pathfix pkgconfig
USE_GNOME= gnomeprefix intltool pygnomedesktop pygnomeextras
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/libexec
diff --git a/deskutils/gnochm/Makefile b/deskutils/gnochm/Makefile
index db54e2195336..ae431e9c4ee1 100644
--- a/deskutils/gnochm/Makefile
+++ b/deskutils/gnochm/Makefile
@@ -17,7 +17,7 @@ USE_GMAKE= yes
USES= pathfix gettext
USE_GNOME= gnomeprefix intlhack pygnome2 pygtk2 pygnomeextras
GNU_CONFIGURE= yes
-USE_PYTHON= 2.2+
+USE_PYTHON= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/deskutils/gourmet/Makefile b/deskutils/gourmet/Makefile
index 76aaade4ed47..2cf1aca08350 100644
--- a/deskutils/gourmet/Makefile
+++ b/deskutils/gourmet/Makefile
@@ -27,7 +27,7 @@ PORTSCOUT= ignore:1
USE_BZIP2= yes
USES= gettext
USE_GNOME= pygnome2 pygnomeextras pygtk2
-USE_PYTHON= -2.7
+USE_PYTHON= 2
USE_PYDISTUTILS=yes
NO_STAGE= yes
diff --git a/deskutils/griffith/Makefile b/deskutils/griffith/Makefile
index 59333f3d5501..ec0035294cf0 100644
--- a/deskutils/griffith/Makefile
+++ b/deskutils/griffith/Makefile
@@ -25,7 +25,7 @@ PYGNOMEEXTRAS_DESC= Enable python-gnome-extras support
USE_XZ= yes
USE_GNOME= pygtk2
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
USES= gettext
USE_GMAKE= yes
NO_BUILD= yes
diff --git a/deskutils/ontv/Makefile b/deskutils/ontv/Makefile
index bb9a36113d96..4e8a428f9acc 100644
--- a/deskutils/ontv/Makefile
+++ b/deskutils/ontv/Makefile
@@ -23,7 +23,7 @@ USE_BZIP2= yes
USES= gettext
USE_GNOME= gnomehack gnomeprefix pygnomedesktop pygnomeextras pygtk2
USE_GMAKE= yes
-USE_PYTHON= 2.5-2.7
+USE_PYTHON= 2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/deskutils/py-vobject/Makefile b/deskutils/py-vobject/Makefile
index ec57192480c5..1e5697a9a004 100644
--- a/deskutils/py-vobject/Makefile
+++ b/deskutils/py-vobject/Makefile
@@ -13,7 +13,7 @@ COMMENT= ICalendar library
RUN_DEPENDS= py*-dateutil>=1.1:${PORTSDIR}/devel/py-dateutil
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
USE_PYDISTUTILS=easy_install
NO_STAGE= yes
diff --git a/deskutils/pybookreader/Makefile b/deskutils/pybookreader/Makefile
index cbcf70bb4a1e..100eab13ef81 100644
--- a/deskutils/pybookreader/Makefile
+++ b/deskutils/pybookreader/Makefile
@@ -13,7 +13,7 @@ COMMENT= Program for reading e-books
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2
-USE_PYTHON= 2.2+
+USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= PyBookReader
USE_GNOME= pygtk2
diff --git a/deskutils/rednotebook/Makefile b/deskutils/rednotebook/Makefile
index 7e5bc8edd79e..305c48580e24 100644
--- a/deskutils/rednotebook/Makefile
+++ b/deskutils/rednotebook/Makefile
@@ -22,7 +22,7 @@ USES= desktop-file-utils gettext
INSTALLS_ICONS= yes
USE_GNOME= pygtk2
-USE_PYTHON= -2.7
+USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
diff --git a/deskutils/semantik/Makefile b/deskutils/semantik/Makefile
index c95a428ba7e1..33a548af0474 100644
--- a/deskutils/semantik/Makefile
+++ b/deskutils/semantik/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv3
USE_KDE4= kdehier kdelibs kdeprefix
USE_OCAML= yes
NO_OCAML_RUNDEPENDS= yes
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
USE_QT4= corelib gui linguist_build svg webkit xml \
moc_build qmake_build uic_build
USES= pkgconfig shebangfix
diff --git a/deskutils/superkaramba/Makefile b/deskutils/superkaramba/Makefile
index 00dbdd6416db..8b4af6788516 100644
--- a/deskutils/superkaramba/Makefile
+++ b/deskutils/superkaramba/Makefile
@@ -13,7 +13,7 @@ COMMENT= Widget framework for KDE
CONFLICTS= kdeutils-4.[0-7].*
USE_XZ= yes
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
USE_KDE4= kdehier kdelibs kdeprefix automoc4 qimageblitz
USES= cmake:outsource
USE_QT4= qmake_build moc_build rcc_build uic_build
diff --git a/deskutils/treeline/Makefile b/deskutils/treeline/Makefile
index 67da895c6d2a..e6e358c54213 100644
--- a/deskutils/treeline/Makefile
+++ b/deskutils/treeline/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-gui>=0:${PORTSDIR}/x11-toolkits/py-qt4-g
WRKSRC= ${WRKDIR}/TreeLine
USE_QT4= # empty
-USE_PYTHON= -2.7
+USE_PYTHON= 2
NO_BUILD= yes
DESKTOP_ENTRIES= "TreeLine" "Structured information storage program" \