aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2009-08-22 11:55:25 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2009-08-22 11:55:25 +0800
commite9aafe3987c0e5ab9b161fb2430a4a0561a908d7 (patch)
treed22e6d25a8893748354b5585b882be0880093231 /deskutils
parent50e5ff23f7a102ee098c5b8e7c416db627f52d99 (diff)
downloadfreebsd-ports-gnome-e9aafe3987c0e5ab9b161fb2430a4a0561a908d7.tar.gz
freebsd-ports-gnome-e9aafe3987c0e5ab9b161fb2430a4a0561a908d7.tar.zst
freebsd-ports-gnome-e9aafe3987c0e5ab9b161fb2430a4a0561a908d7.zip
An ANSI C library allowing communication with google calendar and contacts,
useful if you need to support this in a C or C++ application. WWW: http://code.google.com/p/libgcal/ PR: ports/137994 Submitted by: Troels Kofoed Jacobsen <tkjacobsen at gmail.com>
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/libgcal/Makefile27
-rw-r--r--deskutils/libgcal/distinfo3
-rw-r--r--deskutils/libgcal/pkg-descr4
-rw-r--r--deskutils/libgcal/pkg-plist14
5 files changed, 49 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 526ff6a3387e..176a5977db9e 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -143,6 +143,7 @@
SUBDIR += kuake
SUBDIR += labyrinth
SUBDIR += launchy
+ SUBDIR += libgcal
SUBDIR += libopensync-plugin-evolution2
SUBDIR += libopensync-plugin-evolution2-devel
SUBDIR += libopensync-plugin-file
diff --git a/deskutils/libgcal/Makefile b/deskutils/libgcal/Makefile
new file mode 100644
index 000000000000..ea0fe1bd1a0e
--- /dev/null
+++ b/deskutils/libgcal/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: libgcal
+# Date created: 2009-08-16
+# Whom: Troels Kofoed Jacobsen <tkjacobsen@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgcal
+PORTVERSION= 0.9.2
+CATEGORIES= deskutils
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= tkjacobsen@gmail.com
+COMMENT= Library allowing communication with google calendar and contacts
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
+ iconv:${PORTSDIR}/converters/libiconv \
+ xml2:${PORTSDIR}/textproc/libxml2
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,(libdir)/pkgconfig,(prefix)/libdata/pkgconfig,' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/deskutils/libgcal/distinfo b/deskutils/libgcal/distinfo
new file mode 100644
index 000000000000..7a0a2f312c20
--- /dev/null
+++ b/deskutils/libgcal/distinfo
@@ -0,0 +1,3 @@
+MD5 (libgcal-0.9.2.tar.gz) = 2e30ebcaad4c01c78b192fe50ec69203
+SHA256 (libgcal-0.9.2.tar.gz) = 5cae3d85549c4a6d1c4bacfd9edc9e2f94dee77f655b28c80815d49d3ba1d522
+SIZE (libgcal-0.9.2.tar.gz) = 365432
diff --git a/deskutils/libgcal/pkg-descr b/deskutils/libgcal/pkg-descr
new file mode 100644
index 000000000000..bf891d606ed9
--- /dev/null
+++ b/deskutils/libgcal/pkg-descr
@@ -0,0 +1,4 @@
+An ANSI C library allowing communication with google calendar and contacts,
+useful if you need to support this in a C or C++ application.
+
+WWW: http://code.google.com/p/libgcal/
diff --git a/deskutils/libgcal/pkg-plist b/deskutils/libgcal/pkg-plist
new file mode 100644
index 000000000000..7c638676ee17
--- /dev/null
+++ b/deskutils/libgcal/pkg-plist
@@ -0,0 +1,14 @@
+include/atom_parser.h
+include/gcal.h
+include/gcal_parser.h
+include/gcal_status.h
+include/gcalendar.h
+include/gcont.h
+include/gcontact.h
+include/internal_gcal.h
+include/xml_aux.h
+lib/libgcal.a
+lib/libgcal.la
+lib/libgcal.so
+lib/libgcal.so.0
+libdata/pkgconfig/libgcal.pc