aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-05-27 00:18:04 +0800
committerwg <wg@FreeBSD.org>2013-05-27 00:18:04 +0800
commitee5f252eae0147866d6b2fa3e7d99aec36c53f0d (patch)
treec9c8dcf7529e20efcff29c4713ac447843890742 /deskutils
parentaef8139a7c6c51250ecd212d2d990f60d53e4093 (diff)
downloadfreebsd-ports-gnome-ee5f252eae0147866d6b2fa3e7d99aec36c53f0d.tar.gz
freebsd-ports-gnome-ee5f252eae0147866d6b2fa3e7d99aec36c53f0d.tar.zst
freebsd-ports-gnome-ee5f252eae0147866d6b2fa3e7d99aec36c53f0d.zip
- Update to 0.6.0 [1]
- Add LICENSE (ISCL) - Unmute install commands Changes: https://github.com/thjaeger/easystroke/blob/94a862e9/changelog PR: ports/178751 [1] Submitted by: Tobias Kortkamp <tobias.kortkamp@gmail.com> (maintainer) Approved by: culot (mentor)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/easystroke/Makefile21
-rw-r--r--deskutils/easystroke/distinfo4
-rw-r--r--deskutils/easystroke/files/patch-Makefile12
-rw-r--r--deskutils/easystroke/files/patch-main.cc11
4 files changed, 19 insertions, 29 deletions
diff --git a/deskutils/easystroke/Makefile b/deskutils/easystroke/Makefile
index 8145974e1717..9e600f6e0b76 100644
--- a/deskutils/easystroke/Makefile
+++ b/deskutils/easystroke/Makefile
@@ -1,17 +1,19 @@
-# Created by: Tobias Kortkamp <tobias.kortkamp@gmail.com>
+# Created by: Tobias Kortkamp <tobias.kortkamp@gmail.com>
# $FreeBSD$
PORTNAME= easystroke
-PORTVERSION= 0.5.6
+PORTVERSION= 0.6.0
CATEGORIES= deskutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
MAINTAINER= tobias.kortkamp@gmail.com
COMMENT= Easystroke is a gesture-recognition application for X11
+LICENSE= ISCL
+
BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man \
${LOCALBASE}/include/xorg/xserver-properties.h:${PORTSDIR}/x11-servers/xorg-server
-LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
+LIB_DEPENDS= gtkmm-3:${PORTSDIR}/x11-toolkits/gtkmm30 \
dbus-glib:${PORTSDIR}/devel/dbus-glib \
boost_serialization:${PORTSDIR}/devel/boost-libs
@@ -20,14 +22,13 @@ MAN1= easystroke.1
USE_GCC= any
USE_XORG= x11 xtst
USE_GMAKE= yes
+USES+= gettext
INSTALLS_ICONS= yes
OPTIONS_DEFINE= NLS
.include <bsd.port.options.mk>
-USES+= gettext
-
.if ${PORT_OPTIONS:MNLS}
BUILD_DEPENDS+= intltool-merge:${PORTSDIR}/textproc/intltool
PLIST_SUB+= NLS=""
@@ -44,17 +45,17 @@ pre-build:
do-install:
@${MKDIR} ${PREFIX}/bin/
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
@${MKDIR} ${PREFIX}/share/applications/
- @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications/
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications/
@${MKDIR} ${PREFIX}/share/pixmaps/
- @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.svg ${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.svg ${PREFIX}/share/pixmaps/
@${MKDIR} ${PREFIX}/man/man1/
- @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
.if ${PORT_OPTIONS:MNLS}
@${MKDIR} ${PREFIX}/share/locale/
- @(cd ${WRKSRC}/po/ && \
+ (cd ${WRKSRC}/po/ && \
${COPYTREE_SHARE} \* ${PREFIX}/share/locale/ "-name *.mo")
.endif
diff --git a/deskutils/easystroke/distinfo b/deskutils/easystroke/distinfo
index 73d60cd3b574..191d9b47d873 100644
--- a/deskutils/easystroke/distinfo
+++ b/deskutils/easystroke/distinfo
@@ -1,2 +1,2 @@
-SHA256 (easystroke-0.5.6.tar.gz) = aee0b9127610ea2b75d0d9ff056e804f059c2241e5e94eae49140268c7fc13ab
-SIZE (easystroke-0.5.6.tar.gz) = 111143
+SHA256 (easystroke-0.6.0.tar.gz) = f4c37adbc4dd405a24badb9e6be20d3223b4087ff9caed2c15ff71674051d0fd
+SIZE (easystroke-0.6.0.tar.gz) = 121358
diff --git a/deskutils/easystroke/files/patch-Makefile b/deskutils/easystroke/files/patch-Makefile
index b3a0b083fd35..8ce9ed6d85d8 100644
--- a/deskutils/easystroke/files/patch-Makefile
+++ b/deskutils/easystroke/files/patch-Makefile
@@ -1,14 +1,14 @@
---- Makefile.orig 2013-02-14 11:04:30.880047783 +0100
-+++ Makefile 2013-02-14 11:05:05.096047700 +0100
-@@ -78,9 +78,9 @@
+--- Makefile.orig 2013-05-18 19:53:39.780480687 +0200
++++ Makefile 2013-05-18 19:54:36.579483230 +0200
+@@ -82,9 +82,9 @@
easystroke.desktop: easystroke.desktop.in $(MOFILES)
intltool-merge po/ -d -u $< $@
-desktop.c: easystroke.desktop
+desktop.c:
echo "const char *desktop_file = \"\\" > $@
-- sed 's/Exec=easystroke/Exec=%s/' $< | sed 's/"/\\"/g' | sed 's/.*/&\\n\\/' >> $@
-+ sed 's/Exec=easystroke/Exec=%s/' easystroke.desktop | sed 's/"/\\"/g' | sed 's/.*/&\\n\\/' >> $@
+- sed 's/Exec=easystroke/Exec=%1$$s/' $< | sed 's/"/\\"/g' | sed 's/.*/&\\n\\/' >> $@
++ sed 's/Exec=easystroke/Exec=%1$$s/' easystroke.desktop | sed 's/"/\\"/g' | sed 's/.*/&\\n\\/' >> $@
echo "\";" >> $@
- dbus-server.cc: dbus-server.h
+ po/POTFILES.in: $(CCFILES) $(HFILES)
diff --git a/deskutils/easystroke/files/patch-main.cc b/deskutils/easystroke/files/patch-main.cc
deleted file mode 100644
index 443fb5665d92..000000000000
--- a/deskutils/easystroke/files/patch-main.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- main.cc~ 2012-10-06 08:07:11.000000000 +0200
-+++ main.cc 2013-02-12 17:29:51.103190380 +0100
-@@ -1350,7 +1350,7 @@
- config_dir += "/.easystroke";
- }
- struct stat st;
-- char *name = canonicalize_file_name(config_dir.c_str());
-+ char *name = realpath(config_dir.c_str(), NULL);
-
- // check if the directory does not exist
- if (lstat(name, &st) == -1) {