aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2016-05-22 00:10:19 +0800
committermadpilot <madpilot@FreeBSD.org>2016-05-22 00:10:19 +0800
commit4cf921a3272e6e989daf9bee408d3805153c324d (patch)
treefdb5cbcd55dff738034885c4535b0885b4bd78a7 /deskutils
parent8587c0b1c7dc165c7b88081b938ae0c0037e8e71 (diff)
downloadfreebsd-ports-gnome-4cf921a3272e6e989daf9bee408d3805153c324d.tar.gz
freebsd-ports-gnome-4cf921a3272e6e989daf9bee408d3805153c324d.tar.zst
freebsd-ports-gnome-4cf921a3272e6e989daf9bee408d3805153c324d.zip
- Update to 2.57.1
- Add patch to fix build on 9.3 i386 - While here regenerate some other patches
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/calibre/Makefile2
-rw-r--r--deskutils/calibre/distinfo5
-rw-r--r--deskutils/calibre/files/patch-setup_build__environment.py4
-rw-r--r--deskutils/calibre/files/patch-src_calibre_library_server_content.py4
-rw-r--r--deskutils/calibre/files/patch-src_calibre_utils_imageops_imageops.cpp15
-rw-r--r--deskutils/calibre/pkg-plist10
6 files changed, 30 insertions, 10 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index 7e4683fa6b0a..64ab70e11094 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= calibre
-PORTVERSION= 2.56.0
+PORTVERSION= 2.57.1
CATEGORIES= deskutils python
MASTER_SITES= http://download.calibre-ebook.com/${PORTVERSION}/
diff --git a/deskutils/calibre/distinfo b/deskutils/calibre/distinfo
index 1527543451a0..f5839e1d9caa 100644
--- a/deskutils/calibre/distinfo
+++ b/deskutils/calibre/distinfo
@@ -1,2 +1,3 @@
-SHA256 (calibre-2.56.0.tar.xz) = 52daf1d86400464d2f7681f4e5523e24bf3183bcaafa13176e511c4a8cd16577
-SIZE (calibre-2.56.0.tar.xz) = 39900812
+TIMESTAMP = 1463820745
+SHA256 (calibre-2.57.1.tar.xz) = 214070623c370886e54c8d3babefa1a33619469fd29a7cf6389dc5e098a8f32d
+SIZE (calibre-2.57.1.tar.xz) = 40495212
diff --git a/deskutils/calibre/files/patch-setup_build__environment.py b/deskutils/calibre/files/patch-setup_build__environment.py
index 11f12ea5080f..bf78f80baf70 100644
--- a/deskutils/calibre/files/patch-setup_build__environment.py
+++ b/deskutils/calibre/files/patch-setup_build__environment.py
@@ -1,6 +1,6 @@
---- setup/build_environment.py.orig 2015-02-20 03:34:13 UTC
+--- setup/build_environment.py.orig 2016-05-20 11:45:27 UTC
+++ setup/build_environment.py
-@@ -101,7 +101,7 @@ def get_sip_dir(q):
+@@ -103,7 +103,7 @@ def get_sip_dir(q):
if os.path.exists(os.path.join(base, 'QtWidgets')):
return base
raise EnvironmentError('Failed to find the location of the PyQt5 .sip files')
diff --git a/deskutils/calibre/files/patch-src_calibre_library_server_content.py b/deskutils/calibre/files/patch-src_calibre_library_server_content.py
index e0725ada0cf6..d3fe1e739c64 100644
--- a/deskutils/calibre/files/patch-src_calibre_library_server_content.py
+++ b/deskutils/calibre/files/patch-src_calibre_library_server_content.py
@@ -1,6 +1,6 @@
---- src/calibre/library/server/content.py.orig 2015-02-20 03:34:13 UTC
+--- src/calibre/library/server/content.py.orig 2016-05-20 11:45:27 UTC
+++ src/calibre/library/server/content.py
-@@ -111,6 +111,7 @@ class ContentServer(object):
+@@ -110,6 +110,7 @@ class ContentServer(object):
'png' : 'image/png',
'gif' : 'image/gif',
'html' : 'text/html',
diff --git a/deskutils/calibre/files/patch-src_calibre_utils_imageops_imageops.cpp b/deskutils/calibre/files/patch-src_calibre_utils_imageops_imageops.cpp
new file mode 100644
index 000000000000..3a5f15ef8b43
--- /dev/null
+++ b/deskutils/calibre/files/patch-src_calibre_utils_imageops_imageops.cpp
@@ -0,0 +1,15 @@
+--- src/calibre/utils/imageops/imageops.cpp.orig 2016-05-20 11:45:27 UTC
++++ src/calibre/utils/imageops/imageops.cpp
+@@ -582,9 +582,9 @@ QImage despeckle(const QImage &image) {
+
+ // overlay() {{{
+ static inline unsigned int BYTE_MUL(unsigned int x, unsigned int a) {
+- quint64 t = (((quint64(x)) | ((quint64(x)) << 24)) & 0x00ff00ff00ff00ff) * a;
+- t = (t + ((t >> 8) & 0xff00ff00ff00ff) + 0x80008000800080) >> 8;
+- t &= 0x00ff00ff00ff00ff;
++ quint64 t = (((quint64(x)) | ((quint64(x)) << 24)) & 0x00ff00ff00ff00ffULL) * a;
++ t = (t + ((t >> 8) & 0xff00ff00ff00ffULL) + 0x80008000800080ULL) >> 8;
++ t &= 0x00ff00ff00ff00ffULL;
+ return ((unsigned int)(t)) | ((unsigned int)(t >> 24));
+ }
+
diff --git a/deskutils/calibre/pkg-plist b/deskutils/calibre/pkg-plist
index c70972762cfd..f7c6c3bac611 100644
--- a/deskutils/calibre/pkg-plist
+++ b/deskutils/calibre/pkg-plist
@@ -770,7 +770,6 @@ lib/calibre/calibre/gui2/device_drivers/mtp_folder_browser.py
lib/calibre/calibre/gui2/dialogs/__init__.py
lib/calibre/calibre/gui2/dialogs/add_empty_book.py
lib/calibre/calibre/gui2/dialogs/add_from_isbn.py
-lib/calibre/calibre/gui2/dialogs/add_from_isbn_ui.py
lib/calibre/calibre/gui2/dialogs/authors_edit.py
lib/calibre/calibre/gui2/dialogs/book_info.py
lib/calibre/calibre/gui2/dialogs/catalog.py
@@ -1118,6 +1117,7 @@ lib/calibre/calibre/gui2/viewer/toc.py
lib/calibre/calibre/gui2/viewer/ui.py
lib/calibre/calibre/gui2/widgets.py
lib/calibre/calibre/gui2/widgets2.py
+lib/calibre/calibre/gui2/win_file_dialogs.py
lib/calibre/calibre/gui2/wizard/__init__.py
lib/calibre/calibre/gui2/wizard/device_ui.py
lib/calibre/calibre/gui2/wizard/finish_ui.py
@@ -1175,10 +1175,10 @@ lib/calibre/calibre/plugins/freetype.so
lib/calibre/calibre/plugins/html.so
lib/calibre/calibre/plugins/hunspell.so
lib/calibre/calibre/plugins/icu.so
+lib/calibre/calibre/plugins/imageops.so
lib/calibre/calibre/plugins/libheadless.so
lib/calibre/calibre/plugins/lzma_binding.so
lib/calibre/calibre/plugins/lzx.so
-lib/calibre/calibre/plugins/magick.so
lib/calibre/calibre/plugins/matcher.so
lib/calibre/calibre/plugins/monotonic.so
lib/calibre/calibre/plugins/msdes.so
@@ -1310,7 +1310,7 @@ lib/calibre/calibre/utils/logging.py
lib/calibre/calibre/utils/lru_cache.py
lib/calibre/calibre/utils/magick/__init__.py
lib/calibre/calibre/utils/magick/draw.py
-lib/calibre/calibre/utils/magick/generate.py
+lib/calibre/calibre/utils/magick/legacy.py
lib/calibre/calibre/utils/matcher.py
lib/calibre/calibre/utils/mdns.py
lib/calibre/calibre/utils/mem.py
@@ -1349,6 +1349,7 @@ lib/calibre/calibre/utils/smtp.py
lib/calibre/calibre/utils/smtplib.py
lib/calibre/calibre/utils/socket_inheritance.py
lib/calibre/calibre/utils/soupparser.py
+lib/calibre/calibre/utils/speedups.py
lib/calibre/calibre/utils/spell/__init__.py
lib/calibre/calibre/utils/terminal.py
lib/calibre/calibre/utils/text2int.py
@@ -1375,6 +1376,7 @@ lib/calibre/calibre/web/feeds/recipes/model.py
lib/calibre/calibre/web/feeds/templates.py
lib/calibre/calibre/web/fetch/__init__.py
lib/calibre/calibre/web/fetch/simple.py
+lib/calibre/calibre/web/fetch/utils.py
lib/calibre/chardet/__init__.py
lib/calibre/chardet/big5freq.py
lib/calibre/chardet/big5prober.py
@@ -1589,6 +1591,8 @@ lib/calibre/tinycss/version.py
%%DATADIR%%/content-server/index-generated.html
%%DATADIR%%/content-server/index.html
%%DATADIR%%/content-server/locales.zip
+%%DATADIR%%/content-server/mathjax.version
+%%DATADIR%%/content-server/mathjax.zip.xz
%%DATADIR%%/content-server/mobile.css
%%DATADIR%%/content-server/reset.css
%%DATADIR%%/content_server/av.jpg