aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-30 06:27:05 +0800
committerbapt <bapt@FreeBSD.org>2013-04-30 06:27:05 +0800
commit31426e557795495adeb04aa9e16edb4c93184379 (patch)
tree8583dfe71adaea6ce266633e1799cd602516b801 /deskutils
parentb36431c8212c7fe9fc83e2f7412d5935b6e10e6e (diff)
downloadfreebsd-ports-gnome-31426e557795495adeb04aa9e16edb4c93184379.tar.gz
freebsd-ports-gnome-31426e557795495adeb04aa9e16edb4c93184379.tar.zst
freebsd-ports-gnome-31426e557795495adeb04aa9e16edb4c93184379.zip
Convert a bunch of ports from WITHOUT_NLS -> ${PORT_OPTIONS:MNLS}
While here: - trim headers - convert to new options framework
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/bmp-docklet/Makefile16
-rw-r--r--deskutils/genius/Makefile18
-rw-r--r--deskutils/gimmie/Makefile10
-rw-r--r--deskutils/gxmessage/Makefile10
-rw-r--r--deskutils/kompose/Makefile16
-rw-r--r--deskutils/tpb/Makefile6
-rw-r--r--deskutils/vym/Makefile10
-rw-r--r--deskutils/x-tile/Makefile18
8 files changed, 48 insertions, 56 deletions
diff --git a/deskutils/bmp-docklet/Makefile b/deskutils/bmp-docklet/Makefile
index 567d89b2564c..d4b77542c144 100644
--- a/deskutils/bmp-docklet/Makefile
+++ b/deskutils/bmp-docklet/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bmp-docklet
-# Date created: 10 April, 2005
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
-#
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= bmp-docklet
PORTVERSION= 1.3
@@ -27,12 +23,14 @@ USE_GNOME= gnomehack intlhack
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment"
-.else
-USES= gettext
-PLIST_SUB+= NLS=""
.endif
.include <bsd.port.mk>
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index 2e78f71d9549..92200cf17c52 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: genius
-# Date created: 1 May 1999
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= genius
PORTVERSION= 1.0.12
@@ -33,13 +29,15 @@ USE_LDCONFIG= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USES= gettext
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
.include <bsd.port.mk>
diff --git a/deskutils/gimmie/Makefile b/deskutils/gimmie/Makefile
index ec63435d06fc..78f16b958d52 100644
--- a/deskutils/gimmie/Makefile
+++ b/deskutils/gimmie/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gimmie
-# Date created: 28 06 2006
-# Whom: pneumann@gmail.com
-#
+# Created by: pneumann@gmail.com
# $FreeBSD$
-#
PORTNAME= gimmie
PORTVERSION= 0.2.7
@@ -30,7 +26,9 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/deskutils/gxmessage/Makefile b/deskutils/gxmessage/Makefile
index cec130660640..902977e841d1 100644
--- a/deskutils/gxmessage/Makefile
+++ b/deskutils/gxmessage/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gxmessage
-# Date created: 9 March 2005
-# Whom: Andriy Gapon <avg@icyb.net.ua>
-#
+# Created by: Andriy Gapon <avg@icyb.net.ua>
# $FreeBSD$
-#
PORTNAME= gxmessage
PORTVERSION= 2.12.4
@@ -22,7 +18,9 @@ INSTALLS_ICONS= yes
MAKE_ARGS+= INSTALL="${INSTALL_PROGRAM}"
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
diff --git a/deskutils/kompose/Makefile b/deskutils/kompose/Makefile
index 1df407853fd7..f543992f1f95 100644
--- a/deskutils/kompose/Makefile
+++ b/deskutils/kompose/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: kompose
-# Date created: 31 Aug 2004
-# Whom: Lauri Watts <lauri@kde.org>
-#
+# Created by: Lauri Watts <lauri@kde.org>
# $FreeBSD$
-#
PORTNAME= kompose
PORTVERSION= 0.5.3
@@ -28,12 +24,14 @@ INSTALLS_ICONS= yes
DOCSDIR= share/doc/HTML/en/${PORTNAME}
-.if defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
-.else
-USES= gettext
-PLIST_SUB+= NLS=""
.endif
post-patch:
diff --git a/deskutils/tpb/Makefile b/deskutils/tpb/Makefile
index 5f3e0e0cea8a..c3812685ed69 100644
--- a/deskutils/tpb/Makefile
+++ b/deskutils/tpb/Makefile
@@ -23,7 +23,9 @@ CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}
MAN1= tpb.1
-.ifndef(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
@@ -39,7 +41,7 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/doc/tpbrc ${PREFIX}/etc/tpbrc.default
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_SCRIPT} ${WRKSRC}/doc/callback_example.sh ${DOCSDIR}
.endif
diff --git a/deskutils/vym/Makefile b/deskutils/vym/Makefile
index 0d86b37af453..da696b1aafdf 100644
--- a/deskutils/vym/Makefile
+++ b/deskutils/vym/Makefile
@@ -28,7 +28,9 @@ DESKTOP_ENTRIES= "VYM" \
"" \
false
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_QT4+= linguist_build
PLIST_SUB+= NLS=""
.else
@@ -36,12 +38,12 @@ PLIST_SUB+= NLS="@comment "
.endif
post-patch:
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e '/INSTALLS += doc/d' ${WRKSRC}/vym.pro
.endif
do-configure:
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
cd ${WRKSRC} && ${QT_LRELEASE} vym.pro
.endif
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
@@ -49,7 +51,7 @@ do-configure:
post-install:
${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
${MKDIR} ${DATADIR}/lang
${INSTALL_DATA} ${WRKSRC}/lang/*.qm ${DATADIR}/lang/
.endif
diff --git a/deskutils/x-tile/Makefile b/deskutils/x-tile/Makefile
index 9692d1fcc06b..2785e64d56da 100644
--- a/deskutils/x-tile/Makefile
+++ b/deskutils/x-tile/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: x-tile
-# Date created: 2010-09-17
-# Whom: Pedro Garcia Freitas <sawp@sawp.com.br>
-#
+# Created by: Pedro Garcia Freitas <sawp@sawp.com.br>
# $FreeBSD$
-#
PORTNAME= x-tile
PORTVERSION= 2.2.1
@@ -21,12 +17,9 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= X_Tile
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
- ${WRKSRC}/x-tile ${WRKSRC}/linux/x-tile.desktop \
- ${WRKSRC}/modules/cons.py
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
@@ -35,4 +28,9 @@ PYDISTUTILS_INSTALL_TARGET= --without-gettext install
PLIST_SUB+= NLS="@comment "
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
+ ${WRKSRC}/x-tile ${WRKSRC}/linux/x-tile.desktop \
+ ${WRKSRC}/modules/cons.py
+
.include <bsd.port.mk>