aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
committermarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
commit5cc9328814fb9b8e64ff3588af7e6031c1d3514b (patch)
treedf0b6bb8e4e84920da9881d421090dc67f70c629 /deskutils
parente058c31decaf84a24b7ab7306f65221b33ada080 (diff)
downloadfreebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.gz
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.zst
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.zip
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of the included version. To restore previous behavior, use the new macro, USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version. For example, to use the ports version of libtool-1.5, add the following to your Makefile: USE_LIBTOOL_VER= 15 To use the included version of libtool with extra hacks provided by libtool-1.5, add the following to your Makefile: USE_INC_LIBTOOL_VER= 15 With this change, ports that had to add additional libtool hacks to prevent .la files from being installed or to fix certain threading issues can now delete those hacks (after appropriate testing, of course). PR: 63944 Based on work by:eik and marcus Approved by: ade (autotools maintainer) Tested by: kris on pointyhat Bound to be hidden problems: You bet
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/glabels/Makefile2
-rw-r--r--deskutils/gtkjournal/Makefile2
-rw-r--r--deskutils/gucharmap/Makefile2
-rw-r--r--deskutils/kbirthday/Makefile2
-rw-r--r--deskutils/xfce4-calendar/Makefile2
-rw-r--r--deskutils/xfce4-notes-plugin/Makefile2
-rw-r--r--deskutils/xfce4-taskbar-plugin/Makefile2
-rw-r--r--deskutils/xfce4-windowlist-plugin/Makefile2
8 files changed, 8 insertions, 8 deletions
diff --git a/deskutils/glabels/Makefile b/deskutils/glabels/Makefile
index c33b7bfb66b4..7238dff88624 100644
--- a/deskutils/glabels/Makefile
+++ b/deskutils/glabels/Makefile
@@ -18,7 +18,7 @@ COMMENT= A program to create labels and business cards
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gnometarget libgnomeui libgnomeprintui
USE_GMAKE= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/deskutils/gtkjournal/Makefile b/deskutils/gtkjournal/Makefile
index e0ccb9c44acc..95ac7ec5faef 100644
--- a/deskutils/gtkjournal/Makefile
+++ b/deskutils/gtkjournal/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2 \
USE_X_PREFIX= yes
USE_OPENSSL= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GNOME= gnomehack lthack gnometarget
CONFIGURE_ARGS= --enable-gtkspell
INSTALLS_SHLIB= yes
diff --git a/deskutils/gucharmap/Makefile b/deskutils/gucharmap/Makefile
index 14c5d581b30f..b937daeebb1d 100644
--- a/deskutils/gucharmap/Makefile
+++ b/deskutils/gucharmap/Makefile
@@ -24,7 +24,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix intlhack gnomehack gtk20
WANT_GNOME= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/deskutils/kbirthday/Makefile b/deskutils/kbirthday/Makefile
index 1dea9f6bddb9..e06c01336f71 100644
--- a/deskutils/kbirthday/Makefile
+++ b/deskutils/kbirthday/Makefile
@@ -18,7 +18,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
# necesary to access the second master site by getting rid of the default switch -A
FETCH_CMD ?=/usr/bin/fetch -Rr
diff --git a/deskutils/xfce4-calendar/Makefile b/deskutils/xfce4-calendar/Makefile
index 2d6ab029e09d..b07b6a1432d0 100644
--- a/deskutils/xfce4-calendar/Makefile
+++ b/deskutils/xfce4-calendar/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
USE_GNOME= gtk20 libxml2
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/deskutils/xfce4-notes-plugin/Makefile b/deskutils/xfce4-notes-plugin/Makefile
index daaf0f735b3b..23251db1a9a4 100644
--- a/deskutils/xfce4-notes-plugin/Makefile
+++ b/deskutils/xfce4-notes-plugin/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GNOME= gtk20 libxml2
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/deskutils/xfce4-taskbar-plugin/Makefile b/deskutils/xfce4-taskbar-plugin/Makefile
index 70fa5d478766..49edb850bccf 100644
--- a/deskutils/xfce4-taskbar-plugin/Makefile
+++ b/deskutils/xfce4-taskbar-plugin/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GNOME= gtk20 libxml2
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/deskutils/xfce4-windowlist-plugin/Makefile b/deskutils/xfce4-windowlist-plugin/Makefile
index 19e0c0fe7924..9b184471da56 100644
--- a/deskutils/xfce4-windowlist-plugin/Makefile
+++ b/deskutils/xfce4-windowlist-plugin/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
USE_GNOME= gtk20 libxml2
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${PORTNAME}