aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2011-09-13 06:04:49 +0800
committerbeech <beech@FreeBSD.org>2011-09-13 06:04:49 +0800
commita7774113e0610ee57afce4017ce876c10436a577 (patch)
tree194e9d6f4ad2f5b8950e8a3a093e97df11448b2d /deskutils
parente63fc391d7ca81dcd5e0c491ad0bea3c6484757c (diff)
downloadfreebsd-ports-gnome-a7774113e0610ee57afce4017ce876c10436a577.tar.gz
freebsd-ports-gnome-a7774113e0610ee57afce4017ce876c10436a577.tar.zst
freebsd-ports-gnome-a7774113e0610ee57afce4017ce876c10436a577.zip
- Update to 2.2.0
PR: ports/160680 Submitted by: Veniamin Gvozdikov <g.veniamin@googlemail.com> (maintainer)
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/conkyforecast/Makefile25
-rw-r--r--deskutils/conkyforecast/distinfo4
-rw-r--r--deskutils/conkyforecast/files/patch-conkyForecast24
-rw-r--r--deskutils/conkyforecast/files/patch-conkyForecast-SunsetSunriseCountdown21
-rw-r--r--deskutils/conkyforecast/files/patch-conkyForecast.py6
-rw-r--r--deskutils/conkyforecast/pkg-plist36
6 files changed, 96 insertions, 20 deletions
diff --git a/deskutils/conkyforecast/Makefile b/deskutils/conkyforecast/Makefile
index 0952c93e0bb9..408f200df79e 100644
--- a/deskutils/conkyforecast/Makefile
+++ b/deskutils/conkyforecast/Makefile
@@ -6,18 +6,20 @@
#
PORTNAME= conkyforecast
-PORTVERSION= 2.09
-PORTREVISION= 1
+PORTVERSION= 2.20
CATEGORIES= deskutils
-MASTER_SITES= http://launchpadlibrarian.net/37518633/ \
+MASTER_SITES= https://launchpadlibrarian.net/70673352/ \
http://fbsd.zlonet.ru/distfiles/
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= g.veniamin@googlemail.com
COMMENT= Weather forecast script for conky
+LICENSE= GPLv3
+
BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= conky:${PORTSDIR}/sysutils/conky \
+ pidof:${PORTSDIR}/sysutils/pidof \
fc-cache:${PORTSDIR}/x11-fonts/fontconfig
USE_PYTHON= yes
@@ -33,8 +35,21 @@ WRKSRC= ${WRKDIR}/src
post-patch:
@cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,/usr/share/${PORTNAME},${DATADIR},g' \
- setup.py test/conkyrc example/conkyrc conkyForecast.py conkyForecast
- @cd ${WRKSRC} && ${RM} -fr test/conkyrc.bak example/conkyrc.bak
+ setup.py \
+ test/conkyForecast.test.conkyrc \
+ test/conkyForecast.test.sh \
+ example/conkyForecast.fontbased.sh \
+ example/conkyForecast.fontbasedtemplate.conkyrc \
+ example/conkyForecast.fontbasedtemplate.sh \
+ example/conkyForecast.imagebasedtemplate.conkyrc \
+ example/conkyForecast.imagebasedtemplate.sh \
+ conkyForecast.py \
+ conkyForecast \
+ conkyForecast-SunsetSunriseCountdown
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's,/usr/bin/python,/usr/bin/env,g' \
+ conkyForecast \
+ conkyForecast-SunsetSunriseCountdown
+ @cd ${WRKSRC} && ${RM} -fr test/*.bak example/*.bak
post-install:
@${MKDIR} ${FONTSDIR}
diff --git a/deskutils/conkyforecast/distinfo b/deskutils/conkyforecast/distinfo
index e2332b95ad60..e445fe36d3c6 100644
--- a/deskutils/conkyforecast/distinfo
+++ b/deskutils/conkyforecast/distinfo
@@ -1,2 +1,2 @@
-SHA256 (conkyforecast_2.09.tar.gz) = a7c196f9cb05e76098ff27149c34f634e0baaf8bf895e58156d3200135dd28cc
-SIZE (conkyforecast_2.09.tar.gz) = 11029079
+SHA256 (conkyforecast_2.20.tar.gz) = 884e49409459af50255cffc76d2231c8d0c49744d30863ccabe7737c042b2c2b
+SIZE (conkyforecast_2.20.tar.gz) = 11097961
diff --git a/deskutils/conkyforecast/files/patch-conkyForecast b/deskutils/conkyforecast/files/patch-conkyForecast
index 43174f186f89..eaa81ba50e9f 100644
--- a/deskutils/conkyforecast/files/patch-conkyForecast
+++ b/deskutils/conkyforecast/files/patch-conkyForecast
@@ -1,7 +1,21 @@
---- conkyForecast.orig 2010-01-07 05:02:45.000000000 +0700
-+++ conkyForecast 2010-05-07 02:07:30.000000000 +0800
-@@ -1,3 +1,3 @@
+--- conkyForecast.orig 2011-09-12 18:05:15.686489911 +0400
++++ conkyForecast 2011-09-12 18:05:39.133432190 +0400
+@@ -1,17 +1,6 @@
#! /bin/sh
cd /usr/share/conkyforecast/
--$PYTHONPATH /usr/bin/python /usr/share/conkyforecast/conkyForecast.py "$@"
-+$PYTHONPATH /usr/bin/env python /usr/share/conkyforecast/conkyForecast.py "$@"
+
+-if [ -f /usr/bin/python2 ]; then
+- pythoncmd="/usr/bin/python2"
+-elif [ -f /usr/bin/python2.7 ] ; then
+- pythoncmd="/usr/bin/python2.7"
+-elif [ -f /usr/bin/python2.6 ] ; then
+- pythoncmd="/usr/bin/python2.6"
+-else
+- # here's hoping!
+- pythoncmd="/usr/bin/python"
+-fi
+-
+ pythonfile="/usr/share/conkyforecast/conkyForecast.py"
+
+-exec $pythoncmd $pythonfile "$@"
++/usr/bin/env python $pythonfile "$@"
diff --git a/deskutils/conkyforecast/files/patch-conkyForecast-SunsetSunriseCountdown b/deskutils/conkyforecast/files/patch-conkyForecast-SunsetSunriseCountdown
new file mode 100644
index 000000000000..f33256471011
--- /dev/null
+++ b/deskutils/conkyforecast/files/patch-conkyForecast-SunsetSunriseCountdown
@@ -0,0 +1,21 @@
+--- conkyForecast-SunsetSunriseCountdown.orig 2011-09-12 18:04:11.318676684 +0400
++++ conkyForecast-SunsetSunriseCountdown 2011-09-12 18:04:42.204794053 +0400
+@@ -1,17 +1,6 @@
+ #! /bin/sh
+ cd /usr/share/conkyforecast/
+
+-if [ -f /usr/bin/python2 ]; then
+- pythoncmd="/usr/bin/python2"
+-elif [ -f /usr/bin/python2.7 ] ; then
+- pythoncmd="/usr/bin/python2.7"
+-elif [ -f /usr/bin/python2.6 ] ; then
+- pythoncmd="/usr/bin/python2.6"
+-else
+- # here's hoping!
+- pythoncmd="/usr/bin/python"
+-fi
+-
+ pythonfile="/usr/share/conkyforecast/conkyForecast-SunsetSunriseCountdown.py"
+
+-exec $pythoncmd $pythonfile "$@"
++/usr/bin/env python $pythonfile "$@"
diff --git a/deskutils/conkyforecast/files/patch-conkyForecast.py b/deskutils/conkyforecast/files/patch-conkyForecast.py
index 6db19cb424f2..0c10fd659c95 100644
--- a/deskutils/conkyforecast/files/patch-conkyForecast.py
+++ b/deskutils/conkyforecast/files/patch-conkyForecast.py
@@ -1,7 +1,7 @@
---- conkyForecast.py.orig 2010-01-07 05:02:45.000000000 +0700
-+++ conkyForecast.py 2010-05-07 01:54:00.000000000 +0800
+--- conkyForecast.py.orig 2011-09-12 16:53:29.846760560 +0400
++++ conkyForecast.py 2011-09-12 16:53:37.428868063 +0400
@@ -1,4 +1,4 @@
--#!/usr/bin/python
+-#!/usr/bin/env python2
+#!/usr/bin/env python
# -*- coding: utf-8 -*-
###############################################################################
diff --git a/deskutils/conkyforecast/pkg-plist b/deskutils/conkyforecast/pkg-plist
index 46cd08a750bc..21cab200682c 100644
--- a/deskutils/conkyforecast/pkg-plist
+++ b/deskutils/conkyforecast/pkg-plist
@@ -1,9 +1,7 @@
bin/conkyForecast
+bin/conkyForecast-SunsetSunriseCountdown
%%DATADIR%%/conkyForecast.config
-%%DATADIR%%/conkyForecast.pot
%%DATADIR%%/conkyForecast.py
-%%DATADIR%%/example/conkyForecast.template
-%%DATADIR%%/example/conkyrc
%%FONTSDIR%%/Arrows.sfd.tar.gz
%%FONTSDIR%%/Arrows.ttf
%%FONTSDIR%%/ConkyWeather.otf
@@ -168,15 +166,43 @@ bin/conkyForecast
%%DATADIR%%/locale/fr/LC_MESSAGES/conkyForecast.po
%%DATADIR%%/locale/it/LC_MESSAGES/conkyForecast.mo
%%DATADIR%%/locale/it/LC_MESSAGES/conkyForecast.po
+%%DATADIR%%/locale/lt/LC_MESSAGES/conkyForecast.mo
+%%DATADIR%%/locale/lt/LC_MESSAGES/conkyForecast.po
+%%DATADIR%%/locale/locale_codes.txt
%%DATADIR%%/locale/nl/LC_MESSAGES/conkyForecast.mo
%%DATADIR%%/locale/nl/LC_MESSAGES/conkyForecast.po
%%DATADIR%%/locale/pl/LC_MESSAGES/conkyForecast.mo
%%DATADIR%%/locale/pl/LC_MESSAGES/conkyForecast.po
%%DATADIR%%/locale/ro/LC_MESSAGES/conkyForecast.mo
%%DATADIR%%/locale/ro/LC_MESSAGES/conkyForecast.po
-%%DATADIR%%/test/conkyForecast.template
-%%DATADIR%%/test/conkyrc
+%%DATADIR%%/locale/sk/LC_MESSAGES/conkyForecast.po
+%%DATADIR%%/locale/sk/LC_MESSAGES/conkyForecast.mo
+%%DATADIR%%/locale/conkyForecast.pot
+%%DATADIR%%/locale/sv/LC_MESSAGES/conkyForecast.po
+%%DATADIR%%/locale/sv/LC_MESSAGES/conkyForecast.mo
+%%DATADIR%%/locale/zh/LC_MESSAGES/conkyForecast.mo
+%%DATADIR%%/locale/zh/LC_MESSAGES/conkyForecast.po
+%%DATADIR%%/test/conkyForecast.test.sh
+%%DATADIR%%/test/conkyForecast.test.template
+%%DATADIR%%/test/conkyForecast.test.conkyrc
+%%DATADIR%%/example/conkyForecast.fontbased.sh
+%%DATADIR%%/example/conkyForecast.imagebasedtemplate.template
+%%DATADIR%%/example/conkyForecast.imagebasedtemplate.conkyrc
+%%DATADIR%%/example/conkyForecast.fontbased.conkyrc
+%%DATADIR%%/example/conkyForecast.imagebasedtemplate.sh
+%%DATADIR%%/example/conkyForecast.fontbasedtemplate.template
+%%DATADIR%%/example/conkyForecast.fontbasedtemplate.sh
+%%DATADIR%%/example/conkyForecast.fontbasedtemplate.conkyrc
+%%DATADIR%%/conkyForecast-SunsetSunriseCountdown.py
@dirrm %%DATADIR%%/test
+@dirrm %%DATADIR%%/locale/zh/LC_MESSAGES
+@dirrm %%DATADIR%%/locale/zh
+@dirrm %%DATADIR%%/locale/sv/LC_MESSAGES
+@dirrm %%DATADIR%%/locale/sv
+@dirrm %%DATADIR%%/locale/sk/LC_MESSAGES
+@dirrm %%DATADIR%%/locale/sk
+@dirrm %%DATADIR%%/locale/lt/LC_MESSAGES
+@dirrm %%DATADIR%%/locale/lt
@dirrm %%DATADIR%%/locale/ro/LC_MESSAGES
@dirrm %%DATADIR%%/locale/ro
@dirrm %%DATADIR%%/locale/pl/LC_MESSAGES