aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ChipmunkPhysics
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2012-12-28 23:57:37 +0800
committerbdrewery <bdrewery@FreeBSD.org>2012-12-28 23:57:37 +0800
commite48a759bd77e6dccfced794d597deaf8f22e2147 (patch)
treea9605de00c24d9bf8ee72ecf682ebb22fde0d3c9 /devel/ChipmunkPhysics
parentb6c2bfdd58e82e7c64795bc2798b14ad2115aba7 (diff)
downloadfreebsd-ports-gnome-e48a759bd77e6dccfced794d597deaf8f22e2147.tar.gz
freebsd-ports-gnome-e48a759bd77e6dccfced794d597deaf8f22e2147.tar.zst
freebsd-ports-gnome-e48a759bd77e6dccfced794d597deaf8f22e2147.zip
Chipmunk is a simple, lightweight, fast and portable 2D rigid body physics
library written in C. It's licensed under the unrestrictive, OSI approved MIT license. WWW: http://chipmunk-physics.net/ PR: ports/174465 Submitted by: "Tim &#268;as" <ports@stdrand.com>
Diffstat (limited to 'devel/ChipmunkPhysics')
-rw-r--r--devel/ChipmunkPhysics/Makefile23
-rw-r--r--devel/ChipmunkPhysics/distinfo2
-rw-r--r--devel/ChipmunkPhysics/pkg-descr5
-rw-r--r--devel/ChipmunkPhysics/pkg-plist30
4 files changed, 60 insertions, 0 deletions
diff --git a/devel/ChipmunkPhysics/Makefile b/devel/ChipmunkPhysics/Makefile
new file mode 100644
index 000000000000..37d5caaaa50c
--- /dev/null
+++ b/devel/ChipmunkPhysics/Makefile
@@ -0,0 +1,23 @@
+# Created by: Tim Cas <ports@stdrand.com>
+# $FreeBSD$
+
+PORTNAME= ChipmunkPhysics
+PORTVERSION= 6.1.2
+CATEGORIES= devel
+MASTER_SITES= http://chipmunk-physics.net/release/Chipmunk-6.x/ \
+ http://files.libsiege.org/chipmunk/
+DISTNAME= Chipmunk-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@stdrand.com
+COMMENT= 2D physics engine written in C
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USE_CMAKE= yes
+CMAKE_ARGS= -DBUILD_DEMOS=OFF
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/ChipmunkPhysics/distinfo b/devel/ChipmunkPhysics/distinfo
new file mode 100644
index 000000000000..d7a6fbac94b3
--- /dev/null
+++ b/devel/ChipmunkPhysics/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Chipmunk-6.1.2.tgz) = f9d3e7d2480e50b034081613c18fa90421d5bf002af813ef1443e832dac43fc2
+SIZE (Chipmunk-6.1.2.tgz) = 324892
diff --git a/devel/ChipmunkPhysics/pkg-descr b/devel/ChipmunkPhysics/pkg-descr
new file mode 100644
index 000000000000..683adb82ba97
--- /dev/null
+++ b/devel/ChipmunkPhysics/pkg-descr
@@ -0,0 +1,5 @@
+Chipmunk is a simple, lightweight, fast and portable 2D rigid body physics
+library written in C. It's licensed under the unrestrictive, OSI approved MIT
+license.
+
+WWW: http://chipmunk-physics.net/
diff --git a/devel/ChipmunkPhysics/pkg-plist b/devel/ChipmunkPhysics/pkg-plist
new file mode 100644
index 000000000000..78008b03a6a7
--- /dev/null
+++ b/devel/ChipmunkPhysics/pkg-plist
@@ -0,0 +1,30 @@
+lib/libchipmunk.so.6.1.2
+lib/libchipmunk.so
+lib/libchipmunk.a
+include/chipmunk/cpBody.h
+include/chipmunk/chipmunk_unsafe.h
+include/chipmunk/cpVect.h
+include/chipmunk/cpSpatialIndex.h
+include/chipmunk/chipmunk_ffi.h
+include/chipmunk/chipmunk.h
+include/chipmunk/cpShape.h
+include/chipmunk/cpSpace.h
+include/chipmunk/cpPolyShape.h
+include/chipmunk/chipmunk_types.h
+include/chipmunk/cpArbiter.h
+include/chipmunk/cpBB.h
+include/chipmunk/chipmunk_private.h
+include/chipmunk/constraints/cpConstraint.h
+include/chipmunk/constraints/util.h
+include/chipmunk/constraints/cpGearJoint.h
+include/chipmunk/constraints/cpGrooveJoint.h
+include/chipmunk/constraints/cpSlideJoint.h
+include/chipmunk/constraints/cpDampedRotarySpring.h
+include/chipmunk/constraints/cpPivotJoint.h
+include/chipmunk/constraints/cpDampedSpring.h
+include/chipmunk/constraints/cpRatchetJoint.h
+include/chipmunk/constraints/cpSimpleMotor.h
+include/chipmunk/constraints/cpRotaryLimitJoint.h
+include/chipmunk/constraints/cpPinJoint.h
+@dirrm include/chipmunk/constraints
+@dirrm include/chipmunk