aboutsummaryrefslogtreecommitdiffstats
path: root/devel/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-03-05 09:23:05 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-03-05 09:23:05 +0800
commit62cd3d615e13f33a45530c267d5ac5ad358e5d44 (patch)
treecb0889bb434c43fc3014fa2aef21028527e95da6 /devel/Makefile
parentd7dd301692440ac34f2b939d8d7c5910300b7df4 (diff)
downloadfreebsd-ports-gnome-62cd3d615e13f33a45530c267d5ac5ad358e5d44.tar.gz
freebsd-ports-gnome-62cd3d615e13f33a45530c267d5ac5ad358e5d44.tar.zst
freebsd-ports-gnome-62cd3d615e13f33a45530c267d5ac5ad358e5d44.zip
- Add p5-Lexical-Import 0.002
Lexical::Import allows functions and other items, from a separate module, to be imported into the lexical namespace (as implemented by Lexical::Var), when the exporting module exports non-lexically to a package in the traditional manner. This is a translation layer, to help code written in the new way to use modules written in the old way. A lexically-imported item takes effect from the end of the definition statement up to the end of the immediately enclosing block, except where it is shadowed within a nested block. This is the same lexical scoping that the my, our, and state keywords supply. Within its scope, any use of the single-part name of the item (e.g., "$foo") refers directly to that item, regardless of what is in any package. Explicitly package-qualified names (e.g., "$main::foo") still refer to the package. There is no conflict between a lexical name definition and the same name in any package. This mechanism only works on Perl 5.11.2 and later. Prior to that, it is impossible for lexical subroutine imports to work for bareword subroutine calls. (See "BUGS" in Lexical::Var for details.) Other kinds of lexical importing are possible on earlier Perls, but because this is such a critical kind of usage in most code, this module will ensure that it works, for convenience. If the limited lexical importing is desired on earlier Perls, use Lexical::Var directly. WWW: http://search.cpan.org/dist/Lexical-Import/
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 315bfadb8924..4805f4c9f730 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1963,6 +1963,7 @@
SUBDIR += p5-Java
SUBDIR += p5-Jonk
SUBDIR += p5-Lexical-Alias
+ SUBDIR += p5-Lexical-Import
SUBDIR += p5-Lexical-Persistence
SUBDIR += p5-Lexical-SealRequireHints
SUBDIR += p5-Lexical-Var