aboutsummaryrefslogtreecommitdiffstats
path: root/devel/Makefile
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2004-11-19 22:31:35 +0800
committerhq <hq@FreeBSD.org>2004-11-19 22:31:35 +0800
commitd757e7ca00d9e44da489d8849c25afa8c2a7d2cb (patch)
tree0ca56254d8932ee557cca998e472cf9d7e882613 /devel/Makefile
parent96a4c42de7fc9879bfc93ce787d18e60396189f4 (diff)
downloadfreebsd-ports-gnome-d757e7ca00d9e44da489d8849c25afa8c2a7d2cb.tar.gz
freebsd-ports-gnome-d757e7ca00d9e44da489d8849c25afa8c2a7d2cb.tar.zst
freebsd-ports-gnome-d757e7ca00d9e44da489d8849c25afa8c2a7d2cb.zip
This package provides standardized, efficient versions of utility classes
commonly encountered in concurrent Java programming. This code consists of implementations of ideas that have been around for ages, and is merely intended to save you the trouble of coding them. The package mainly consists of implementations of a few interfaces: * Sync -- locks, conditions * Channel -- queues, buffers * Barrier -- multi-party synchronization * SynchronizedVariable -- atomic ints, refs etc * java.util.Collection -- collections * Executor -- replacements for direct use of Thread Plus some utilities and frameworks that build upon these. This package was the precursor to java.util.concurrent. WWW: http://gee.cs.oswego.edu/dl/classes/EDU/oswego/cs/dl/util/concurrent/intro.html
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7f6027c6931a..782ec3128aec 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -358,6 +358,7 @@
SUBDIR += ixlib
SUBDIR += jakelib2
SUBDIR += jam
+ SUBDIR += java-util-concurrent
SUBDIR += jclassinfo
SUBDIR += jrtplib
SUBDIR += jude_take