aboutsummaryrefslogtreecommitdiffstats
path: root/devel/Makefile
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2004-04-05 00:24:47 +0800
committerlinimon <linimon@FreeBSD.org>2004-04-05 00:24:47 +0800
commitd0ae89a0097a890c5dc626275c3031594b6e086d (patch)
tree45ed7c2aa65e2362180a3cc5bbdca5d3443fd2c2 /devel/Makefile
parentc2f4225b382ddc71518df30e541c35f38aa158d9 (diff)
downloadfreebsd-ports-gnome-d0ae89a0097a890c5dc626275c3031594b6e086d.tar.gz
freebsd-ports-gnome-d0ae89a0097a890c5dc626275c3031594b6e086d.tar.zst
freebsd-ports-gnome-d0ae89a0097a890c5dc626275c3031594b6e086d.zip
Apache Avalon provides a complete platform for component programming including
a core framework, utilities, tools, components and containers. By using key design patterns such as Inversion of Control (IoC) and Seperation of Concerns (SoC), Avalon achieves a number of advantages over traditional object oriented programming frameworks: * No implementation lock * Low coupling between components * Component lifecycle management * Configuration management and easy to use API * Component meta-data framework and tools * Service dependecy management * Embeddable containers for standalone, J2EE and web environments The Avalon Framework API and Implementation consists of interfaces that define relationships between commonly used application components, best-of-practice pattern enforcements, and several lightweight convenience implementations of the generic components. WWW: http://avalon.apache.org/framework/ PR: ports/64999 Submitted by: Herve Quiroz <herve.quiroz@esil.univ-mrs.fr>
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 820f5aa74d61..33c0660935e0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -67,6 +67,7 @@
SUBDIR += automake14
SUBDIR += automake17
SUBDIR += automake18
+ SUBDIR += avalon-framework
SUBDIR += avarice
SUBDIR += avltree
SUBDIR += avr-binutils