aboutsummaryrefslogtreecommitdiffstats
path: root/devel/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-12-06 05:13:31 +0800
committerkrion <krion@FreeBSD.org>2003-12-06 05:13:31 +0800
commitb75c8d2b0afbe598831a5945795a6a5bcdfae4cf (patch)
tree13a3dc3182a0dab9627271f252273f07332ff02f /devel/Makefile
parent6ec1930b6cc7b0d48b6260568d29dfc397426d74 (diff)
downloadfreebsd-ports-gnome-b75c8d2b0afbe598831a5945795a6a5bcdfae4cf.tar.gz
freebsd-ports-gnome-b75c8d2b0afbe598831a5945795a6a5bcdfae4cf.tar.zst
freebsd-ports-gnome-b75c8d2b0afbe598831a5945795a6a5bcdfae4cf.zip
OpenTop contains framework classes that provide the features
you need to write network-centric, web-enabled and internationalized applications in C++. It enables you to: * create network clients and servers using either raw socket facilities or higher-level protocols such as HTTP and FTP. * create multi-threaded applications and manage synchronization between threads using simple but effective threading abstractions which are common to all platforms. * use the full Unicode character range, using built-in character types and standard string classes. * use byte and character streams and manipulate files using an API inspired by the excellent java.io package. * take advantage of its open architecture by registering your own (or third-party) classes to perform custom processing. * write portable applications and extension libraries. OpenTop is an ideal base on which to deliver cross-platform solutions, benefitting independent software vendors and corporate IT departments. * integrate XML into your C++ applications with the C++ XML Toolkit extension library. PR: 59887 Submitted by: Sergey Matveychuk <sem@ciam.ru>
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b79e5782a5ff..399cbd672118 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -486,6 +486,7 @@
SUBDIR += omniORB
SUBDIR += oniguruma
SUBDIR += openthreads
+ SUBDIR += opentop
SUBDIR += openzz
SUBDIR += orbitcpp
SUBDIR += ossp-al