aboutsummaryrefslogtreecommitdiffstats
path: root/devel/Makefile
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-05-19 12:19:15 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-05-19 12:19:15 +0800
commitc200c3191cc037d3006be36b646659cdc8c1e22e (patch)
treee05b8203a922050e4b3dfe91a95bbdc8d6dfd297 /devel/Makefile
parent192e35e2c25550f44fb57657438291df7723a65b (diff)
downloadfreebsd-ports-gnome-c200c3191cc037d3006be36b646659cdc8c1e22e.tar.gz
freebsd-ports-gnome-c200c3191cc037d3006be36b646659cdc8c1e22e.tar.zst
freebsd-ports-gnome-c200c3191cc037d3006be36b646659cdc8c1e22e.zip
Lutok is a lightweight C++ API library for Lua.
Lutok provides thin C++ wrappers around the Lua C API to ease the interaction between C++ and Lua. These wrappers make intensive use of RAII to prevent resource leakage, expose C++-friendly data types, report errors by means of exceptions and ensure that the Lua stack is always left untouched in the face of errors. The library also provides a small subset of miscellaneous utility functions built on top of the wrappers. Lutok focuses on providing a clean and safe C++ interface; the drawback is that it is not suitable for performance-critical environments. In order to implement error-safe C++ wrappers on top of a Lua C binary library, Lutok adds several layers or abstraction and error checking that go against the original spirit of the Lua C API and thus degrade performance. WWW: https://code.google.com/p/lutok/ PR: ports/177639 Submitted by: Alan Somers <asomers@FreeBSD.org>
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index df448f7fea9a..bbc9c7c2daad 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1193,6 +1193,7 @@
SUBDIR += luabind
SUBDIR += luafilesystem
SUBDIR += luajava
+ SUBDIR += lutok
SUBDIR += lwp
SUBDIR += lxr
SUBDIR += m17n-db