aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ORBit2/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>1998-08-19 14:15:08 +0800
committervanilla <vanilla@FreeBSD.org>1998-08-19 14:15:08 +0800
commit83aa59fcd2199a7d1bc9e920f1cd21c857d8f81e (patch)
tree51cf60fa91047f6b9d07129b2de4b120d3b19148 /devel/ORBit2/Makefile
parentccce353095a0d29dec0b944237053cf403480efb (diff)
downloadfreebsd-ports-gnome-83aa59fcd2199a7d1bc9e920f1cd21c857d8f81e.tar.gz
freebsd-ports-gnome-83aa59fcd2199a7d1bc9e920f1cd21c857d8f81e.tar.zst
freebsd-ports-gnome-83aa59fcd2199a7d1bc9e920f1cd21c857d8f81e.zip
ORBit is a high-performance CORBA ORB with support for the C language.
It is used by the GNOME Project. PR: ports/7654 Submitted by: Chia-liang Kao <clkao@cirx.org>
Diffstat (limited to 'devel/ORBit2/Makefile')
-rw-r--r--devel/ORBit2/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/ORBit2/Makefile b/devel/ORBit2/Makefile
new file mode 100644
index 000000000000..fd59f2f29157
--- /dev/null
+++ b/devel/ORBit2/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: orbit
+# Version required: 0.2.1
+# Date Created: 16 Aug 1998
+# Whom: Chia-liang Kao <clkao@CirX.ORG>
+#
+# $Id$
+#
+
+DISTNAME= ORBit-0.2.1
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.gnome.org/pub/ORBit/
+
+MAINTAINER= clkao@CirX.ORG
+
+LIB_DEPENDS= glib11\\.0\\.:${PORTSDIR}/devel/glib
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ENV= INSTALL='$${INSTALL} -c'
+CONFIGURE_ARGS= --disable-indent
+
+post-install:
+ ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>