aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ORBit2
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-04-26 15:45:59 +0800
committersobomax <sobomax@FreeBSD.org>2002-04-26 15:45:59 +0800
commit7c0d5e385b49cdbbfa49aa2b36a8a1bcebe77c17 (patch)
tree5469d1f5213035912a19b861ea7a63b579709772 /devel/ORBit2
parent93ec8b9c310e122b17a4f8c84d336ccd5486af97 (diff)
downloadfreebsd-ports-gnome-7c0d5e385b49cdbbfa49aa2b36a8a1bcebe77c17.tar.gz
freebsd-ports-gnome-7c0d5e385b49cdbbfa49aa2b36a8a1bcebe77c17.tar.zst
freebsd-ports-gnome-7c0d5e385b49cdbbfa49aa2b36a8a1bcebe77c17.zip
- Update to 2.3.108 (version from GNOME2 beta4);
- use USE_LIBTOOL.
Diffstat (limited to 'devel/ORBit2')
-rw-r--r--devel/ORBit2/Makefile6
-rw-r--r--devel/ORBit2/distinfo2
-rw-r--r--devel/ORBit2/files/patch-configure13
-rw-r--r--devel/ORBit2/files/patch-ltmain.sh45
4 files changed, 17 insertions, 49 deletions
diff --git a/devel/ORBit2/Makefile b/devel/ORBit2/Makefile
index 6889eee5b341..7f235abd961d 100644
--- a/devel/ORBit2/Makefile
+++ b/devel/ORBit2/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= ORBit2
-PORTVERSION= 2.3.107
+PORTVERSION= 2.3.108
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta4
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -21,7 +21,7 @@ LIB_DEPENDS= IDL-2.0:${PORTSDIR}/devel/libIDL \
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ARGS= --disable-indent
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/devel/ORBit2/distinfo b/devel/ORBit2/distinfo
index 1ab4745b30a8..3d1e2ae5af37 100644
--- a/devel/ORBit2/distinfo
+++ b/devel/ORBit2/distinfo
@@ -1 +1 @@
-MD5 (gnome2/ORBit2-2.3.107.tar.bz2) = ef5a236d51993ac6f16a34229b21a870
+MD5 (gnome2/ORBit2-2.3.108.tar.bz2) = 0e75116b7234e4265d18eac574d89471
diff --git a/devel/ORBit2/files/patch-configure b/devel/ORBit2/files/patch-configure
new file mode 100644
index 000000000000..3c4e6cd0faf9
--- /dev/null
+++ b/devel/ORBit2/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure 2002/04/26 07:38:33 1.1
++++ configure 2002/04/26 07:38:42
+@@ -6201,6 +6201,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/devel/ORBit2/files/patch-ltmain.sh b/devel/ORBit2/files/patch-ltmain.sh
deleted file mode 100644
index 91713d2306f8..000000000000
--- a/devel/ORBit2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,45 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh.orig Wed Jan 23 11:38:40 2002
-+++ ltmain.sh Sun Feb 3 01:44:17 2002
-@@ -1037,8 +1037,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -2412,6 +2420,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4179,10 +4190,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"