aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ace+tao
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-06 19:59:23 +0800
committerkrion <krion@FreeBSD.org>2004-03-06 19:59:23 +0800
commitaff9f228f7b8e1b7145fbadfc718c457c42db00f (patch)
tree11e352b84a6a7ad8a10c7773c0424c734a18affb /devel/ace+tao
parenta1c65473d8ccaba08cd138b99b9ca5c31c319fc8 (diff)
downloadfreebsd-ports-gnome-aff9f228f7b8e1b7145fbadfc718c457c42db00f.tar.gz
freebsd-ports-gnome-aff9f228f7b8e1b7145fbadfc718c457c42db00f.tar.zst
freebsd-ports-gnome-aff9f228f7b8e1b7145fbadfc718c457c42db00f.zip
- Use more right way to link library
PR: ports/63820 Submitted by: maintainer
Diffstat (limited to 'devel/ace+tao')
-rw-r--r--devel/ace+tao/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/ace+tao/Makefile b/devel/ace+tao/Makefile
index 51b14e1fa2b2..5a951290af04 100644
--- a/devel/ace+tao/Makefile
+++ b/devel/ace+tao/Makefile
@@ -162,9 +162,10 @@ do-install:
for f in `${FIND} . -maxdepth 1 -name "lib*.so.${ACE_VERSION}" -o \
-name "lib*.so.${TAO_VERSION}" -not -name "*Test*"`; do \
${INSTALL_DATA} $${f} ${PREFIX}/lib; \
- ${LN} -fs ${PREFIX}/lib/$${f} \
- `${ECHO_CMD} ${PREFIX}/lib/$${f} | \
- ${SED} -e 's/.${ACE_VERSION}//;s/.${TAO_VERSION}//'`; \
+ lib=`${ECHO} $${f} | ${SED} -e s#.*/##`; \
+ (cd ${PREFIX}/lib; \
+ ${LN} -fs $${lib} `${ECHO} $${lib} | ${SED} -e \
+ 's/.${ACE_VERSION}//;s/.${TAO_VERSION}//'`); \
done
@${ECHO_MSG} "Installing executables into ${PREFIX}/bin"; \