aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ace
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
committerbapt <bapt@FreeBSD.org>2014-05-05 17:45:36 +0800
commit1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184 (patch)
tree96cc94ba02edcc043c52eb3f26adbc632bbe44d8 /devel/ace
parentd8575795a2106dcbddc552f756cb3916f113f9e0 (diff)
downloadfreebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.gz
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.tar.zst
freebsd-ports-gnome-1fa39fd2c3d6f5edbc6d4a9d6f9ceae142a0f184.zip
Convert all :U to :tu and :L to :tl
Since FreeBSD 8.4 and FreeBSD 9.1 make(1) do support :tu and :tl as a replacement for :U and :L (which has been marked as deprecated) bmake which is the default on FreeBSD 10+ only support by default :tu/:tl a hack has been added at the time to support :U and :L to ease migration. This hack is now not necessary anymore Note that this makes the ports tree incompatible with make(1) from FreeBSD 8.3 or earlier With hat: portmgr
Diffstat (limited to 'devel/ace')
-rw-r--r--devel/ace/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/ace/Makefile b/devel/ace/Makefile
index 8a551d566bd1..30da33b31481 100644
--- a/devel/ace/Makefile
+++ b/devel/ace/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 6.2.5
CATEGORIES= devel
MASTER_SITES= ftp://download.dre.vanderbilt.edu/previous_versions/ \
http://download.dre.vanderbilt.edu/previous_versions/
-DISTNAME= ${PORTNAME:U}-${PORTVERSION}
+DISTNAME= ${PORTNAME:tu}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Adaptive Communication Environment for C++
@@ -68,9 +68,9 @@ post-patch:
do-configure:
@cd ${WRKSRC}/ace \
- && ${ECHO_CMD} "#include <ace/config-${OPSYS:L}.h>" >> config.h
+ && ${ECHO_CMD} "#include <ace/config-${OPSYS:tl}.h>" >> config.h
@cd ${WRKSRC}/include/makeinclude \
- && ${ECHO_CMD} "include \$$(ACE_ROOT)/include/makeinclude/platform_${OPSYS:L}.GNU" >> platform_macros.GNU \
+ && ${ECHO_CMD} "include \$$(ACE_ROOT)/include/makeinclude/platform_${OPSYS:tl}.GNU" >> platform_macros.GNU \
&& ${ECHO_CMD} "CC= ${CC}" >> platform_macros.GNU \
&& ${ECHO_CMD} "CXX= ${CXX}" >> platform_macros.GNU \
&& ${ECHO_CMD} "CPPFLAGS= ${CPPFLAGS}" >> platform_macros.GNU \