aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ace
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-03-20 09:01:51 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-03-20 09:01:51 +0800
commit998f8bf1031d8321b350bcc32a01758d18b0519f (patch)
treeefb1b7bf8d8dab92ba59e6594b276ddecf788b9a /devel/ace
parent890809dc86c45e499109599f93f228f225199f39 (diff)
downloadfreebsd-ports-gnome-998f8bf1031d8321b350bcc32a01758d18b0519f.tar.gz
freebsd-ports-gnome-998f8bf1031d8321b350bcc32a01758d18b0519f.tar.zst
freebsd-ports-gnome-998f8bf1031d8321b350bcc32a01758d18b0519f.zip
- Fix build when aio.ko is loaded
- While here, fix build on CURRENT PR: 129363 Submitted by: "G. Paul Ziemba" <p-fbsd-bugs at ziemba dot us>
Diffstat (limited to 'devel/ace')
-rw-r--r--devel/ace/Makefile10
-rw-r--r--devel/ace/files/patch-tests25
2 files changed, 30 insertions, 5 deletions
diff --git a/devel/ace/Makefile b/devel/ace/Makefile
index cd2f900be494..ac2daf834c34 100644
--- a/devel/ace/Makefile
+++ b/devel/ace/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ace
PORTVERSION= 5.5.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ftp://download.dre.vanderbilt.edu/previous_versions/ \
http://download.dre.vanderbilt.edu/previous_versions/
@@ -39,16 +39,16 @@ MAN1= ace-gperf.1
EXTRA_PATCHES= ${FILESDIR}/extra-ace-OS_NS_netdb.inl
.endif
-.if ${OSVERSION} >= 800024
-BROKEN= does not compile
-.endif
-
post-extract:
@${MKDIR} ${BUILD_WRKSRC}
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
's|@libdir@/pkgconfig|@prefix@/libdata/pkgconfig|g'
+.if ${OSVERSION} >= 800024
+ @${REINPLACE_CMD} -e 's|cpu_set_t|cpuset_t|g' ${WRKSRC}/ace/OS_NS_Thread.cpp \
+ ${WRKSRC}/ace/OS_NS_Thread.h
+.endif
do-configure:
@(cd ${BUILD_WRKSRC} && \
diff --git a/devel/ace/files/patch-tests b/devel/ace/files/patch-tests
new file mode 100644
index 000000000000..279157ac586d
--- /dev/null
+++ b/devel/ace/files/patch-tests
@@ -0,0 +1,25 @@
+
+--- tests/Proactor_Test.cpp.orig 2006-04-20 00:41:47.000000000 -0700
++++ tests/Proactor_Test.cpp 2008-12-01 11:00:05.000000000 -0800
+@@ -253,7 +253,7 @@
+ break;
+ # endif /* sun */
+
+-# if !defined(__Lynx__)
++# if !defined(__Lynx__) && !defined (__FreeBSD__)
+ case CB:
+ ACE_NEW_RETURN (proactor_impl,
+ ACE_POSIX_CB_Proactor (max_op),
+--- tests/Proactor_Test_IPV6.cpp.orig 2006-04-20 00:41:47.000000000 -0700
++++ tests/Proactor_Test_IPV6.cpp 2008-12-01 17:40:59.000000000 -0800
+@@ -253,7 +253,7 @@
+ break;
+ # endif /* sun */
+
+-# if !defined(__Lynx__)
++# if !defined(__Lynx__) && !defined(__FreeBSD__)
+ case CB:
+ ACE_NEW_RETURN (proactor_impl,
+ ACE_POSIX_CB_Proactor (max_op),
+
+