aboutsummaryrefslogtreecommitdiffstats
path: root/devel/aifad
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2015-12-22 22:33:37 +0800
committermiwi <miwi@FreeBSD.org>2015-12-22 22:33:37 +0800
commit93bca6a212e8ab6e904a1f1b868375cd116922dd (patch)
treeda7bcd20bced33cf0a7ee5d9602345228d578db0 /devel/aifad
parent721c0c2df9965105a9de06f6fdf75186ce23271c (diff)
downloadfreebsd-ports-gnome-93bca6a212e8ab6e904a1f1b868375cd116922dd.tar.gz
freebsd-ports-gnome-93bca6a212e8ab6e904a1f1b868375cd116922dd.tar.zst
freebsd-ports-gnome-93bca6a212e8ab6e904a1f1b868375cd116922dd.zip
- Update to 2.0.6
- Switch to options helper - Update WWW PR: 205199 Submitted by: Ports Fury Approved by: mat (mentor) Differential Revision: D4619
Diffstat (limited to 'devel/aifad')
-rw-r--r--devel/aifad/Makefile22
-rw-r--r--devel/aifad/distinfo4
-rw-r--r--devel/aifad/pkg-descr10
-rw-r--r--devel/aifad/pkg-plist14
4 files changed, 22 insertions, 28 deletions
diff --git a/devel/aifad/Makefile b/devel/aifad/Makefile
index 1fbb259efa6f..89f7470532e5 100644
--- a/devel/aifad/Makefile
+++ b/devel/aifad/Makefile
@@ -2,15 +2,13 @@
# $FreeBSD$
PORTNAME= aifad
-PORTVERSION= 2.0.2
+PORTVERSION= 2.0.6
+DISTVERSIONPREFIX= v
CATEGORIES= devel
-MASTER_SITES= http://cdn.bitbucket.org/mmottl/aifad/downloads/
MAINTAINER= ports@FreeBSD.org
COMMENT= Machine learning system
-BROKEN= unfetchable
-
LICENSE= GPLv3
BUILD_DEPENDS= menhir:${PORTSDIR}/devel/menhir \
@@ -19,19 +17,29 @@ BUILD_DEPENDS= menhir:${PORTSDIR}/devel/menhir \
ocaml-res>0:${PORTSDIR}/devel/ocaml-res
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+USE_GITHUB= yes
+GH_ACCOUNT= mmottl
+
USE_OCAML= yes
NO_OCAML_RUNDEPENDS=yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix ${STAGEDIR}${PREFIX}
+PORTDOCS= AUTHORS.txt CHANGES.txt README.md TODO.md
+PORTEXAMPLES= *
+PLIST_FILES= bin/aifad
+
OPTIONS_DEFINE= DOCS EXAMPLES
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/aifad
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS.txt CHANGES.txt README.md \
- TODO.md ${STAGEDIR}${DOCSDIR})
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/examples && ${INSTALL_DATA} * ${STAGEDIR}${EXAMPLESDIR})
diff --git a/devel/aifad/distinfo b/devel/aifad/distinfo
index 6a0f9daf506a..2b8671d0a99b 100644
--- a/devel/aifad/distinfo
+++ b/devel/aifad/distinfo
@@ -1,2 +1,2 @@
-SHA256 (aifad-2.0.2.tar.gz) = c265614a2dcc893eaab7e559cd8a6b446e09d3262974bb7e01b3c453c80356a8
-SIZE (aifad-2.0.2.tar.gz) = 103080
+SHA256 (mmottl-aifad-v2.0.6_GH0.tar.gz) = e7f66d8af30e6c95efadffb07e447bd8596ae20f92ec96429799b51c3c559f99
+SIZE (mmottl-aifad-v2.0.6_GH0.tar.gz) = 107722
diff --git a/devel/aifad/pkg-descr b/devel/aifad/pkg-descr
index 4d958e8a1e1c..f104934b7e47 100644
--- a/devel/aifad/pkg-descr
+++ b/devel/aifad/pkg-descr
@@ -1,7 +1,7 @@
AIFAD stands for --Automated Induction of Functions over Algebraic
-Datatypes-- and improves decision tree learning by supporting significantly
-more complex kinds of data. This allows users to more conveniently describe
-the data they want to have learnt, which can improve accuracy and complexity
-of resulting models.
+Datatypes-- and improves decision tree learning by supporting
+significantly more complex kinds of data. This allows users to more
+conveniently describe the data they want to have learnt, which can
+improve accuracy and complexity of resulting models.
-WWW: https://bitbucket.org/mmottl/aifad
+WWW: https://mmottl.github.io/aifad
diff --git a/devel/aifad/pkg-plist b/devel/aifad/pkg-plist
deleted file mode 100644
index fe81bb101fbb..000000000000
--- a/devel/aifad/pkg-plist
+++ /dev/null
@@ -1,14 +0,0 @@
-bin/aifad
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.txt
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
-%%PORTDOCS%%%%DOCSDIR%%/README.md
-%%PORTDOCS%%%%DOCSDIR%%/TODO.md
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/breast_cancer1.add
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/breast_cancer1.ads
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/breast_cancer2.add
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/breast_cancer2.ads
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c45.data
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c45.names
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/large.ads
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test.add
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test.ads