aboutsummaryrefslogtreecommitdiffstats
path: root/devel/anjuta
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
committertijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
commit55e5c34e31b90aa95311b10bd4a3072f2163ebfe (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /devel/anjuta
parent0c15193d405451f0e1452ba981c8efb1df1447dd (diff)
downloadfreebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.gz
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.zst
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'devel/anjuta')
-rw-r--r--devel/anjuta/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index e622ab57a286..bc5cb8a05f33 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -4,7 +4,7 @@
PORTNAME= anjuta
PORTVERSION= 2.32.1.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -30,8 +30,8 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
CONFLICTS= anjuta-3.[0-9]*
-USES= desktop-file-utils gmake gettext libtool pathfix perl5 pkgconfig \
- shebangfix shared-mime-info tar:bzip2
+USES= desktop-file-utils gmake gettext libtool:keepla pathfix \
+ perl5 pkgconfig shared-mime-info shebangfix tar:bzip2
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip