aboutsummaryrefslogtreecommitdiffstats
path: root/devel/anjuta
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-11 21:45:37 +0800
committerbapt <bapt@FreeBSD.org>2014-04-11 21:45:37 +0800
commit555722a2ac56dd465f7a88e6e81eb8ef88300998 (patch)
tree62d07f6ed1b53508b61d481c5e9eabc639ba2350 /devel/anjuta
parent01fa91ec78dd4127b2eb842ba31408f79d28234d (diff)
downloadfreebsd-ports-gnome-555722a2ac56dd465f7a88e6e81eb8ef88300998.tar.gz
freebsd-ports-gnome-555722a2ac56dd465f7a88e6e81eb8ef88300998.tar.zst
freebsd-ports-gnome-555722a2ac56dd465f7a88e6e81eb8ef88300998.zip
Support stage
Diffstat (limited to 'devel/anjuta')
-rw-r--r--devel/anjuta/Makefile35
-rw-r--r--devel/anjuta/pkg-plist6
2 files changed, 22 insertions, 19 deletions
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index 0b7d5cd9586e..733c383c627c 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -4,7 +4,7 @@
PORTNAME= anjuta
PORTVERSION= 2.32.1.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -15,10 +15,10 @@ COMMENT= Integrated Development Environment for C and C++
BUILD_DEPENDS= autogen:${PORTSDIR}/devel/autogen \
bash:${PORTSDIR}/shells/bash \
p5-Locale-gettext>=1.05:${PORTSDIR}/devel/p5-Locale-gettext
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre \
- gladeui-1:${PORTSDIR}/devel/glade3 \
- unique-1.0:${PORTSDIR}/x11-toolkits/unique \
- gdl-1:${PORTSDIR}/x11-toolkits/gdl
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
+ libgladeui-1.so:${PORTSDIR}/devel/glade3 \
+ libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique \
+ libgdl-1.so:${PORTSDIR}/x11-toolkits/gdl
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
autogen:${PORTSDIR}/devel/autogen \
${LOCALBASE}/share/autotools:${PORTSDIR}/devel/autotools \
@@ -30,10 +30,11 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
CONFLICTS= anjuta-3.[0-9]*
-USE_BZIP2= yes
-USES= gmake gettext pathfix perl5 pkgconfig shebangfix shared-mime-info
+USES= desktop-file-utils gmake gettext libtool pathfix perl5 pkgconfig \
+ shebangfix shared-mime-info tar:bzip2
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
+INSTALL_TARGET= install-strip
USE_PYTHON= yes
USE_GNOME= gnomeprefix vte gtksourceview2 libgda4
USE_CSTD= gnu89
@@ -57,21 +58,21 @@ GCONF_SCHEMAS= anjuta-build-basic-autotools-plugin.schemas \
file-manager.schemas \
preferences.schemas \
python-plugin-properties.schemas
-SHEBANG_FILES= scripts/builder2schema.pl
-
-MAN1= anjuta.1 anjuta-launcher.1
+SHEBANG_FILES= scripts/builder2schema.pl \
+ plugins/gbf-am/gbf-am-parse.in \
+ plugins/gbf-mkfile/gbf-mkfile-parse.in \
+ plugins/tools/scripts/*.pl
OPTIONS_DEFINE= SVN DEVHELP
OPTIONS_DEFAULT=DEVHELP
DEVHELP_DESC= Devhelp support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSVN}
BUILD_DEPENDS+= svn:${PORTSDIR}/devel/subversion
-LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr1
-LIB_DEPENDS+= neon:${PORTSDIR}/www/neon29
+LIB_DEPENDS+= libapr-1.so:${PORTSDIR}/devel/apr1
+LIB_DEPENDS+= libneon.so:${PORTSDIR}/www/neon29
RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion
PLIST_SUB+= SVN=""
.else
@@ -80,7 +81,7 @@ PLIST_SUB+= SVN="@comment "
.endif
.if ${PORT_OPTIONS:MDEVHELP}
-LIB_DEPENDS+= devhelp-2:${PORTSDIR}/devel/devhelp
+LIB_DEPENDS+= libdevhelp-2.so:${PORTSDIR}/devel/devhelp
PLIST_SUB+= DEVHELP=""
.else
CONFIGURE_ARGS+=--disable-plugin-devhelp
@@ -101,12 +102,10 @@ post-configure:
${WRKSRC}/plugins/symbol-db/symbol-db-prefs.h
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in AUTHORS COPYING ChangeLog FUTURE INSTALL NEWS README \
doc/ScintillaDoc.html TODO
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/devel/anjuta/pkg-plist b/devel/anjuta/pkg-plist
index 45fbaeb0aa10..e447357719a9 100644
--- a/devel/anjuta/pkg-plist
+++ b/devel/anjuta/pkg-plist
@@ -208,6 +208,7 @@ lib/anjuta/liblanguage-manager.so
lib/anjuta/libpython_plugin.la
lib/anjuta/libpython_plugin.so
lib/anjuta/libpython_plugin.so.0
+lib/anjuta/libpython_plugin.so.0.0.0
lib/anjuta/python-plugin.plugin
lib/anjuta/sourceview.plugin
lib/anjuta/symbol-db.plugin
@@ -216,10 +217,14 @@ lib/glade3/modules/libgladeanjuta.so
lib/libanjuta.la
lib/libanjuta.so
lib/libanjuta.so.0
+lib/libanjuta.so.0.0.0
lib/libanjuta-foocanvas.la
lib/libanjuta-foocanvas.so
lib/libanjuta-foocanvas.so.0
+lib/libanjuta-foocanvas.so.0.0.0
libdata/pkgconfig/libanjuta-1.0.pc
+man/man1/anjuta-launcher.1.gz
+man/man1/anjuta.1.gz
share/anjuta/AUTHORS
share/anjuta/GBF/AmFiles.pm
share/anjuta/GBF/General.pm
@@ -1188,7 +1193,6 @@ share/locale/vi/LC_MESSAGES/anjuta.mo
share/locale/zh_CN/LC_MESSAGES/anjuta.mo
share/locale/zh_HK/LC_MESSAGES/anjuta.mo
share/locale/zh_TW/LC_MESSAGES/anjuta.mo
-share/mime/application/x-anjuta.xml
share/mime/packages/anjuta.xml
share/omf/anjuta-manual/anjuta-manual-C.omf
share/omf/anjuta-manual/anjuta-manual-de.omf