aboutsummaryrefslogtreecommitdiffstats
path: root/devel/apache-ant
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-08-26 13:37:03 +0800
committerpetef <petef@FreeBSD.org>2001-08-26 13:37:03 +0800
commitb8a99a47e8297c1295fc4a42f6d799df02af6bec (patch)
treed84fa8ebd68b6afa300ef752c44616c21c365fc2 /devel/apache-ant
parente90c2a0c20805dada6bb4617d817238ae930f4eb (diff)
downloadfreebsd-ports-gnome-b8a99a47e8297c1295fc4a42f6d799df02af6bec.tar.gz
freebsd-ports-gnome-b8a99a47e8297c1295fc4a42f6d799df02af6bec.tar.zst
freebsd-ports-gnome-b8a99a47e8297c1295fc4a42f6d799df02af6bec.zip
- make the ant program actually work if no JAVA_HOME is set (make the default
java command the javavm wrapper). - bump portrevision PR: 27073 Submitted by: maintainer
Diffstat (limited to 'devel/apache-ant')
-rw-r--r--devel/apache-ant/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/apache-ant/Makefile b/devel/apache-ant/Makefile
index a3b28c80f69d..489c23853a8d 100644
--- a/devel/apache-ant/Makefile
+++ b/devel/apache-ant/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jakarta-ant
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= devel java
MASTER_SITES= http://jakarta.apache.org/builds/${PORTNAME}/release/v${PORTVERSION}/bin/
DISTFILES= ${DISTNAME}-bin${EXTRACT_SUFX} \
@@ -35,6 +36,9 @@ DATADIRS= lib
DATADIRS+= docs
.endif
+post-patch:
+ @${PERL} -pi -e 's,JAVACMD=java,JAVACMD=javavm,g' ${WRKSRC}/bin/ant
+
do-install:
${MKDIR} ${PORTDESTDIR}/bin ${PORTDESTDIR}/lib
cd ${INSTALL_WRKSRC}; \