aboutsummaryrefslogtreecommitdiffstats
path: root/devel/apr0
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-05-18 12:41:03 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-05-18 12:41:03 +0800
commitfc108c6968ec830d75cc741379317bc5046891f7 (patch)
tree3c193dcc491e1c2525a16a8d7b847b3ab4be4ad0 /devel/apr0
parentfa6b10630133968536179e2a09f1a0ab2ab0065e (diff)
downloadfreebsd-ports-gnome-fc108c6968ec830d75cc741379317bc5046891f7.tar.gz
freebsd-ports-gnome-fc108c6968ec830d75cc741379317bc5046891f7.tar.zst
freebsd-ports-gnome-fc108c6968ec830d75cc741379317bc5046891f7.zip
- Convert to the apr 0.9.x series. Specifically apr-0.9.18 and apr-util-0.9.17
PR: ports/146553 Submitted by: myself (pgollucci@) With Hat: apache@
Diffstat (limited to 'devel/apr0')
-rw-r--r--devel/apr0/Makefile76
-rw-r--r--devel/apr0/distinfo12
-rw-r--r--devel/apr0/files/patch-apr-0.9.18__build__buildcheck.sh11
-rw-r--r--devel/apr0/files/patch-apr-0.9.18__config.layout10
-rw-r--r--devel/apr0/files/patch-apr-0.9.18__configure.in43
-rw-r--r--devel/apr0/files/patch-apr-0.9.18__threadproc__unix__procsup.c18
-rw-r--r--devel/apr0/files/patch-apr-util-0.9.17__build__dbm.m480
-rw-r--r--devel/apr0/files/patch-apr-util-0.9.17__config.layout10
-rw-r--r--devel/apr0/files/patch-apr-util-1.3.9__build__dbm.m4129
-rw-r--r--devel/apr0/files/patch-apr_buildconf79
-rw-r--r--devel/apr0/files/patch-apr_hints.m415
-rw-r--r--devel/apr0/pkg-plist194
12 files changed, 336 insertions, 341 deletions
diff --git a/devel/apr0/Makefile b/devel/apr0/Makefile
index 11f8eb68abd6..eb23b1a369f9 100644
--- a/devel/apr0/Makefile
+++ b/devel/apr0/Makefile
@@ -6,7 +6,6 @@
PORTNAME= apr
PORTVERSION= ${APR_VERSION}.${APU_VERSION}
-PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= apr
@@ -17,6 +16,8 @@ COMMENT= Apache Portability Library
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
+CONFLICTS= apr-*-1.*
+
MAKE_JOBS_SAFE= yes
OPTIONS= THREADS "Enable Threads in apr" on \
@@ -24,14 +25,11 @@ OPTIONS= THREADS "Enable Threads in apr" on \
BDB "Enable Berkley BDB support in apr-util" on \
GDBM "Enable GNU dbm support in apr-util" on \
LDAP "Enable LDAP support in apr-util" off \
- MYSQL "Enable MySQL suport in apr-util" off \
NDBM "Enable NDBM support in apr-util" off \
- PGSQL "Enable Postgresql suport in apr-util" off \
- SQLITE "Enable SQLite3 support in apr-util" off \
DEVRANDOM "Use /dev/random or compatible in apr" on
-APR_VERSION= 1.4.2
-APU_VERSION= 1.3.9
+APR_VERSION= 0.9.18
+APU_VERSION= 0.9.17
USE_ICONV= yes
USE_AUTOTOOLS= automake:19 autoconf:262 libtool:22:env
@@ -47,10 +45,10 @@ APR_WRKDIR= ${WRKDIR}/apr-${APR_VERSION}
APU_WRKDIR= ${WRKDIR}/apr-util-${APU_VERSION}
PLIST_SUB= SHLIB_APR_MAJOR="${SHLIB_APR_MAJOR}" SHLIB_APU_MAJOR="${SHLIB_APU_MAJOR}"
-SHLIB_APR_MAJOR= 4
-SHLIB_APU_MAJOR= 3
+SHLIB_APR_MAJOR= 9
+SHLIB_APU_MAJOR= 9
-APR_CONF_ARGS= --with-installbuilddir=${DATADIR}/build-1
+APR_CONF_ARGS= --with-installbuilddir=${DATADIR}/build-0
APU_CONF_ARGS= --with-apr=${APR_WRKDIR} \
--with-expat=${LOCALBASE} \
--with-iconv=${LOCALBASE}
@@ -97,7 +95,6 @@ PLIST_SUB+= GDBM="@comment "
APU_CONF_ARGS+= --without-gdbm
.else
PLIST_SUB+= GDBM=""
-APU_EXTRAS= yes
LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
APU_CONF_ARGS+= --with-gdbm=${LOCALBASE}
.if defined(PKGNAMESUFFIX)
@@ -111,7 +108,6 @@ PKGNAMESUFFIX= -gdbm
PLIST_SUB+= BDB="@comment "
APU_CONF_ARGS+= --without-berkeley-db
.else
-APU_EXTRAS= yes
PLIST_SUB+= BDB=""
USE_BDB= 42+
INVALID_BDB_VER= 50
@@ -124,7 +120,6 @@ PKGNAMESUFFIX= -${BDB_INCLUDE_DIR:S,^${LOCALBASE}/include/,,}
.endif
.if defined(WITH_NDBM)
-APU_EXTRAS= yes
PLIST_SUB+= NDBM=""
APU_CONF_ARGS+= --with-ndbm=/usr
.if defined(PKGNAMESUFFIX)
@@ -138,7 +133,6 @@ APU_CONF_ARGS+= --without-ndbm
.endif
.if defined(WITH_LDAP)
-APU_EXTRAS= yes
PLIST_SUB+= LDAP=""
USE_OPENLDAP= yes
APU_CONF_ARGS+= --with-ldap-include=${LOCALBASE}/include \
@@ -150,62 +144,6 @@ PKGNAMESUFFIX= -ldap
.endif
.else
PLIST_SUB+= LDAP="@comment "
-APU_CONF_ARGS+= --without-ldap
-.endif
-
-.if defined(WITH_MYSQL)
-APU_EXTRAS= yes
-PLIST_SUB+= MYSQL=""
-USE_MYSQL= YES
-APU_CONF_ARGS+= --with-mysql=${LOCALBASE}
-CONFIGURE_ENV+= LIBS="${LIBS}"
-CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/mysql -DHAVE_MYSQL_H
-LDFLAGS+= -L${LOCALBASE}/lib/mysql
-.if defined(PKGNAMESUFFIX)
-PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-mysql${MYSQL_VER}
-.else
-PKGNAMESUFFIX= -mysql
-.endif
-.else
-PLIST_SUB+= MYSQL="@comment "
-APU_CONF_ARGS+= --without-mysql
-.endif
-
-.if defined(WITH_PGSQL)
-APU_EXTRAS= yes
-PLIST_SUB+= PGSQL=""
-USE_PGSQL= YES
-APU_CONF_ARGS+= --with-pgsql=${LOCALBASE}
-CONFIGURE_ENV+= ac_cv_path_PGSQL_CONFIG=""
-.if defined(PKGNAMESUFFIX)
-PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-pgsql${PGSQL_VER}
-.else
-PKGNAMESUFFIX= -pgsql
-.endif
-.else
-PLIST_SUB+= PGSQL="@comment "
-APU_CONF_ARGS+= --without-pgsql
-.endif
-
-.if defined(WITH_SQLITE)
-APU_EXTRAS= yes
-PLIST_SUB+= SQLITE3=""
-USE_SQLITE= YES
-APU_CONF_ARGS+= --with-sqlite3=${LOCALBASE}
-.if defined(PKGNAMESUFFIX)
-PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-sqlite3
-.else
-PKGNAMESUFFIX= -sqlite3
-.endif
-.else
-APU_CONF_ARGS+= --without-sqlite3
-PLIST_SUB+= SQLITE3="@comment "
-.endif
-
-.if defined(APU_EXTRAS)
-PLIST_SUB+= APU_EXTRAS=""
-.else
-PLIST_SUB+= APU_EXTRAS="@comment "
.endif
post-patch:
diff --git a/devel/apr0/distinfo b/devel/apr0/distinfo
index 3dbdf15760e7..5327bb44f52a 100644
--- a/devel/apr0/distinfo
+++ b/devel/apr0/distinfo
@@ -1,6 +1,6 @@
-MD5 (apr-1.4.2.tar.gz) = fc80cb54f158c2674f9eeb47a1f672cd
-SHA256 (apr-1.4.2.tar.gz) = 6a0291d6f6a59d5eab5ae5441c37b78b17f7a1a2fa1478741b7178f5fbc33ebe
-SIZE (apr-1.4.2.tar.gz) = 949945
-MD5 (apr-util-1.3.9.tar.gz) = cc2ec0ba4f01d88375f1170f762518fa
-SHA256 (apr-util-1.3.9.tar.gz) = 20897069274a026057df26b90a6424da9d70318d930c99885c451d8753b8e4d9
-SIZE (apr-util-1.3.9.tar.gz) = 790952
+MD5 (apr-0.9.18.tar.gz) = d5e7642baf892fb532968340f37aeabb
+SHA256 (apr-0.9.18.tar.gz) = dad08e2156f3d5dd31f2d9cc24f9dfbcf952531077b7fae2b7f0ae50e2de7cc6
+SIZE (apr-0.9.18.tar.gz) = 1074982
+MD5 (apr-util-0.9.17.tar.gz) = 2d819c1c95e324f4fb05d13cac008fc8
+SHA256 (apr-util-0.9.17.tar.gz) = 7b994cf80e54104f0f19eb35a8d4fafe4f90b383b0303f1184218448d276a4e1
+SIZE (apr-util-0.9.17.tar.gz) = 613970
diff --git a/devel/apr0/files/patch-apr-0.9.18__build__buildcheck.sh b/devel/apr0/files/patch-apr-0.9.18__build__buildcheck.sh
new file mode 100644
index 000000000000..59898637b6e5
--- /dev/null
+++ b/devel/apr0/files/patch-apr-0.9.18__build__buildcheck.sh
@@ -0,0 +1,11 @@
+--- ./apr-0.9.18/build/buildcheck.sh.orig 2004-11-24 18:10:04.000000000 -0500
++++ ./apr-0.9.18/build/buildcheck.sh 2010-05-13 16:34:13.409617834 -0400
+@@ -26,7 +26,7 @@
+ # output is multiline from 1.5 onwards
+
+ # Require libtool 1.3.3 or newer
+-libtool=`build/PrintPath glibtool libtool`
++libtool=${LIBTOOL}
+ lt_pversion=`$libtool --version 2>/dev/null|sed -e 's/([^)]*)//g;s/^[^0-9]*//;s/[- ].*//g;q'`
+ if test -z "$lt_pversion"; then
+ echo "buildconf: libtool not found."
diff --git a/devel/apr0/files/patch-apr-0.9.18__config.layout b/devel/apr0/files/patch-apr-0.9.18__config.layout
new file mode 100644
index 000000000000..26ca03741d1b
--- /dev/null
+++ b/devel/apr0/files/patch-apr-0.9.18__config.layout
@@ -0,0 +1,10 @@
+--- ./apr-0.9.18/config.layout.orig 2004-11-24 18:02:04.000000000 -0500
++++ ./apr-0.9.18/config.layout 2010-05-13 16:34:13.416618739 -0400
+@@ -229,3 +229,7 @@
+ infodir: ${exec_prefix}/share/info
+ libsuffix: -${APR_MAJOR_VERSION}
+ </Layout>
++
++<Layout FreeBSD>
++ libsuffix:
++</Layout>
diff --git a/devel/apr0/files/patch-apr-0.9.18__configure.in b/devel/apr0/files/patch-apr-0.9.18__configure.in
new file mode 100644
index 000000000000..e156abd6d609
--- /dev/null
+++ b/devel/apr0/files/patch-apr-0.9.18__configure.in
@@ -0,0 +1,43 @@
+--- ./apr-0.9.18/configure.in.orig 2008-06-20 13:32:47.000000000 -0400
++++ ./apr-0.9.18/configure.in 2010-05-13 16:34:13.421618268 -0400
+@@ -7,6 +7,7 @@
+ AC_INIT(build/apr_common.m4)
+ AC_CONFIG_HEADER(include/arch/unix/apr_private.h)
+ AC_CONFIG_AUX_DIR(build)
++AC_CONFIG_MACRO_DIR(build)
+
+ dnl
+ dnl Include our own M4 macros along with those for libtool
+@@ -16,6 +17,11 @@
+ sinclude(build/apr_threads.m4)
+ sinclude(build/apr_hints.m4)
+ sinclude(build/libtool.m4)
++sinclude(build/ltsugar.m4)
++sinclude(build/argz.m4)
++sinclude(build/ltoptions.m4)
++sinclude(build/ltversion.m4)
++sinclude(build/lt~obsolete.m4)
+
+ dnl Save user-defined environment settings for later restoration
+ dnl
+@@ -98,6 +104,8 @@
+ dnl preload section from invoking the macro to get compiler info.
+ AC_PROG_CC
+
++AC_PROG_SED
++
+ dnl Preload
+ APR_PRELOAD
+
+@@ -141,6 +149,11 @@
+ AC_ARG_ENABLE(experimental-libtool,[ --experimental-libtool Use experimental custom libtool (not included in source distribution)],
+ [experimental_libtool=$enableval],[experimental_libtool=no])
+
++dnl Workarounds for busted Libtool 2.x when we don't call AC_PROG_LIBTOOL
++if test "x$Xsed" = "x"; then
++ Xsed="$SED -e 1s/^X//"
++fi
++
+ case $host in
+ *os2*)
+ # Use a custom-made libtool replacement
diff --git a/devel/apr0/files/patch-apr-0.9.18__threadproc__unix__procsup.c b/devel/apr0/files/patch-apr-0.9.18__threadproc__unix__procsup.c
new file mode 100644
index 000000000000..c9ccf13bda48
--- /dev/null
+++ b/devel/apr0/files/patch-apr-0.9.18__threadproc__unix__procsup.c
@@ -0,0 +1,18 @@
+--- ./apr-0.9.18/threadproc/unix/procsup.c.orig 2006-09-20 12:04:09.000000000 -0400
++++ ./apr-0.9.18/threadproc/unix/procsup.c 2010-05-13 16:34:13.426619474 -0400
+@@ -21,6 +21,7 @@
+ int x;
+
+ chdir("/");
++#ifndef FREEBSD_THREAD_HACK
+ #if !defined(MPE) && !defined(OS2) && !defined(TPF) && !defined(BEOS)
+ /* Don't detach for MPE because child processes can't survive the death of
+ * the parent. */
+@@ -56,6 +57,7 @@
+ return errno;
+ }
+ #endif
++#endif
+
+ /* close out the standard file descriptors */
+ if (freopen("/dev/null", "r", stdin) == NULL) {
diff --git a/devel/apr0/files/patch-apr-util-0.9.17__build__dbm.m4 b/devel/apr0/files/patch-apr-util-0.9.17__build__dbm.m4
new file mode 100644
index 000000000000..c58d317c5cb4
--- /dev/null
+++ b/devel/apr0/files/patch-apr-util-0.9.17__build__dbm.m4
@@ -0,0 +1,80 @@
+--- ./apr-util-0.9.17/build/dbm.m4.orig 2008-11-24 02:30:29.000000000 -0500
++++ ./apr-util-0.9.17/build/dbm.m4 2010-05-13 16:34:13.400617508 -0400
+@@ -298,8 +298,8 @@
+ fi
+ APU_CHECK_BERKELEY_DB(1, -1, -1,
+ "$places",
+- "db_185.h",
+- "db"
++ "db.h",
++ "c"
+ )
+ if test "$apu_have_db" = "1"; then
+ apu_db_version=185
+@@ -341,7 +341,7 @@
+ APU_CHECK_BERKELEY_DB(3, -1, -1,
+ "$places",
+ "db3/db.h db.h",
+- "db3 db"
++ "db3"
+ )
+ if test "$apu_have_db" = "1"; then
+ apu_db_version=3
+@@ -361,8 +361,8 @@
+ fi
+ APU_CHECK_BERKELEY_DB("4", "0", "-1",
+ "$places",
+- "db4/db.h db.h",
+- "db-4.0 db4 db"
++ "db4/db.h",
++ "db4"
+ )
+ if test "$apu_have_db" = "1"; then
+ apu_db_version=4
+@@ -382,8 +382,8 @@
+ fi
+ APU_CHECK_BERKELEY_DB("4", "1", "-1",
+ "$places",
+- "db41/db.h db4/db.h db.h",
+- "db-4.1 db4 db"
++ "db41/db.h",
++ "db41"
+ )
+ if test "$apu_have_db" = "1"; then
+ apu_db_version=4
+@@ -403,13 +403,14 @@
+ fi
+ APU_CHECK_BERKELEY_DB("4", "2", "-1",
+ "$places",
+- "db42/db.h db4/db.h db.h",
+- "db-4.2 db4 db"
++ "db42/db.h",
++ "db-4.2"
+ )
+ if test "$apu_have_db" = "1"; then
+ apu_db_version=4
+ fi
+ ])
++
+ dnl
+ dnl APU_CHECK_DB43: is DB4.3 present?
+ dnl
+@@ -422,8 +423,8 @@
+ fi
+ APU_CHECK_BERKELEY_DB("4", "3", "-1",
+ "$places",
+- "db43/db.h db4/db.h db.h",
+- "db-4.3 db43 db4 db"
++ "db43/db.h",
++ "db-4.3"
+ )
+ if test "$apu_have_db" = "1"; then
+ apu_db_version=4
+@@ -579,6 +580,7 @@
+ fi
+ fi
+ fi
++
+ AC_MSG_CHECKING(for Berkeley DB)
+ if test "$apu_have_db" = "1"; then
+ AC_MSG_RESULT(found db$apu_db_version)
diff --git a/devel/apr0/files/patch-apr-util-0.9.17__config.layout b/devel/apr0/files/patch-apr-util-0.9.17__config.layout
new file mode 100644
index 000000000000..5c76ba73bb5e
--- /dev/null
+++ b/devel/apr0/files/patch-apr-util-0.9.17__config.layout
@@ -0,0 +1,10 @@
+--- ./apr-util-0.9.17/config.layout.orig 2004-11-24 18:45:40.000000000 -0500
++++ ./apr-util-0.9.17/config.layout 2010-05-13 16:34:13.405620669 -0400
+@@ -229,3 +229,7 @@
+ infodir: ${exec_prefix}/share/info
+ libsuffix -${APRUTIL_MAJOR_VERSION}
+ </Layout>
++
++<Layout FreeBSD>
++ libsuffix:
++</Layout>
diff --git a/devel/apr0/files/patch-apr-util-1.3.9__build__dbm.m4 b/devel/apr0/files/patch-apr-util-1.3.9__build__dbm.m4
deleted file mode 100644
index 0f0fe1e9cbb3..000000000000
--- a/devel/apr0/files/patch-apr-util-1.3.9__build__dbm.m4
+++ /dev/null
@@ -1,129 +0,0 @@
---- ./apr-util-1.3.9/build/dbm.m4.orig 2008-11-21 01:32:58.000000000 -0500
-+++ ./apr-util-1.3.9/build/dbm.m4 2010-05-06 20:21:58.910611623 -0400
-@@ -522,6 +522,25 @@
- apu_db_version=4
- fi
- ])
-+dnl
-+dnl APU_CHECK_DB48: is DB4.8 present?
-+dnl
-+dnl if present: sets apu_db_header, apu_db_lib, and apu_db_version
-+dnl
-+AC_DEFUN([APU_CHECK_DB48], [
-+ places=$1
-+ if test -z "$places"; then
-+ places="std /usr/local/BerkeleyDB.4.8 /boot/home/config"
-+ fi
-+ APU_CHECK_BERKELEY_DB("4", "8", "-1",
-+ "$places",
-+ "db48/db.h db4/db.h db.h",
-+ "db-4.8 db4-4.8 db48 db4 db"
-+ )
-+ if test "$apu_have_db" = "1"; then
-+ apu_db_version=4
-+ fi
-+])
-
- AC_DEFUN([APU_CHECK_DB], [
- requested=$1
-@@ -606,6 +625,12 @@
- AC_MSG_ERROR(Berkeley db4 not found)
- fi
- ;;
-+ db48)
-+ APU_CHECK_DB48("$check_places")
-+ if test "$apu_db_version" != "4"; then
-+ AC_MSG_ERROR(Berkeley db4 not found)
-+ fi
-+ ;;
- default)
- APU_CHECK_DB_ALL("$check_places")
- ;;
-@@ -613,34 +638,37 @@
- ])
-
- dnl
--dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 4.7 to 1.
-+dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 4.8 to 1.
- dnl
- AC_DEFUN([APU_CHECK_DB_ALL], [
- all_places=$1
-
-- APU_CHECK_DB47("$all_places")
-+ APU_CHECK_DB48("$all_places")
- if test "$apu_db_version" != "4"; then
-- APU_CHECK_DB46("$all_places")
-+ APU_CHECK_DB47("$all_places")
- if test "$apu_db_version" != "4"; then
-- APU_CHECK_DB45("$all_places")
-+ APU_CHECK_DB46("$all_places")
- if test "$apu_db_version" != "4"; then
-- APU_CHECK_DB44("$all_places")
-+ APU_CHECK_DB45("$all_places")
- if test "$apu_db_version" != "4"; then
-- APU_CHECK_DB43("$all_places")
-+ APU_CHECK_DB44("$all_places")
- if test "$apu_db_version" != "4"; then
-- APU_CHECK_DB42("$all_places")
-+ APU_CHECK_DB43("$all_places")
- if test "$apu_db_version" != "4"; then
-- APU_CHECK_DB41("$all_places")
-+ APU_CHECK_DB42("$all_places")
- if test "$apu_db_version" != "4"; then
-- APU_CHECK_DB4("$all_places")
-+ APU_CHECK_DB41("$all_places")
- if test "$apu_db_version" != "4"; then
-- APU_CHECK_DB3("$all_places")
-- if test "$apu_db_version" != "3"; then
-- APU_CHECK_DB2("$all_places")
-- if test "$apu_db_version" != "2"; then
-- APU_CHECK_DB1("$all_places")
-- if test "$apu_db_version" != "1"; then
-- APU_CHECK_DB185("$all_places")
-+ APU_CHECK_DB4("$all_places")
-+ if test "$apu_db_version" != "4"; then
-+ APU_CHECK_DB3("$all_places")
-+ if test "$apu_db_version" != "3"; then
-+ APU_CHECK_DB2("$all_places")
-+ if test "$apu_db_version" != "2"; then
-+ APU_CHECK_DB1("$all_places")
-+ if test "$apu_db_version" != "1"; then
-+ APU_CHECK_DB185("$all_places")
-+ fi
- fi
- fi
- fi
-@@ -679,11 +707,11 @@
- apu_db_version=0
-
- AC_ARG_WITH(dbm, [APR_HELP_STRING([--with-dbm=DBM], [choose the DBM type to use.
-- DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44,db45,db46,db47}])],
-+ DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44,db45,db46,db47,db48}])],
- [
- if test "$withval" = "yes"; then
- AC_MSG_ERROR([--with-dbm needs to specify a DBM type to use.
-- One of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47])
-+ One of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48])
- fi
- requested="$withval"
- ], [
-@@ -882,6 +910,10 @@
- apu_use_db=1
- apu_default_dbm=db4
- ;;
-+ db48)
-+ apu_use_db=1
-+ apu_default_dbm=db4
-+ ;;
- default)
- dnl ### use more sophisticated DBMs for the default?
- apu_default_dbm="sdbm (default)"
-@@ -889,7 +921,7 @@
- ;;
- *)
- AC_MSG_ERROR([--with-dbm=$look_for is an unknown DBM type.
-- Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47])
-+ Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48])
- ;;
- esac
-
diff --git a/devel/apr0/files/patch-apr_buildconf b/devel/apr0/files/patch-apr_buildconf
index f34ebe102a4a..242a802e108a 100644
--- a/devel/apr0/files/patch-apr_buildconf
+++ b/devel/apr0/files/patch-apr_buildconf
@@ -1,10 +1,75 @@
---- apr-1.4.2/buildconf.orig 2009-02-24 06:37:18.000000000 +0300
-+++ apr-1.4.2/buildconf 2009-09-27 14:25:11.000000000 +0400
-@@ -71,6 +71,7 @@
+--- ./apr-0.9.18/buildconf.orig 2006-09-20 12:04:09.000000000 -0400
++++ ./apr-0.9.18/buildconf 2010-05-13 16:34:13.412618222 -0400
+@@ -23,7 +23,7 @@
+ #
+ build/buildcheck.sh || exit 1
- echo "buildconf: Using libtool.m4 at ${ltfile}."
+-libtoolize=`build/PrintPath glibtoolize libtoolize`
++libtoolize="${LIBTOOLIZE}"
+ if [ "x$libtoolize" = "x" ]; then
+ echo "libtoolize not found in path"
+ exit 1
+@@ -35,29 +35,48 @@
+ # Note: APR supplies its own config.guess and config.sub -- we do not
+ # rely on libtool's versions
+ #
+-echo "Copying libtool helper files ..."
++echo "buildconf: copying libtool helper files using $libtoolize"
-+chmod 664 build/libtool.m4
- cat $ltfile | sed -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' > build/libtool.m4
+ # Remove any libtool files so one can switch between libtool 1.3
+ # and libtool 1.4 by simply rerunning the buildconf script.
+-(cd build ; rm -f ltconfig ltmain.sh libtool.m4)
+-
+-$libtoolize --copy --automake
+-
+-ltpath=`dirname $libtoolize`
+-ltfile=${LIBTOOL_M4-`cd $ltpath/../share/aclocal ; pwd`/libtool.m4}
++(cd build ; rm -f ltconfig ltmain.sh libtool.m4 ltoptions.m4 ltsugar.m4 ltversion.m4 lt~obsolete.m4)
- # libtool.m4 from 1.6 requires ltsugar.m4
+-if [ ! -f $ltfile ]; then
++lt_pversion=`$libtoolize --version 2>/dev/null|sed -e 's/([^)]*)//g;s/^[^0-9]*//;s/[- ].*//g;q'`
++lt_version=`echo $lt_pversion|sed -e 's/\([a-z]*\)$/.\1/'`
++IFS=.; set $lt_version; IFS=' '
++if test "$1" = "1"; then
++ $libtoolize --copy --automake
++ if [ -f libtool.m4 ]; then
++ ltfile=`pwd`/libtool.m4
++ else
++ ltfindcmd="`sed -n \"/=[^\\\`]/p;/libtool_m4=/{s/.*=/echo /p;q;}\" \
++ < $libtoolize`"
++ ltfile=${LIBTOOL_M4-`eval "$ltfindcmd"`}
++ # Expecting the code above to be very portable, but just in case...
++ if [ -z "$ltfile" -o ! -f "$ltfile" ]; then
++ ltpath=`dirname $libtoolize`
++ ltfile=${LIBTOOL_M4}
++ fi
++ fi
++ if [ ! -f $ltfile ]; then
+ echo "$ltfile not found"
+ exit 1
++ fi
++ # Do we need this anymore?
++ echo "buildconf: Using libtool.m4 at ${ltfile}."
++ cat $ltfile | sed -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' > build/libtool.m4
++fi
++if test "$1" = "2"; then
++ $libtoolize --copy
++ # Wouldn't it just be better to define top_builddir??
++ mv build/libtool.m4 build/libtool.m4.$$
++ cat build/libtool.m4.$$ | sed -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' > build/libtool.m4
++ chmod 664 build/libtool.m4.$$
++ rm build/libtool.m4.$$
+ fi
+
+-echo "buildconf: Using libtool.m4 at ${ltfile}."
+-
+-cat $ltfile | sed -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' > build/libtool.m4
+-
+-# This is just temporary until people's workspaces are cleared -- remove
+-# any old aclocal.m4 left over from prior build so it doesn't cause errors.
+-rm -f aclocal.m4
++# Clean up any leftovers
++rm -f aclocal.m4 libtool.m4
+
+ #
+ # Generate the autoconf header and ./configure
diff --git a/devel/apr0/files/patch-apr_hints.m4 b/devel/apr0/files/patch-apr_hints.m4
deleted file mode 100644
index f86ec6c0fd5b..000000000000
--- a/devel/apr0/files/patch-apr_hints.m4
+++ /dev/null
@@ -1,15 +0,0 @@
---- apr-1.4.2/build/apr_hints.m4.orig Wed Oct 27 11:12:28 2004
-+++ apr-1.4.2/build/apr_hints.m4 Wed Oct 27 11:25:32 2004
-@@ -137,11 +137,7 @@
- ;;
- *-freebsd*)
- APR_SETIFNULL(apr_lock_method, [USE_FLOCK_SERIALIZE])
-- if test -x /sbin/sysctl; then
-- os_version=`/sbin/sysctl -n kern.osreldate`
-- else
-- os_version=000000
-- fi
-+ os_version="OSVERSION"
- # 502102 is when libc_r switched to libpthread (aka libkse).
- if test $os_version -ge "502102"; then
- apr_cv_pthreads_cflags="none"
diff --git a/devel/apr0/pkg-plist b/devel/apr0/pkg-plist
index b89a75c8eec4..261fe7e5e0d7 100644
--- a/devel/apr0/pkg-plist
+++ b/devel/apr0/pkg-plist
@@ -1,118 +1,82 @@
-bin/apr-1-config
-bin/apu-1-config
-%%DATADIR%%/build-1/apr_rules.mk
-%%DATADIR%%/build-1/libtool
-%%DATADIR%%/build-1/make_exports.awk
-%%DATADIR%%/build-1/make_var_export.awk
-%%DATADIR%%/build-1/mkdir.sh
-include/apr-1/apr.h
-include/apr-1/apr_allocator.h
-include/apr-1/apr_anylock.h
-include/apr-1/apr_atomic.h
-include/apr-1/apr_base64.h
-include/apr-1/apr_buckets.h
-include/apr-1/apr_date.h
-include/apr-1/apr_dbd.h
-include/apr-1/apr_dbm.h
-include/apr-1/apr_dso.h
-include/apr-1/apr_env.h
-include/apr-1/apr_errno.h
-include/apr-1/apr_file_info.h
-include/apr-1/apr_file_io.h
-include/apr-1/apr_fnmatch.h
-include/apr-1/apr_general.h
-include/apr-1/apr_getopt.h
-include/apr-1/apr_global_mutex.h
-include/apr-1/apr_hash.h
-include/apr-1/apr_hooks.h
-include/apr-1/apr_inherit.h
-include/apr-1/apr_ldap.h
-include/apr-1/apr_ldap_init.h
-include/apr-1/apr_ldap_option.h
-include/apr-1/apr_ldap_rebind.h
-include/apr-1/apr_ldap_url.h
-include/apr-1/apr_lib.h
-include/apr-1/apr_md4.h
-include/apr-1/apr_md5.h
-include/apr-1/apr_memcache.h
-include/apr-1/apr_mmap.h
-include/apr-1/apr_network_io.h
-include/apr-1/apr_optional.h
-include/apr-1/apr_optional_hooks.h
-include/apr-1/apr_poll.h
-include/apr-1/apr_pools.h
-include/apr-1/apr_portable.h
-include/apr-1/apr_proc_mutex.h
-include/apr-1/apr_queue.h
-include/apr-1/apr_random.h
-include/apr-1/apr_reslist.h
-include/apr-1/apr_ring.h
-include/apr-1/apr_rmm.h
-include/apr-1/apr_sdbm.h
-include/apr-1/apr_sha1.h
-include/apr-1/apr_shm.h
-include/apr-1/apr_signal.h
-include/apr-1/apr_strings.h
-include/apr-1/apr_strmatch.h
-include/apr-1/apr_support.h
-include/apr-1/apr_tables.h
-include/apr-1/apr_thread_cond.h
-include/apr-1/apr_thread_mutex.h
-include/apr-1/apr_thread_pool.h
-include/apr-1/apr_thread_proc.h
-include/apr-1/apr_thread_rwlock.h
-include/apr-1/apr_time.h
-include/apr-1/apr_uri.h
-include/apr-1/apr_user.h
-include/apr-1/apr_uuid.h
-include/apr-1/apr_version.h
-include/apr-1/apr_want.h
-include/apr-1/apr_xlate.h
-include/apr-1/apr_xml.h
-include/apr-1/apu.h
-include/apr-1/apu_version.h
-include/apr-1/apu_want.h
-libdata/pkgconfig/apr-1.pc
-libdata/pkgconfig/apr-util-1.pc
+bin/apr-config
+bin/apu-config
+%%DATADIR%%/build-0/apr_rules.mk
+%%DATADIR%%/build-0/libtool
+%%DATADIR%%/build-0/make_exports.awk
+%%DATADIR%%/build-0/make_var_export.awk
+%%DATADIR%%/build-0/mkdir.sh
+include/apr-0/apr.h
+include/apr-0/apr_allocator.h
+include/apr-0/apr_anylock.h
+include/apr-0/apr_atomic.h
+include/apr-0/apr_compat.h
+include/apr-0/apr_base64.h
+include/apr-0/apr_buckets.h
+include/apr-0/apr_date.h
+include/apr-0/apr_dbm.h
+include/apr-0/apr_dso.h
+include/apr-0/apr_env.h
+include/apr-0/apr_errno.h
+include/apr-0/apr_file_info.h
+include/apr-0/apr_file_io.h
+include/apr-0/apr_fnmatch.h
+include/apr-0/apr_general.h
+include/apr-0/apr_getopt.h
+include/apr-0/apr_global_mutex.h
+include/apr-0/apr_hash.h
+include/apr-0/apr_hooks.h
+include/apr-0/apr_inherit.h
+include/apr-0/apr_ldap_url.h
+include/apr-0/apr_ldap.h
+include/apr-0/apr_lib.h
+include/apr-0/apr_md4.h
+include/apr-0/apr_md5.h
+include/apr-0/apr_mmap.h
+include/apr-0/apr_network_io.h
+include/apr-0/apr_optional.h
+include/apr-0/apr_optional_hooks.h
+include/apr-0/apr_poll.h
+include/apr-0/apr_pools.h
+include/apr-0/apr_portable.h
+include/apr-0/apr_proc_mutex.h
+include/apr-0/apr_queue.h
+include/apr-0/apr_reslist.h
+include/apr-0/apr_ring.h
+include/apr-0/apr_rmm.h
+include/apr-0/apr_sdbm.h
+include/apr-0/apr_sha1.h
+include/apr-0/apr_shm.h
+include/apr-0/apr_signal.h
+include/apr-0/apr_strings.h
+include/apr-0/apr_strmatch.h
+include/apr-0/apr_support.h
+include/apr-0/apr_tables.h
+include/apr-0/apr_thread_cond.h
+include/apr-0/apr_thread_mutex.h
+include/apr-0/apr_thread_proc.h
+include/apr-0/apr_thread_rwlock.h
+include/apr-0/apr_time.h
+include/apr-0/apr_uri.h
+include/apr-0/apr_user.h
+include/apr-0/apr_uuid.h
+include/apr-0/apr_version.h
+include/apr-0/apr_want.h
+include/apr-0/apr_xlate.h
+include/apr-0/apr_xml.h
+include/apr-0/apu.h
+include/apr-0/apu_compat.h
+include/apr-0/apu_version.h
+include/apr-0/apu_want.h
lib/apr.exp
lib/aprutil.exp
-lib/libapr-1.a
-lib/libapr-1.la
-lib/libapr-1.so
-lib/libapr-1.so.%%SHLIB_APR_MAJOR%%
-lib/libaprutil-1.a
-lib/libaprutil-1.la
-lib/libaprutil-1.so
-lib/libaprutil-1.so.%%SHLIB_APU_MAJOR%%
-%%BDB%%lib/apr-util-1/apr_dbm_db-1.so
-%%BDB%%lib/apr-util-1/apr_dbm_db.so
-%%BDB%%lib/apr-util-1/apr_dbm_db.la
-%%BDB%%lib/apr-util-1/apr_dbm_db.a
-%%GDBM%%lib/apr-util-1/apr_dbm_gdbm-1.so
-%%GDBM%%lib/apr-util-1/apr_dbm_gdbm.so
-%%GDBM%%lib/apr-util-1/apr_dbm_gdbm.la
-%%GDBM%%lib/apr-util-1/apr_dbm_gdbm.a
-%%NDBM%%lib/apr-util-1/apr_dbm_ndbm-1.so
-%%NDBM%%lib/apr-util-1/apr_dbm_ndbm.so
-%%NDBM%%lib/apr-util-1/apr_dbm_ndbm.la
-%%NDBM%%lib/apr-util-1/apr_dbm_ndbm.a
-%%LDAP%%lib/apr-util-1/apr_ldap-1.so
-%%LDAP%%lib/apr-util-1/apr_ldap.so
-%%LDAP%%lib/apr-util-1/apr_ldap.la
-%%LDAP%%lib/apr-util-1/apr_ldap.a
-%%MYSQL%%lib/apr-util-1/apr_dbd_mysql-1.so
-%%MYSQL%%lib/apr-util-1/apr_dbd_mysql.so
-%%MYSQL%%lib/apr-util-1/apr_dbd_mysql.la
-%%MYSQL%%lib/apr-util-1/apr_dbd_mysql.a
-%%PGSQL%%lib/apr-util-1/apr_dbd_pgsql-1.so
-%%PGSQL%%lib/apr-util-1/apr_dbd_pgsql.so
-%%PGSQL%%lib/apr-util-1/apr_dbd_pgsql.la
-%%PGSQL%%lib/apr-util-1/apr_dbd_pgsql.a
-%%SQLITE3%%lib/apr-util-1/apr_dbd_sqlite3-1.so
-%%SQLITE3%%lib/apr-util-1/apr_dbd_sqlite3.so
-%%SQLITE3%%lib/apr-util-1/apr_dbd_sqlite3.la
-%%SQLITE3%%lib/apr-util-1/apr_dbd_sqlite3.a
-%%APU_EXTRAS%%@dirrm lib/apr-util-1
-@dirrm %%DATADIR%%/build-1
+lib/libapr-0.a
+lib/libapr-0.la
+lib/libapr-0.so
+lib/libapr-0.so.%%SHLIB_APR_MAJOR%%
+lib/libaprutil-0.a
+lib/libaprutil-0.la
+lib/libaprutil-0.so
+lib/libaprutil-0.so.%%SHLIB_APU_MAJOR%%
+@dirrm %%DATADIR%%/build-0
@dirrm %%DATADIR%%
-@dirrm include/apr-1
+@dirrm include/apr-0