aboutsummaryrefslogtreecommitdiffstats
path: root/devel/apr2
diff options
context:
space:
mode:
authorrodrigc <rodrigc@FreeBSD.org>2005-06-06 23:16:42 +0800
committerrodrigc <rodrigc@FreeBSD.org>2005-06-06 23:16:42 +0800
commit8a8f284c0d8dfcac6a39c4be5ca659981fa44a4d (patch)
treeb67ee0f4e28060928d4866da8e5893cddc8baa46 /devel/apr2
parent5879ac7a186d7ddba15f3269e79b3c44fa632ddb (diff)
downloadfreebsd-ports-gnome-8a8f284c0d8dfcac6a39c4be5ca659981fa44a4d.tar.gz
freebsd-ports-gnome-8a8f284c0d8dfcac6a39c4be5ca659981fa44a4d.tar.zst
freebsd-ports-gnome-8a8f284c0d8dfcac6a39c4be5ca659981fa44a4d.zip
Do not unconditionally use Python in build of apr.
PR: 80479 Submitted by: Brian Minard <bminard@flatfoot.ca> Approved by: demon (ports mentor)
Diffstat (limited to 'devel/apr2')
-rw-r--r--devel/apr2/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index 7272bb0fcdc4..823eaccd67aa 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -13,6 +13,8 @@
# (the database bindings are detected and recorded automatically if these
# switches are not set)
# APR_UTIL_WITH_LDAP: force dependency on OpenLDAP
+# WITH_PYTHON: force dependency on Python and run APR's buildconf.
+# Really only needed if built from APR's CVS depot.
PORTNAME= apr
PORTVERSION= 1.0.1
@@ -25,7 +27,12 @@ DISTFILES= apr-${PORTVERSION}.tar.gz apr-util-${PORTVERSION}.tar.gz
MAINTAINER= rodrigc@crodrigues.org
COMMENT= The Apache Group's Portability Library
+.if defined(WITH_PYTHON)
BUILD_DEPENDS= ${PYTHON_CMD}:${PYTHON_PORTSDIR}
+USE_PYTHON= yes
+PYTHON_NO_DEPENDS= yes
+.endif
+
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
USE_ICONV= yes
@@ -35,8 +42,6 @@ WANT_LIBTOOL_VER= 15
USE_REINPLACE= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_PYTHON= yes
-PYTHON_NO_DEPENDS= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}
@@ -141,12 +146,14 @@ pre-configure:
.endfor
run-autotools:
+.if defined(WITH_PYTHON)
cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} ${SH} ./buildconf
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${RM} -fr xml/expat
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./buildconf \
--with-apr=../apr-${PORTVERSION}
+.endif
cd ${WRKDIR}/apr-${PORTVERSION}; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./configure ${CONFIGURE_ARGS}
cd ${WRKDIR}/apr-util-${PORTVERSION}; \