aboutsummaryrefslogtreecommitdiffstats
path: root/devel/astah-community
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-05-12 05:06:37 +0800
committerpav <pav@FreeBSD.org>2009-05-12 05:06:37 +0800
commit3cdade8cb5115a900ed2e0abf652b760d9043b24 (patch)
tree13231325c6dd816d36e1cd3c14d3066d070e4a1c /devel/astah-community
parented57aadc0a60ed082cdf1f83386b1fc847d793e9 (diff)
downloadfreebsd-ports-gnome-3cdade8cb5115a900ed2e0abf652b760d9043b24.tar.gz
freebsd-ports-gnome-3cdade8cb5115a900ed2e0abf652b760d9043b24.tar.zst
freebsd-ports-gnome-3cdade8cb5115a900ed2e0abf652b760d9043b24.zip
- Update to 5.5
PR: ports/134241 Submitted by: Yoshihiko Sarumaru <sarumaru@jp.freebsd.org> (maintainer)
Diffstat (limited to 'devel/astah-community')
-rw-r--r--devel/astah-community/Makefile27
-rw-r--r--devel/astah-community/distinfo6
-rw-r--r--devel/astah-community/files/mozilla12
3 files changed, 20 insertions, 25 deletions
diff --git a/devel/astah-community/Makefile b/devel/astah-community/Makefile
index 5b0abc455f3e..4c40309b1cb5 100644
--- a/devel/astah-community/Makefile
+++ b/devel/astah-community/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= jude-community
-PORTVERSION= 5.4.1
+PORTVERSION= 5.5
CATEGORIES= devel java
MASTER_SITES= # you have to register yourself as a member to download
DISTNAME= ${PORTNAME}-${PORTVERSION:S!.!_!g}
@@ -16,21 +16,13 @@ COMMENT= A Java/UML Object-Oriented Design Tool
USE_ZIP= yes
-# Export HTML function can be used with JDK 1.4 only.
-# (But it can work with JDK 1.5 + copying JDK 1.4 tools.jar to ${DATADIR})
-OPTIONS= EXPORT_HTML "Enable Exporting HTML function (needs JDK1.4)" Off
-
.include <bsd.port.pre.mk>
-# In case you are going to use JDK1.5+ in Japanese environment, make sure
+# In case you are going to use JDK1.5 in Japanese environment, make sure
# you have prepared following command to avoid from font problem:
# ln -s ${LOCALBASE}/lib/X11/fonts/TrueType \
# ${LOCALBASE}/diablo-jdk1.5.0/jre/lib/fonts/fallback
-.if defined(WITH_EXPORT_HTML)
-JAVA_VERSION= 1.4
-.else
-JAVA_VERSION= 1.4+
-.endif
+JAVA_VERSION= 1.5+
USE_JAVA= yes
JAVA_OS= native
@@ -54,15 +46,14 @@ PLIST_FILES= bin/jude
PORTDATA= ${PORTNAME}.jar jude-api.jar jude-gui_en.properties_org \
jude.ico jude-doc.ico Welcome.jude Welcome_ja.jude \
template \
- mozilla
-.endif
-.if defined(WITH_EXPORT_HTML)
-PORTDATA+= tools.jar
+ mozilla \
+ tools.jar
.endif
.if !defined(NOPORTDOCS)
PORTDOCS= ReleaseNote-e.html ReleaseNote.html \
ProductInformation.txt \
+ README-e.txt README.txt \
API_sample_program_license_agreement-e.txt \
API_sample_program_license_agreement.txt
.endif
@@ -78,13 +69,11 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/jude ${PREFIX}/bin
.if !defined(NOPORTDATA)
${MKDIR} ${DATADIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA:Nmozilla}" ${DATADIR})
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA:Nmozilla:Ntools.jar}" ${DATADIR})
${INSTALL_SCRIPT} ${FILESDIR}/mozilla ${DATADIR}
-.if defined(WITH_EXPORT_HTML)
- # ExportHTML needs lib/tools.jar of JDK1.4
+ # ExportHTML needs lib/tools.jar of JDK1.5/1.6
${LN} -s ${JAVA_HOME}/lib/tools.jar ${DATADIR}
.endif
-.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for docfile in ${PORTDOCS}
diff --git a/devel/astah-community/distinfo b/devel/astah-community/distinfo
index 6ee9eaefba32..77bc182d0fce 100644
--- a/devel/astah-community/distinfo
+++ b/devel/astah-community/distinfo
@@ -1,3 +1,3 @@
-MD5 (jude-community-5_4_1.zip) = 2bd4b56d0a73105eaed12363856abb3e
-SHA256 (jude-community-5_4_1.zip) = dcb3890a53d27b363b2e310db7819889b332319ea460f8e53dce42575bd0274e
-SIZE (jude-community-5_4_1.zip) = 10246359
+MD5 (jude-community-5_5.zip) = 90549e57d30ff0e818b8bdd8475ab8dc
+SHA256 (jude-community-5_5.zip) = 5f3dba918dbf055c40ff82c0d47844765d6c3e566e2fa6fa15a1138d88b53c4f
+SIZE (jude-community-5_5.zip) = 9520770
diff --git a/devel/astah-community/files/mozilla b/devel/astah-community/files/mozilla
index 3d89ee859656..114bd4f0d7eb 100644
--- a/devel/astah-community/files/mozilla
+++ b/devel/astah-community/files/mozilla
@@ -1,10 +1,16 @@
#!/bin/sh
-# eliminate own path from PATH (without this, cause a inifinite loop)
+# eliminate own path from PATH (without this, may cause a inifinite loop)
PATH=${PATH#$(dirname $0)}
-# add your favorite browser in the top of the list
-for browser in mozilla linux-mozilla firefox3 firefox linux-firefox firebird opera linux-opera
+# set your favorite browser to JUDE_BROWSER environmental variable
+for browser in \
+${JUDE_BROWSER} \
+firefox-devel linux-firefox-devel \
+firefox3 \
+firefox linux-firefox \
+seamonkey-devel linux-seamonkey-devel seamonkey linux-seamonkey \
+opera-devel opera linux-opera
do
type $browser > /dev/null 2>&1 && exec $browser "$@"
done