aboutsummaryrefslogtreecommitdiffstats
path: root/devel/astah-community
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-05-09 21:01:54 +0800
committertota <tota@FreeBSD.org>2011-05-09 21:01:54 +0800
commit8f4a4ae024fb1c3f8846d440d3de8d77423d5809 (patch)
tree9c4ca53fdedd0d3a5e4037c041d576912d06acbc /devel/astah-community
parent7bf111e18ad9d696b46fb75cf9fa78c0dd94c869 (diff)
downloadfreebsd-ports-gnome-8f4a4ae024fb1c3f8846d440d3de8d77423d5809.tar.gz
freebsd-ports-gnome-8f4a4ae024fb1c3f8846d440d3de8d77423d5809.tar.zst
freebsd-ports-gnome-8f4a4ae024fb1c3f8846d440d3de8d77423d5809.zip
- Rename devel/jude-community to devel/astah-community
- Update to 6.4 - Take maintainership PR: ports/156740 Submitted by: tota (myself) Approved by: Yoshihiko Sarumaru <sarumaru@jp.FreeBSD.org> (maintainer)
Diffstat (limited to 'devel/astah-community')
-rw-r--r--devel/astah-community/Makefile60
-rw-r--r--devel/astah-community/distinfo5
-rw-r--r--devel/astah-community/files/mozilla16
-rw-r--r--devel/astah-community/files/patch-astah20
-rw-r--r--devel/astah-community/files/patch-jude20
-rw-r--r--devel/astah-community/pkg-descr36
6 files changed, 65 insertions, 92 deletions
diff --git a/devel/astah-community/Makefile b/devel/astah-community/Makefile
index dfeea6042b7d..34310a6abb86 100644
--- a/devel/astah-community/Makefile
+++ b/devel/astah-community/Makefile
@@ -5,74 +5,66 @@
# $FreeBSD$
#
-PORTNAME= jude-community
-PORTVERSION= 5.5.2
+PORTNAME= astah
+PORTVERSION= 6.4
CATEGORIES= devel java
-MASTER_SITES= # you have to register yourself as a member to download
-DISTNAME= ${PORTNAME}-${PORTVERSION:S!.!_!g}
+MASTER_SITES= #
+PKGNAMESUFFIX= -community
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION:S!.!_!g}
-MAINTAINER= sarumaru@jp.FreeBSD.org
+MAINTAINER= tota@FreeBSD.org
COMMENT= A Java/UML Object-Oriented Design Tool
USE_ZIP= yes
.include <bsd.port.pre.mk>
-# In case you are going to use JDK1.5 in Japanese environment, make sure
-# you have prepared following command to avoid from font problem:
-# ln -s ${LOCALBASE}/lib/X11/fonts/TrueType \
-# ${LOCALBASE}/diablo-jdk1.5.0/jre/lib/fonts/fallback
-JAVA_VERSION= 1.5+
+JAVA_VERSION= 1.6+
USE_JAVA= yes
-JAVA_OS= native
+JAVA_OS= linux
NO_BUILD= yes
-.include "${PORTSDIR}/Mk/bsd.java.mk"
-
-RESTRICTED= See http://jude.change-vision.com/jude-web/notes/ProductLicenseAgreement.html
-WRKSRC= ${WRKDIR}/${PORTNAME:S!-!_!}
+RESTRICTED= See http://astah.change-vision.com/en/product/astah-eula.html
+WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX:S!-!_!}
REINPLACE_ARGS= -i ""
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-DOWNLOAD_URL= http://jude.change-vision.com/jude-web/download/index.html
+.if !exists(${DISTDIR}/${DISTFILES})
+DOWNLOAD_URL= http://members.change-vision.com/files/${PORTNAME}${PKGNAMESUFFIX:S!-!_!}/${PORTVERSION:S!.!_!}/${DISTFILES}
IGNORE= needs you to fetch manually the distribution file\
from ${DOWNLOAD_URL}, \
then place it in ${DISTDIR} and run make again
.endif
-PLIST_FILES= bin/jude
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
+
+PLIST_FILES= bin/astah
.if !defined(NOPORTDATA)
-PORTDATA= ${PORTNAME}.jar jude-api.jar jude-gui_en.properties_org \
- jude.ico jude-doc.ico Welcome.jude Welcome_ja.jude \
- template \
- mozilla \
- tools.jar
+PORTDATA= astah-community.jar astah-api.jar astah-gui_en.properties_org \
+ astah.ico astah-doc.ico Welcome.asta Welcome_ja.asta \
+ template
.endif
.if !defined(NOPORTDOCS)
PORTDOCS= ReleaseNote-e.html ReleaseNote.html \
ProductInformation.txt \
- README-e.txt README.txt \
API_sample_program_license_agreement-e.txt \
API_sample_program_license_agreement.txt
.endif
post-patch:
- ${REINPLACE_CMD} -e "s!%%JAVA_HOME%%!${JAVA_HOME}!; \
- s!%%DATADIR%%!${DATADIR}!" ${WRKSRC}/jude
+ ${REINPLACE_CMD} -e "s!%%JAVA_HOME%%!${JAVA_HOME}!g; \
+ s!%%DATADIR%%!${DATADIR}!" ${WRKSRC}/astah
.if !defined(NOPORTDOCS)
- ${REINPLACE_CMD} 's/png\\/png\//' ${WRKSRC}/api/*/doc/JudeAPI_reference.html
+ ${REINPLACE_CMD} 's/png\\/png\//' ${WRKSRC}/api/*/doc/astahAPI_reference.html
.endif
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/jude ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/astah ${PREFIX}/bin
.if !defined(NOPORTDATA)
${MKDIR} ${DATADIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA:Nmozilla:Ntools.jar}" ${DATADIR})
- ${INSTALL_SCRIPT} ${FILESDIR}/mozilla ${DATADIR}
- # ExportHTML needs lib/tools.jar of JDK1.5/1.6
- ${LN} -s ${JAVA_HOME}/lib/tools.jar ${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${DATADIR})
.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@@ -81,9 +73,9 @@ do-install:
.endfor
${MKDIR} ${DOCSDIR}/api
(cd ${WRKSRC}/api && ${COPYTREE_SHARE} \* ${DOCSDIR}/api)
- @ cd ${PREFIX} && ${FIND} share/doc/${PORTNAME}/api -type f -print | \
+ @ cd ${PREFIX} && ${FIND} share/doc/${PORTNAME}${PKGNAMESUFFIX}/api -type f -print | \
${SORT} -r >> ${TMPPLIST}
- @ cd ${PREFIX} && ${FIND} share/doc/${PORTNAME}/api -type d -print | \
+ @ cd ${PREFIX} && ${FIND} share/doc/${PORTNAME}${PKGNAMESUFFIX}/api -type d -print | \
${SORT} -r | ${SED} -e 's#^#@dirrm #' >> ${TMPPLIST}
.endif
diff --git a/devel/astah-community/distinfo b/devel/astah-community/distinfo
index 988f7477b405..c2dcb827aa25 100644
--- a/devel/astah-community/distinfo
+++ b/devel/astah-community/distinfo
@@ -1,3 +1,2 @@
-MD5 (jude-community-5_5_2.zip) = e638e744731e999c711c13418d31a70c
-SHA256 (jude-community-5_5_2.zip) = e59e5f4aa17229abe92c7bcf8e206c2648c2ba621f56352d0862c378191aae7f
-SIZE (jude-community-5_5_2.zip) = 9535791
+SHA256 (astah-community-6_4.zip) = 26814a7110b2ffe6daa30eeb491f390b7a805810669888c458e678be707d5123
+SIZE (astah-community-6_4.zip) = 20180980
diff --git a/devel/astah-community/files/mozilla b/devel/astah-community/files/mozilla
deleted file mode 100644
index 114bd4f0d7eb..000000000000
--- a/devel/astah-community/files/mozilla
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-# eliminate own path from PATH (without this, may cause a inifinite loop)
-PATH=${PATH#$(dirname $0)}
-
-# set your favorite browser to JUDE_BROWSER environmental variable
-for browser in \
-${JUDE_BROWSER} \
-firefox-devel linux-firefox-devel \
-firefox3 \
-firefox linux-firefox \
-seamonkey-devel linux-seamonkey-devel seamonkey linux-seamonkey \
-opera-devel opera linux-opera
-do
- type $browser > /dev/null 2>&1 && exec $browser "$@"
-done
diff --git a/devel/astah-community/files/patch-astah b/devel/astah-community/files/patch-astah
new file mode 100644
index 000000000000..9d3976b7d1ea
--- /dev/null
+++ b/devel/astah-community/files/patch-astah
@@ -0,0 +1,20 @@
+--- astah.orig 2011-03-29 13:25:03.000000000 +0900
++++ astah 2011-04-30 20:22:19.000000000 +0900
+@@ -3,13 +3,14 @@
+ #Remove "#" from following two lines, if you'd like to use j2sdk.
+ #JAVA_HOME=/usr/lib/j2sdk1.4/;export JAVA_HOME
+ #PATH=$JAVA_HOME/bin:$PATH; export PATH
++PATH=%%DATADIR%%:$PATH
+
+-#ASTAH_HOME=/usr/local/share/astah_community
+-ASTAH_HOME=`dirname $0`
++ASTAH_HOME=%%DATADIR%%
++#ASTAH_HOME=`dirname $0`
+ ASTAH_JAR=astah-community.jar
+
+ CLASSPATH=$ASTAH_HOME/$ASTAH_JAR
+
+ JAVA_OPTS="-Xms16m -Xmx384m"
+
+-java $JAVA_OPTS -jar $ASTAH_HOME/$ASTAH_JAR $1 $2 $3
++LD_LIBRARY_PATH=%%JAVA_HOME%%/jre/lib/i386/jli %%JAVA_HOME%%/bin/java $JAVA_OPTS -jar $ASTAH_HOME/$ASTAH_JAR $1 $2 $3
diff --git a/devel/astah-community/files/patch-jude b/devel/astah-community/files/patch-jude
deleted file mode 100644
index c0bae388278b..000000000000
--- a/devel/astah-community/files/patch-jude
+++ /dev/null
@@ -1,20 +0,0 @@
---- jude.orig Tue Oct 26 21:21:53 2004
-+++ jude Tue Nov 9 13:58:28 2004
-@@ -3,13 +3,14 @@
- #Remove "#" from following two lines, if you'd like to use j2sdk.
- #JAVA_HOME=/usr/lib/j2sdk1.4/;export JAVA_HOME
- #PATH=$JAVA_HOME/bin:$PATH; export PATH
-+PATH=%%DATADIR%%:$PATH
-
--#JUDE_HOME=/usr/local/share/jude_community
--JUDE_HOME=`dirname $0`
-+JUDE_HOME=%%DATADIR%%
-+#JUDE_HOME=`dirname $0`
- JUDE_JAR=jude-community.jar
-
- CLASSPATH=$JUDE_HOME/$JUDE_JAR
-
- JAVA_OPTS="-Xms16m -Xmx512m -Xss2m"
-
--java $JAVA_OPTS -jar $JUDE_HOME/$JUDE_JAR $1 $2 $3
-+%%JAVA_HOME%%/bin/java $JAVA_OPTS -jar $JUDE_HOME/$JUDE_JAR $1 $2 $3
diff --git a/devel/astah-community/pkg-descr b/devel/astah-community/pkg-descr
index bbc51762f0a1..1ae693d42ebe 100644
--- a/devel/astah-community/pkg-descr
+++ b/devel/astah-community/pkg-descr
@@ -1,21 +1,19 @@
-JUDE/Community is the free edition with basic features.
-It is rich in functionality, offering features, such as editing and printing
-UML1.4 diagrams, import/export of Java source code, graphics output, and
-auto layout. (A restriction is that the JUDE logo always appears in the header
-of printed documents.)
+astah* community is a simple and user-friendly UML modeling tool.
-Basic Features
-JUDE supports the following basic UML 1.4 diagrams:
-- Class (Object, Package, Robustness)
-- Usecase
-- Sequence
-- Collaboration
-- Statechart
-- Activity
-- Component
-- Deployment
-- Template Generation of Java Source Files
-- Import of Java Source Files
-- Automatic Generation of Class Diagrams with Model Information
+astah* community features:
+- UML 2.x (Class, UseCase, Sequence, Activity, Communication, Statemachine,
+ Component, Deployment, Composite Structure, Object and Package Diagrams)
+- Suggest Feature
+- Alignment Guide
+- Customizing Keybinds
+- Oval, TextBox, Filled Rectangle, Corner-rounded Rectangle and Texts
+- Alignment, Size adjustment
+- Print
+- Export diagram images (PNG, JPEG) *1
+- astah* API (Models of Class, UseCase, Activity, Sequence and Statemachine
+ Diagrames)
+- GUI Localization
-WWW: http://jude.change-vision.com/jude-web/index.html
+*1 The product name is displayed on the corner.
+
+WWW: http://astah.change-vision.com/en/product/astah-community.html