aboutsummaryrefslogtreecommitdiffstats
path: root/devel/astyle
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-08 04:36:56 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-08 04:36:56 +0800
commitb9d96f0bddafec7d1d853fb10a676282bf117fd3 (patch)
treec09daa85de93050de125dec6004d90281a22b5b0 /devel/astyle
parentf743e860666b70d1983dbd6d47f4a17b98a65af7 (diff)
downloadfreebsd-ports-gnome-b9d96f0bddafec7d1d853fb10a676282bf117fd3.tar.gz
freebsd-ports-gnome-b9d96f0bddafec7d1d853fb10a676282bf117fd3.tar.zst
freebsd-ports-gnome-b9d96f0bddafec7d1d853fb10a676282bf117fd3.zip
- Fix the command line option parser [1]
- Fix the packing list when NOPORTDOCS is defined - Polish the Makefile PR: ports/80666 [1] Submitted by: Alex Rousskov <rousskov@measurement-factory.com> [1]
Diffstat (limited to 'devel/astyle')
-rw-r--r--devel/astyle/Makefile7
-rw-r--r--devel/astyle/files/patch-astyle__main.cpp20
2 files changed, 24 insertions, 3 deletions
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index dd3a3cfc1b88..14cdf61f2891 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -7,6 +7,7 @@
PORTNAME= astyle
PORTVERSION= 1.15.3
+PORTREVISION= 1
CATEGORIES= devel textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,9 +24,9 @@ ALL_TARGET= astyle
MAKE_ARGS= CPPFLAGS="${CXXFLAGS}"
PLIST_FILES= bin/astyle
+.if !defined(NOPORTDOCS)
PORTDOCS= astyle.html astyle_release_notes.html license.html
-
-.include <bsd.port.pre.mk>
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/astyle ${PREFIX}/bin
@@ -34,4 +35,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/*.html ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/astyle/files/patch-astyle__main.cpp b/devel/astyle/files/patch-astyle__main.cpp
new file mode 100644
index 000000000000..6d399204ecfb
--- /dev/null
+++ b/devel/astyle/files/patch-astyle__main.cpp
@@ -0,0 +1,20 @@
+--- astyle_main.cpp.orig Thu Mar 7 08:22:30 2002
++++ astyle_main.cpp Sat May 7 22:31:21 2005
+@@ -267,7 +267,7 @@
+ {
+ manuallySetJavaStyle(formatter);
+ }
+- else if ( IS_OPTIONS(arg, "t", "indent=tab=") )
++ else if ( IS_PARAM_OPTIONS(arg, "t", "indent=tab=") )
+ {
+ int spaceNum = 4;
+ string spaceNumParam = GET_PARAMS(arg, "t", "indent=tab=");
+@@ -275,7 +275,7 @@
+ spaceNum = atoi(spaceNumParam.c_str());
+ formatter.setTabIndentation(spaceNum, false);
+ }
+- else if ( IS_OPTIONS(arg, "T", "force-indent=tab=") )
++ else if ( IS_PARAM_OPTIONS(arg, "T", "force-indent=tab=") )
+ {
+ int spaceNum = 4;
+ string spaceNumParam = GET_PARAMS(arg, "T", "force-indent=tab=");