aboutsummaryrefslogtreecommitdiffstats
path: root/devel/atlas-devel/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2003-07-08 20:50:26 +0800
committeroliver <oliver@FreeBSD.org>2003-07-08 20:50:26 +0800
commit3776700e31be1460d5e9cf48432003b4256b12b2 (patch)
tree175bc02e23deca40930885ab837892d377fef186 /devel/atlas-devel/Makefile
parent46ba62c8b06f003610f68d97c73abb0b2b44c0b9 (diff)
downloadfreebsd-ports-gnome-3776700e31be1460d5e9cf48432003b4256b12b2.tar.gz
freebsd-ports-gnome-3776700e31be1460d5e9cf48432003b4256b12b2.tar.zst
freebsd-ports-gnome-3776700e31be1460d5e9cf48432003b4256b12b2.zip
update Atlas to 0.4.6
Diffstat (limited to 'devel/atlas-devel/Makefile')
-rw-r--r--devel/atlas-devel/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/devel/atlas-devel/Makefile b/devel/atlas-devel/Makefile
index 8f3e8b144bda..45d75305b190 100644
--- a/devel/atlas-devel/Makefile
+++ b/devel/atlas-devel/Makefile
@@ -6,16 +6,29 @@
#
PORTNAME= Atlas
-PORTVERSION= 0.4.4
+PORTVERSION= 0.4.6
CATEGORIES= devel
MASTER_SITES= ftp://victor.worldforge.org/pub/worldforge/libs/Atlas-C++/ \
ftp://ftp.ecs.soton.ac.uk/pub/worldforge/libs/Atlas-C++/
DISTNAME= ${PORTNAME}-C++-${PORTVERSION}
-MAINTAINER= oliver@freebsd.org
+MAINTAINER= oliver@FreeBSD.org
COMMENT= A C++ reference implementation of the Atlas protocol
+USE_REINPLACE= YES
USE_LIBTOOL= YES
GNU_CONFIGURE= YES
+post-patch:
+ @${REINPLACE_CMD} -e 's| install-data-local||g' \
+ -e 's|\(^pkgconfigdir =\) .*|\1 ${PREFIX}/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in README COPYING AUTHORS THANKS NEWS
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
.include <bsd.port.mk>